summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-12-25 11:19:31 +0100
committerRemi Collet <fedora@famillecollet.com>2016-12-25 11:19:31 +0100
commitd1bf191ba62d1552fb2cbe43d9f9c1f0cce1f358 (patch)
tree1f493ca069ead0f9c5030f08fb6ee1643be6c9b0
parent0dd2a5d4c4424b9401176a4bc2dacd1c972dfdfe (diff)
php-phalcon3: 3.0.3
-rw-r--r--REFLECTION98
-rw-r--r--php-phalcon3.spec8
2 files changed, 55 insertions, 51 deletions
diff --git a/REFLECTION b/REFLECTION
index 6fd3cc7..c708e90 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #157 phalcon version 3.0.2 ] {
+Extension [ <persistent> extension #160 phalcon version 3.0.3 ] {
- INI {
Entry [ phalcon.db.escape_identifiers <ALL> ]
@@ -2307,6 +2307,40 @@ Extension [ <persistent> extension #157 phalcon version 3.0.2 ] {
}
}
+ Interface [ <internal:phalcon> interface Phalcon\Mvc\Collection\BehaviorInterface ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [2] {
+ Method [ <internal:phalcon> abstract public method notify ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $type ]
+ Parameter #1 [ <required> Phalcon\Mvc\CollectionInterface $collection ]
+ }
+ }
+
+ Method [ <internal:phalcon> abstract public method missingMethod ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> Phalcon\Mvc\CollectionInterface $collection ]
+ Parameter #1 [ <required> $method ]
+ Parameter #2 [ <optional> $arguments ]
+ }
+ }
+ }
+ }
+
Interface [ <internal:phalcon> interface Phalcon\Mvc\Model\BehaviorInterface ] {
- Constants [0] {
@@ -2588,40 +2622,6 @@ Extension [ <persistent> extension #157 phalcon version 3.0.2 ] {
}
}
- Interface [ <internal:phalcon> interface Phalcon\Mvc\Collection\BehaviorInterface ] {
-
- - Constants [0] {
- }
-
- - Static properties [0] {
- }
-
- - Static methods [0] {
- }
-
- - Properties [0] {
- }
-
- - Methods [2] {
- Method [ <internal:phalcon> abstract public method notify ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> $type ]
- Parameter #1 [ <required> Phalcon\Mvc\CollectionInterface $collection ]
- }
- }
-
- Method [ <internal:phalcon> abstract public method missingMethod ] {
-
- - Parameters [3] {
- Parameter #0 [ <required> Phalcon\Mvc\CollectionInterface $collection ]
- Parameter #1 [ <required> $method ]
- Parameter #2 [ <optional> $arguments ]
- }
- }
- }
- }
-
Interface [ <internal:phalcon> interface Phalcon\Mvc\Model\MetaData\StrategyInterface ] {
- Constants [0] {
@@ -11127,7 +11127,7 @@ Extension [ <persistent> extension #157 phalcon version 3.0.2 ] {
}
}
- Class [ <internal:phalcon> abstract class Phalcon\Mvc\Collection\Behavior ] {
+ Class [ <internal:phalcon> abstract class Phalcon\Mvc\Collection\Behavior implements Phalcon\Mvc\Collection\BehaviorInterface ] {
- Constants [0] {
}
@@ -11164,7 +11164,7 @@ Extension [ <persistent> extension #157 phalcon version 3.0.2 ] {
}
}
- Method [ <internal:phalcon> public method notify ] {
+ Method [ <internal:phalcon, prototype Phalcon\Mvc\Collection\BehaviorInterface> public method notify ] {
- Parameters [2] {
Parameter #0 [ <required> $type ]
@@ -11172,7 +11172,7 @@ Extension [ <persistent> extension #157 phalcon version 3.0.2 ] {
}
}
- Method [ <internal:phalcon> public method missingMethod ] {
+ Method [ <internal:phalcon, prototype Phalcon\Mvc\Collection\BehaviorInterface> public method missingMethod ] {
- Parameters [3] {
Parameter #0 [ <required> Phalcon\Mvc\CollectionInterface $model ]
@@ -25351,7 +25351,7 @@ Extension [ <persistent> extension #157 phalcon version 3.0.2 ] {
Method [ <internal:phalcon> public method create ] {
- Parameters [2] {
- Parameter #0 [ <optional> $name ]
+ Parameter #0 [ <required> $name ]
Parameter #1 [ <optional> $entity ]
}
}
@@ -25876,14 +25876,6 @@ Extension [ <persistent> extension #157 phalcon version 3.0.2 ] {
Method [ <internal:phalcon, prototype Phalcon\Http\RequestInterface> public method getHTTPReferer ] {
}
- Method [ <internal:phalcon> final protected method _getQualityHeader ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> $serverIndex ]
- Parameter #1 [ <required> $name ]
- }
- }
-
Method [ <internal:phalcon> final protected method _getBestQuality ] {
- Parameters [2] {
@@ -25918,6 +25910,14 @@ Extension [ <persistent> extension #157 phalcon version 3.0.2 ] {
Method [ <internal:phalcon, prototype Phalcon\Http\RequestInterface> public method getDigestAuth ] {
}
+
+ Method [ <internal:phalcon> final protected method _getQualityHeader ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $serverIndex ]
+ Parameter #1 [ <required> $name ]
+ }
+ }
}
}
@@ -31062,7 +31062,7 @@ Extension [ <persistent> extension #157 phalcon version 3.0.2 ] {
}
}
- Method [ <internal:phalcon> public method order ] {
+ Method [ <internal, deprecated:phalcon> public method order ] {
- Parameters [1] {
Parameter #0 [ <required> $orderColumns ]
@@ -34515,7 +34515,7 @@ Extension [ <persistent> extension #157 phalcon version 3.0.2 ] {
Method [ <internal:phalcon, prototype Phalcon\Mvc\Model\Query\BuilderInterface> public method limit ] {
- Parameters [2] {
- Parameter #0 [ <optional> $limit ]
+ Parameter #0 [ <required> $limit ]
Parameter #1 [ <optional> $offset ]
}
}
diff --git a/php-phalcon3.spec b/php-phalcon3.spec
index 0585307..2d788c6 100644
--- a/php-phalcon3.spec
+++ b/php-phalcon3.spec
@@ -13,7 +13,7 @@
%global pkg_name %{name}
%endif
-%global gh_commit 877266877c88a0e3fcccd1a232b9537e73a641ad
+%global gh_commit 74ffe4e9794389d533e430161375736226d85e06
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner phalcon
%global gh_project cphalcon
@@ -29,7 +29,7 @@
%endif
Name: %{?sub_prefix}php-phalcon3
-Version: 3.0.2
+Version: 3.0.3
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Summary: Phalcon Framework
@@ -55,6 +55,7 @@ BuildRequires: %{?scl_prefix}php-gd
BuildRequires: %{?scl_prefix}php-libsodium
BuildRequires: %{?scl_prefix}php-mbstring
BuildRequires: %{?scl_prefix}php-msgpack
+BuildRequires: %{?scl_prefix}php-imagick
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
@@ -245,6 +246,9 @@ rm -rf %{buildroot}
%changelog
+* Sun Dec 25 2016 Remi Collet <remi@fedoraproject.org> - 3.0.3-1
+- update to 3.0.3
+
* Sun Nov 27 2016 Remi Collet <remi@fedoraproject.org> - 3.0.2-1
- update to 3.0.2