summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2017-03-23 13:18:18 +0100
committerRemi Collet <fedora@famillecollet.com>2017-03-23 13:18:18 +0100
commitb5d9c75c7064303e24b9704e1dd8f86c083fe9f7 (patch)
tree577f9ffce6775306deeca8b263fe2246267821b9
parent78ad98e8eead2b685e688ae8ea823ec18b5ede63 (diff)
v3.1.0
-rw-r--r--.gitignore3
-rw-r--r--REFLECTION455
-rw-r--r--php-phalcon3.spec7
3 files changed, 438 insertions, 27 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..af9f2ef
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+*.tar.xz
+*.tar.gz
+*.src.rpm
diff --git a/REFLECTION b/REFLECTION
index b0bd7b3..3c9924e 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #170 phalcon version 3.0.4 ] {
+Extension [ <persistent> extension #171 phalcon version 3.1.0 ] {
- INI {
Entry [ phalcon.db.escape_identifiers <ALL> ]
@@ -39,7 +39,7 @@ Extension [ <persistent> extension #170 phalcon version 3.0.4 ] {
}
}
- - Classes [371] {
+ - Classes [376] {
Interface [ <internal:phalcon> interface Phalcon\Di\InjectionAwareInterface ] {
- Constants [0] {
@@ -4322,7 +4322,7 @@ Extension [ <persistent> extension #170 phalcon version 3.0.4 ] {
- Properties [0] {
}
- - Methods [13] {
+ - Methods [15] {
Method [ <internal:phalcon> abstract public method setId ] {
- Parameters [1] {
@@ -4349,6 +4349,16 @@ Extension [ <persistent> extension #170 phalcon version 3.0.4 ] {
Method [ <internal:phalcon> abstract public method getConnection ] {
}
+ Method [ <internal:phalcon> abstract public method setDirtyState ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $dirtyState ]
+ }
+ }
+
+ Method [ <internal:phalcon> abstract public method getDirtyState ] {
+ }
+
Method [ <internal:phalcon> abstract public method fireEvent ] {
- Parameters [1] {
@@ -4921,6 +4931,46 @@ Extension [ <persistent> extension #170 phalcon version 3.0.4 ] {
}
}
+ Interface [ <internal:phalcon> interface Phalcon\Mvc\Model\BinderInterface ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [4] {
+ Method [ <internal:phalcon> abstract public method getBoundModels ] {
+ }
+
+ Method [ <internal:phalcon> abstract public method getCache ] {
+ }
+
+ Method [ <internal:phalcon> abstract public method setCache ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> Phalcon\Cache\BackendInterface $cache ]
+ }
+ }
+
+ Method [ <internal:phalcon> abstract public method bindToHandler ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $handler ]
+ Parameter #1 [ <required> array $params ]
+ Parameter #2 [ <required> $cacheKey ]
+ Parameter #3 [ <optional> $methodName ]
+ }
+ }
+ }
+ }
+
Interface [ <internal:phalcon> interface Phalcon\Mvc\Model\CriteriaInterface ] {
- Constants [0] {
@@ -6996,6 +7046,26 @@ Extension [ <persistent> extension #170 phalcon version 3.0.4 ] {
}
}
+ Interface [ <internal:phalcon> interface Phalcon\Mvc\Model\Binder\BindableInterface ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [1] {
+ Method [ <internal:phalcon> abstract public method getModelName ] {
+ }
+ }
+ }
+
Interface [ <internal:phalcon> interface Phalcon\Mvc\ModuleDefinitionInterface ] {
- Constants [0] {
@@ -10636,7 +10706,7 @@ Extension [ <persistent> extension #170 phalcon version 3.0.4 ] {
- Static methods [0] {
}
- - Properties [21] {
+ - Properties [22] {
Property [ <default> protected $_dependencyInjector ]
Property [ <default> protected $_eventsManager ]
Property [ <default> protected $_activeHandler ]
@@ -10658,9 +10728,10 @@ Extension [ <persistent> extension #170 phalcon version 3.0.4 ] {
Property [ <default> protected $_previousHandlerName ]
Property [ <default> protected $_previousActionName ]
Property [ <default> protected $_modelBinding ]
+ Property [ <default> protected $_modelBinder ]
}
- - Methods [32] {
+ - Methods [35] {
Method [ <internal:phalcon, prototype Phalcon\Di\InjectionAwareInterface> public method setDI ] {
- Parameters [1] {
@@ -10790,11 +10861,23 @@ Extension [ <persistent> extension #170 phalcon version 3.0.4 ] {
Method [ <internal:phalcon> public method setModelBinding ] {
- - Parameters [1] {
+ - Parameters [2] {
Parameter #0 [ <required> $value ]
+ Parameter #1 [ <optional> $cache ]
}
}
+ Method [ <internal:phalcon> public method setModelBinder ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> Phalcon\Mvc\Model\BinderInterface $modelBinder ]
+ Parameter #1 [ <optional> $cache ]
+ }
+ }
+
+ Method [ <internal:phalcon> public method getModelBinder ] {
+ }
+
Method [ <internal:phalcon, prototype Phalcon\DispatcherInterface> public method dispatch ] {
}
@@ -10823,6 +10906,9 @@ Extension [ <persistent> extension #170 phalcon version 3.0.4 ] {
}
}
+ Method [ <internal:phalcon> public method getBoundModels ] {
+ }
+
Method [ <internal:phalcon> protected method _resolveEmptyProperties ] {
}
}
@@ -16000,7 +16086,7 @@ Extension [ <persistent> extension #170 phalcon version 3.0.4 ] {
- Static methods [0] {
}
- - Properties [22] {
+ - Properties [23] {
Property [ <default> protected $_dependencyInjector ]
Property [ <default> protected $_eventsManager ]
Property [ <default> protected $_activeHandler ]
@@ -16019,13 +16105,14 @@ Extension [ <persistent> extension #170 phalcon version 3.0.4 ] {
Property [ <default> protected $_previousHandlerName ]
Property [ <default> protected $_previousActionName ]
Property [ <default> protected $_modelBinding ]
+ Property [ <default> protected $_modelBinder ]
Property [ <default> protected $_handlerSuffix ]
Property [ <default> protected $_defaultHandler ]
Property [ <default> protected $_defaultAction ]
Property [ <default> protected $_options ]
}
- - Methods [42] {
+ - Methods [45] {
Method [ <internal:phalcon, prototype Phalcon\Cli\DispatcherInterface> public method setTaskSuffix ] {
- Parameters [1] {
@@ -16219,11 +16306,23 @@ Extension [ <persistent> extension #170 phalcon version 3.0.4 ] {
Method [ <internal:phalcon, inherits Phalcon\Dispatcher> public method setModelBinding ] {
- - Parameters [1] {
+ - Parameters [2] {
Parameter #0 [ <required> $value ]
+ Parameter #1 [ <optional> $cache ]
}
}
+ Method [ <internal:phalcon, inherits Phalcon\Dispatcher> public method setModelBinder ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> Phalcon\Mvc\Model\BinderInterface $modelBinder ]
+ Parameter #1 [ <optional> $cache ]
+ }
+ }
+
+ Method [ <internal:phalcon, inherits Phalcon\Dispatcher> public method getModelBinder ] {
+ }
+
Method [ <internal:phalcon, inherits Phalcon\Dispatcher, prototype Phalcon\DispatcherInterface> public method dispatch ] {
}
@@ -16243,6 +16342,9 @@ Extension [ <persistent> extension #170 phalcon version 3.0.4 ] {
Method [ <internal:phalcon, inherits Phalcon\Dispatcher> public method getHandlerClass ] {
}
+ Method [ <internal:phalcon, inherits Phalcon\Dispatcher> public method getBoundModels ] {
+ }
+
Method [ <internal:phalcon, inherits Phalcon\Dispatcher> protected method _resolveEmptyProperties ] {
}
}
@@ -19022,7 +19124,7 @@ Extension [ <persistent> extension #170 phalcon version 3.0.4 ] {
Property [ <default> protected $_escapeChar ]
}
- - Methods [61] {
+ - Methods [62] {
Method [ <internal:phalcon, overwrites Phalcon\Db\DialectInterface, prototype Phalcon\Db\DialectInterface> public method getColumnDefinition ] {
- Parameters [1] {
@@ -19120,6 +19222,14 @@ Extension [ <persistent> extension #170 phalcon version 3.0.4 ] {
}
}
+ Method [ <internal:phalcon> public method truncateTable ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $tableName ]
+ Parameter #1 [ <required> $schemaName ]
+ }
+ }
+
Method [ <internal:phalcon, overwrites Phalcon\Db\DialectInterface, prototype Phalcon\Db\DialectInterface> public method dropTable ] {
- Parameters [3] {
@@ -19539,7 +19649,7 @@ Extension [ <persistent> extension #170 phalcon version 3.0.4 ] {
Property [ <default> protected $_escapeChar ]
}
- - Methods [62] {
+ - Methods [63] {
Method [ <internal:phalcon, overwrites Phalcon\Db\DialectInterface, prototype Phalcon\Db\DialectInterface> public method getColumnDefinition ] {
- Parameters [1] {
@@ -19637,6 +19747,14 @@ Extension [ <persistent> extension #170 phalcon version 3.0.4 ] {
}
}
+ Method [ <internal:phalcon> public method truncateTable ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $tableName ]
+ Parameter #1 [ <required> $schemaName ]
+ }
+ }
+
Method [ <internal:phalcon, overwrites Phalcon\Db\DialectInterface, prototype Phalcon\Db\DialectInterface> public method dropTable ] {
- Parameters [3] {
@@ -20063,7 +20181,7 @@ Extension [ <persistent> extension #170 phalcon version 3.0.4 ] {
Property [ <default> protected $_escapeChar ]
}
- - Methods [62] {
+ - Methods [63] {
Method [ <internal:phalcon, overwrites Phalcon\Db\DialectInterface, prototype Phalcon\Db\DialectInterface> public method getColumnDefinition ] {
- Parameters [1] {
@@ -20161,6 +20279,14 @@ Extension [ <persistent> extension #170 phalcon version 3.0.4 ] {
}
}
+ Method [ <internal:phalcon> public method truncateTable ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $tableName ]
+ Parameter #1 [ <required> $schemaName ]
+ }
+ }
+
Method [ <internal:phalcon, overwrites Phalcon\Db\DialectInterface, prototype Phalcon\Db\DialectInterface> public method dropTable ] {
- Parameters [3] {
@@ -27280,6 +27406,10 @@ Extension [ <persistent> extension #170 phalcon version 3.0.4 ] {
}
Method [ <internal:phalcon> public method register ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> $prepend ]
+ }
}
Method [ <internal:phalcon> public method unregister ] {
@@ -28582,11 +28712,14 @@ Extension [ <persistent> extension #170 phalcon version 3.0.4 ] {
Class [ <internal:phalcon> abstract class Phalcon\Mvc\Collection implements Phalcon\Mvc\EntityInterface, Phalcon\Mvc\CollectionInterface, Phalcon\Di\InjectionAwareInterface, Serializable ] {
- - Constants [4] {
+ - Constants [7] {
Constant [ integer OP_NONE ] { 0 }
Constant [ integer OP_CREATE ] { 1 }
Constant [ integer OP_UPDATE ] { 2 }
Constant [ integer OP_DELETE ] { 3 }
+ Constant [ integer DIRTY_STATE_PERSISTENT ] { 0 }
+ Constant [ integer DIRTY_STATE_TRANSIENT ] { 1 }
+ Constant [ integer DIRTY_STATE_DETACHED ] { 2 }
}
- Static properties [2] {
@@ -28667,18 +28800,19 @@ Extension [ <persistent> extension #170 phalcon version 3.0.4 ] {
}
}
- - Properties [8] {
+ - Properties [9] {
Property [ <default> public $_id ]
Property [ <default> protected $_dependencyInjector ]
Property [ <default> protected $_modelsManager ]
Property [ <default> protected $_source ]
Property [ <default> protected $_operationMade ]
+ Property [ <default> protected $_dirtyState ]
Property [ <default> protected $_connection ]
Property [ <default> protected $_errorMessages ]
Property [ <default> protected $_skipped ]
}
- - Methods [38] {
+ - Methods [40] {
Method [ <internal:phalcon, ctor> final public method __construct ] {
- Parameters [2] {
@@ -28789,7 +28923,7 @@ Extension [ <persistent> extension #170 phalcon version 3.0.4 ] {
Method [ <internal:phalcon> protected method validate ] {
- Parameters [1] {
- Parameter #0 [ <required> Phalcon\Mvc\Model\ValidatorInterface $validator ]
+ Parameter #0 [ <required> $validator ]
}
}
@@ -28856,6 +28990,16 @@ Extension [ <persistent> extension #170 phalcon version 3.0.4 ] {
Method [ <internal:phalcon, prototype Phalcon\Mvc\CollectionInterface> public method delete ] {
}
+ Method [ <internal:phalcon, prototype Phalcon\Mvc\CollectionInterface> public method setDirtyState ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $dirtyState ]
+ }
+ }
+
+ Method [ <internal:phalcon, prototype Phalcon\Mvc\CollectionInterface> public method getDirtyState ] {
+ }
+
Method [ <internal:phalcon> protected method addBehavior ] {
- Parameters [1] {
@@ -29334,7 +29478,7 @@ Extension [ <persistent> extension #170 phalcon version 3.0.4 ] {
- Static methods [0] {
}
- - Properties [21] {
+ - Properties [22] {
Property [ <default> protected $_dependencyInjector ]
Property [ <default> protected $_eventsManager ]
Property [ <default> protected $_activeHandler ]
@@ -29353,12 +29497,13 @@ Extension [ <persistent> extension #170 phalcon version 3.0.4 ] {
Property [ <default> protected $_previousHandlerName ]
Property [ <default> protected $_previousActionName ]
Property [ <default> protected $_modelBinding ]
+ Property [ <default> protected $_modelBinder ]
Property [ <default> protected $_handlerSuffix ]
Property [ <default> protected $_defaultHandler ]
Property [ <default> protected $_defaultAction ]
}
- - Methods [44] {
+ - Methods [47] {
Method [ <internal:phalcon, prototype Phalcon\Mvc\DispatcherInterface> public method setControllerSuffix ] {
- Parameters [1] {
@@ -29545,11 +29690,23 @@ Extension [ <persistent> extension #170 phalcon version 3.0.4 ] {
Method [ <internal:phalcon, inherits Phalcon\Dispatcher> public method setModelBinding ] {
- - Parameters [1] {
+ - Parameters [2] {
Parameter #0 [ <required> $value ]
+ Parameter #1 [ <optional> $cache ]
+ }
+ }
+
+ Method [ <internal:phalcon, inherits Phalcon\Dispatcher> public method setModelBinder ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> Phalcon\Mvc\Model\BinderInterface $modelBinder ]
+ Parameter #1 [ <optional> $cache ]
}
}
+ Method [ <internal:phalcon, inherits Phalcon\Dispatcher> public method getModelBinder ] {
+ }
+
Method [ <internal:phalcon, inherits Phalcon\Dispatcher, prototype Phalcon\DispatcherInterface> public method dispatch ] {
}
@@ -29578,6 +29735,9 @@ Extension [ <persistent> extension #170 phalcon version 3.0.4 ] {
}
}
+ Method [ <internal:phalcon, inherits Phalcon\Dispatcher> public method getBoundModels ] {
+ }
+
Method [ <internal:phalcon, inherits Phalcon\Dispatcher> protected method _resolveEmptyProperties ] {
}
}
@@ -29651,7 +29811,7 @@ Extension [ <persistent> extension #170 phalcon version 3.0.4 ] {
- Static methods [0] {
}
- - Properties [12] {
+ - Properties [14] {
Property [ <default> protected $_eventsManager ]
Property [ <default> protected $_dependencyInjector ]
Property [ <default> protected $_handlers ]
@@ -29664,9 +29824,11 @@ Extension [ <persistent> extension #170 phalcon version 3.0.4 ] {
Property [ <default> protected $_afterHandlers ]
Property [ <default> protected $_finishHandlers ]
Property [ <default> protected $_returnedValue ]
+ Property [ <default> protected $_modelBinder ]
+ Property [ <default> protected $_afterBindingHandlers ]
}
- - Methods [35] {
+ - Methods [39] {
Method [ <internal:phalcon, ctor> public method __construct ] {
- Parameters [1] {
@@ -29858,6 +30020,13 @@ Extension [ <persistent> extension #170 phalcon version 3.0.4 ] {
}
}
+ Method [ <internal:phalcon> public method afterBinding ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $handler ]
+ }
+ }
+
Method [ <internal:phalcon> public method after ] {
- Parameters [1] {
@@ -29875,6 +30044,20 @@ Extension [ <persistent> extension #170 phalcon version 3.0.4 ] {
Method [ <internal:phalcon> public method getHandlers ] {
}
+ Method [ <internal:phalcon> public method getModelBinder ] {
+ }
+
+ Method [ <internal:phalcon> public method setModelBinder ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> Phalcon\Mvc\Model\BinderInterface $modelBinder ]
+ Parameter #1 [ <optional> $cache ]
+ }
+ }
+
+ Method [ <internal:phalcon> public method getBoundModels ] {
+ }
+
Method [ <internal:phalcon, inherits Phalcon\Di\Injectable, prototype Phalcon\Di\InjectionAwareInterface> public method getDI ] {
}
@@ -30102,12 +30285,13 @@ Extension [ <persistent> extension #170 phalcon version 3.0.4 ] {
- Static methods [0] {
}
- - Properties [2] {
+ - Properties [3] {
Property [ <default> protected $_handler ]
+ Property [ <default> protected $_modelBinder ]
Property [ <default> protected $_definition ]
}
- - Methods [3] {
+ - Methods [4] {
Method [ <internal:phalcon> public method getDefinition ] {
}
@@ -30125,6 +30309,15 @@ Extension [ <persistent> extension #170 phalcon version 3.0.4 ] {
Parameter #1 [ <required> $arguments ]
}
}
+
+ Method [ <internal:phalcon> public method callMethod ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $method ]
+ Parameter #1 [ <required> $arguments ]
+ Parameter #2 [ <optional> Phalcon\Mvc\Model\BinderInterface or NULL $modelBinder ]
+ }
+ }
}
}
@@ -30870,6 +31063,77 @@ Extension [ <persistent> extension #170 phalcon version 3.0.4 ] {
}
}
+ Class [ <internal:phalcon> class Phalcon\Mvc\Model\Binder implements Phalcon\Mvc\Model\BinderInterface ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [4] {
+ Property [ <default> protected $boundModels ]
+ Property [ <default> protected $cache ]
+ Property [ <default> protected $internalCache ]
+ Property [ <default> protected $originalValues ]
+ }
+
+ - Methods [8] {
+ Method [ <internal:phalcon, prototype Phalcon\Mvc\Model\BinderInterface> public method getBoundModels ] {
+ }
+
+ Method [ <internal:phalcon> public method getOriginalValues ] {
+ }
+
+ Method [ <internal:phalcon, ctor> public method __construct ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> Phalcon\Cache\BackendInterface or NULL $cache ]
+ }
+ }
+
+ Method [ <internal:phalcon, prototype Phalcon\Mvc\Model\BinderInterface> public method setCache ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> Phalcon\Cache\BackendInterface $cache ]
+ }
+ }
+
+ Method [ <internal:phalcon, prototype Phalcon\Mvc\Model\BinderInterface> public method getCache ] {
+ }
+
+ Method [ <internal:phalcon, prototype Phalcon\Mvc\Model\BinderInterface> public method bindToHandler ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $handler ]
+ Parameter #1 [ <required> array $params ]
+ Parameter #2 [ <required> $cacheKey ]
+ Parameter #3 [ <optional> $methodName ]
+ }
+ }
+
+ Method [ <internal:phalcon> protected method getParamsFromCache ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $cacheKey ]
+ }
+ }
+
+ Method [ <internal:phalcon> protected method getParamsFromReflection ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $handler ]
+ Parameter #1 [ <required> array $params ]
+ Parameter #2 [ <required> $cacheKey ]
+ Parameter #3 [ <required> $methodName ]
+ }
+ }
+ }
+ }
+
Class [ <internal:phalcon> class Phalcon\Mvc\Model\Criteria implements Phalcon\Mvc\Model\CriteriaInterface, Phalcon\Di\InjectionAwareInterface ] {
- Constants [0] {
@@ -41165,7 +41429,10 @@ Extension [ <persistent> extension #170 phalcon version 3.0.4 ] {
Property [ <default> protected $_values ]
}
- - Methods [25] {
+ - Methods [26] {
+ Method [ <internal:phalcon> public method getData ] {
+ }
+
Method [ <internal:phalcon> public method setValidators ] {
- Parameters [1] {
@@ -41756,6 +42023,69 @@ Extension [ <persistent> extension #170 phalcon version 3.0.4 ] {
}
}
+ Class [ <internal:phalcon> class Phalcon\Validation\Validator\Callback extends Phalcon\Validation\Validator implements Phalcon\Validation\ValidatorInterface ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [1] {
+ Property [ <default> protected $_options ]
+ }
+
+ - Methods [6] {
+ Method [ <internal:phalcon, overwrites Phalcon\Validation\Validator, prototype Phalcon\Validation\Validator> public method validate ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> Phalcon\Validation $validation ]
+ Parameter #1 [ <required> $field ]
+ }
+ }
+
+ Method [ <internal:phalcon, inherits Phalcon\Validation\Validator, ctor> public method __construct ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> array or NULL $options ]
+ }
+ }
+
+ Method [ <internal, deprecated:phalcon, inherits Phalcon\Validation\Validator> public method isSetOption ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $key ]
+ }
+ }
+
+ Method [ <internal:phalcon, inherits Phalcon\Validation\Validator, prototype Phalcon\Validation\ValidatorInterface> public method hasOption ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $key ]
+ }
+ }
+
+ Method [ <internal:phalcon, inherits Phalcon\Validation\Validator, prototype Phalcon\Validation\ValidatorInterface> public method getOption ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $key ]
+ Parameter #1 [ <optional> $defaultValue ]
+ }
+ }
+
+ Method [ <internal:phalcon, inherits Phalcon\Validation\Validator> public method setOption ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $key ]
+ Parameter #1 [ <required> $value ]
+ }
+ }
+ }
+ }
+
Class [ <internal:phalcon> class Phalcon\Validation\Validator\Confirmation extends Phalcon\Validation\Validator implements Phalcon\Validation\ValidatorInterface ] {
- Constants [0] {
@@ -42094,6 +42424,63 @@ Extension [ <persistent> extension #170 phalcon version 3.0.4 ] {
}
}
+ Class [ <internal:phalcon> class Phalcon\Validation\Validator\Exception extends Phalcon\Exception implements Throwable ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [4] {
+ Property [ <default> protected $message ]
+ Property [ <default> protected $code ]
+ Property [ <default> protected $file ]
+ Property [ <default> protected $line ]
+ }
+
+ - Methods [10] {
+ Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <optional> $message ]
+ Parameter #1 [ <optional> $code ]
+ Parameter #2 [ <optional> $previous ]
+ }
+ }
+
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
+ }
+ }
+ }
+
Class [ <internal:phalcon> class Phalcon\Validation\Validator\ExclusionIn extends Phalcon\Validation\Validator implements Phalcon\Validation\ValidatorInterface ] {
- Constants [0] {
@@ -42622,7 +43009,7 @@ Extension [ <persistent> extension #170 phalcon version 3.0.4 ] {
Property [ <default> private $columnMap ]
}
- - Methods [8] {
+ - Methods [10] {
Method [ <internal:phalcon, overwrites Phalcon\Validation\Validator, prototype Phalcon\Validation\Validator> public method validate ] {
- Parameters [2] {
@@ -42647,6 +43034,24 @@ Extension [ <persistent> extension #170 phalcon version 3.0.4 ] {
}
}
+ Method [ <internal:phalcon> protected method isUniquenessModel ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $record ]
+ Parameter #1 [ <required> array $field ]
+ Parameter #2 [ <required> array $values ]
+ }
+ }
+
+ Method [ <internal:phalcon> protected method isUniquenessCollection ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $record ]
+ Parameter #1 [ <required> array $field ]
+ Parameter #2 [ <required> array $values ]
+ }
+ }
+
Method [ <internal:phalcon, inherits Phalcon\Validation\Validator, ctor> public method __construct ] {
- Parameters [1] {
diff --git a/php-phalcon3.spec b/php-phalcon3.spec
index 0593712..2e4c8d9 100644
--- a/php-phalcon3.spec
+++ b/php-phalcon3.spec
@@ -13,7 +13,7 @@
%global pkg_name %{name}
%endif
-%global gh_commit 2f52d45cdc1dfb9d9dac40a63a7ca333d785e68c
+%global gh_commit 60ed9dd842015a05cfd7e0360c972154d85b3172
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner phalcon
%global gh_project cphalcon
@@ -29,7 +29,7 @@
%endif
Name: %{?sub_prefix}php-phalcon3
-Version: 3.0.4
+Version: 3.1.0
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Summary: Phalcon Framework
@@ -246,6 +246,9 @@ rm -rf %{buildroot}
%changelog
+* Thu Mar 23 2017 Remi Collet <remi@remirepo.net> - 3.1.0-1
+- Update to 3.1.0
+
* Tue Feb 21 2017 Remi Collet <remi@fedoraproject.org> - 3.0.4-1
- update to 3.0.4