summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-07-11 09:49:56 +0200
committerRemi Collet <remi@remirepo.net>2017-07-11 09:49:56 +0200
commitaa736d3073ee4b41535525f6fdf911f409676dcc (patch)
tree9900aff9c630a492453cf3180e25606f45873356
parentd0e0c54dfd3f815bb641e98e34a3c3c1622a950b (diff)
v3.2.1
-rw-r--r--REFLECTION43
-rw-r--r--php-phalcon3.spec32
2 files changed, 37 insertions, 38 deletions
diff --git a/REFLECTION b/REFLECTION
index ac715bf..52e37d8 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #174 phalcon version 3.2.0 ] {
+Extension [ <persistent> extension #175 phalcon version 3.2.1 ] {
- INI {
Entry [ phalcon.db.escape_identifiers <ALL> ]
@@ -14205,7 +14205,7 @@ Extension [ <persistent> extension #174 phalcon version 3.2.0 ] {
Property [ <default> protected $_implicitOutput ]
}
- - Methods [25] {
+ - Methods [26] {
Method [ <internal:phalcon, ctor> public method __construct ] {
- Parameters [1] {
@@ -14326,6 +14326,14 @@ Extension [ <persistent> extension #174 phalcon version 3.2.0 ] {
}
}
+ Method [ <internal:phalcon> public method collectionResourcesByType ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> array $resources ]
+ Parameter #1 [ <required> $type ]
+ }
+ }
+
Method [ <internal:phalcon> public method output ] {
- Parameters [3] {
@@ -18355,6 +18363,15 @@ Extension [ <persistent> extension #174 phalcon version 3.2.0 ] {
}
}
+ Method [ <internal:phalcon, overwrites Phalcon\Db\Adapter, prototype Phalcon\Db\AdapterInterface> public method addForeignKey ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $tableName ]
+ Parameter #1 [ <required> $schemaName ]
+ Parameter #2 [ <required> Phalcon\Db\ReferenceInterface $reference ]
+ }
+ }
+
Method [ <internal:phalcon, inherits Phalcon\Db\Adapter\Pdo, ctor> public method __construct ] {
- Parameters [1] {
@@ -18723,15 +18740,6 @@ Extension [ <persistent> extension #174 phalcon version 3.2.0 ] {
}
}
- Method [ <internal:phalcon, inherits Phalcon\Db\Adapter, prototype Phalcon\Db\AdapterInterface> public method addForeignKey ] {
-
- - Parameters [3] {
- Parameter #0 [ <required> $tableName ]
- Parameter #1 [ <required> $schemaName ]
- Parameter #2 [ <required> Phalcon\Db\ReferenceInterface $reference ]
- }
- }
-
Method [ <internal:phalcon, inherits Phalcon\Db\Adapter, prototype Phalcon\Db\AdapterInterface> public method dropForeignKey ] {
- Parameters [3] {
@@ -20034,7 +20042,7 @@ Extension [ <persistent> extension #174 phalcon version 3.2.0 ] {
Property [ <default> protected $_escapeChar ]
}
- - Methods [62] {
+ - Methods [63] {
Method [ <internal:phalcon, overwrites Phalcon\Db\DialectInterface, prototype Phalcon\Db\DialectInterface> public method getColumnDefinition ] {
- Parameters [1] {
@@ -20236,6 +20244,9 @@ Extension [ <persistent> extension #174 phalcon version 3.2.0 ] {
}
}
+ Method [ <internal:phalcon> public method getForeignKeyChecks ] {
+ }
+
Method [ <internal:phalcon, inherits Phalcon\Db\Dialect> public method registerCustomFunction ] {
- Parameters [2] {
@@ -35978,7 +35989,7 @@ Extension [ <persistent> extension #174 phalcon version 3.2.0 ] {
}
}
- Method [ <internal:phalcon> private method _conditionBetween ] {
+ Method [ <internal:phalcon> protected method _conditionBetween ] {
- Parameters [5] {
Parameter #0 [ <required> $clause ]
@@ -35989,7 +36000,7 @@ Extension [ <persistent> extension #174 phalcon version 3.2.0 ] {
}
}
- Method [ <internal:phalcon> private method _conditionNotBetween ] {
+ Method [ <internal:phalcon> protected method _conditionNotBetween ] {
- Parameters [5] {
Parameter #0 [ <required> $clause ]
@@ -36000,7 +36011,7 @@ Extension [ <persistent> extension #174 phalcon version 3.2.0 ] {
}
}
- Method [ <internal:phalcon> private method _conditionIn ] {
+ Method [ <internal:phalcon> protected method _conditionIn ] {
- Parameters [4] {
Parameter #0 [ <required> $clause ]
@@ -36010,7 +36021,7 @@ Extension [ <persistent> extension #174 phalcon version 3.2.0 ] {
}
}
- Method [ <internal:phalcon> private method _conditionNotIn ] {
+ Method [ <internal:phalcon> protected method _conditionNotIn ] {
- Parameters [4] {
Parameter #0 [ <required> $clause ]
diff --git a/php-phalcon3.spec b/php-phalcon3.spec
index 7f1d3aa..b0b36bb 100644
--- a/php-phalcon3.spec
+++ b/php-phalcon3.spec
@@ -13,7 +13,7 @@
%global pkg_name %{name}
%endif
-%global gh_commit 084fbce9f88c970a4fee64d22911f44dc720f944
+%global gh_commit 2d3aa171588d2d82ed26ade076c70d77ca07e2a3
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner phalcon
%global gh_project cphalcon
@@ -29,7 +29,7 @@
%endif
Name: %{?sub_prefix}php-phalcon3
-Version: 3.2.0
+Version: 3.2.1
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Summary: Phalcon Framework
@@ -49,7 +49,7 @@ BuildRequires: %{?scl_prefix}php-devel > 5.5
BuildRequires: %{?scl_prefix}php-json
BuildRequires: %{?scl_prefix}php-pdo
# For sources generation
-BuildRequires: %{?scl_prefix}zephir >= 0.9.8
+BuildRequires: %{?scl_prefix}zephir >= 0.9.9
BuildRequires: %{?scl_prefix}php-gd
BuildRequires: %{?scl_prefix}php-libsodium
BuildRequires: %{?scl_prefix}php-mbstring
@@ -103,12 +103,6 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
cp %{SOURCE2} %{SOURCE3} %{SOURCE4} %{SOURCE5} \
ext/phalcon/assets/filters/
-%if "%{php_version}" < "7"
-# https://github.com/phalcon/cphalcon/issues/12909
-sed -e 's/zend_error_noreturn/zend_error/' \
- -i ext/kernel/extended/fcall.c ext/kernel/object.c
-%endif
-
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_PHALCON_VERSION/{s/.* "//;s/".*$//;p}' ext/php_phalcon.h)
if test "x${extver}" != "x%{version}%{?prever:-%{prever}}"; then
@@ -168,12 +162,6 @@ cp -r build/NTS build/ZTS
: Build NTS extension
cd build/NTS
-%if "%{php_version}" < "7"
-# https://github.com/phalcon/cphalcon/issues/12909
-sed -e 's/zend_error_noreturn/zend_error/' \
- -i phalcon.zep.c
-%endif
-
%{_bindir}/phpize
peclconf %{_bindir}/php-config
make %{?_smp_mflags}
@@ -181,12 +169,6 @@ make %{?_smp_mflags}
%if %{with_zts}
: Build ZTS extension
cd ../ZTS
-%if "%{php_version}" < "7"
-# https://github.com/phalcon/cphalcon/issues/12909
-sed -e 's/zend_error_noreturn/zend_error/' \
- -i phalcon.zep.c
-%endif
-
%{_bindir}/zts-phpize
peclconf %{_bindir}/zts-php-config
make %{?_smp_mflags}
@@ -244,7 +226,7 @@ REPORT_EXIT_STATUS=1 \
%files
%{!?_licensedir:%global license %%doc}
-%license LICENSE.txt
+%license LICENSE*.txt
%doc *.md
%config(noreplace) %{php_inidir}/%{ini_name}
@@ -259,6 +241,12 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Tue Jul 11 2017 Remi Collet <remi@remirepo.net> - 3.2.1-1
+- Update to 3.2.1
+
+* Wed Jun 21 2017 Remi Collet <remi@remirepo.net> - 3.2.0-2
+- test build with zephir 0.9.9
+
* Mon Jun 19 2017 Remi Collet <remi@remirepo.net> - 3.2.0-1
- Update to 3.2.0
- open https://github.com/phalcon/cphalcon/issues/12909 - PHP 5 compat