summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-02-25 09:49:34 +0100
committerRemi Collet <remi@remirepo.net>2019-02-25 09:49:34 +0100
commit43f47004691939eb5dd15eb38cbe4b8f04ea96b5 (patch)
treee37aad7f8f9c2d289350e719a0a0840f59d74ba8
parent66514257c422d79f4d2df342635a2f05f604141d (diff)
update to 3.4.3 using zephir 0.10.15
make minifiers return unchanged input value backported from upstream version 4.x
-rw-r--r--PHPINFO6
-rw-r--r--REFLECTION2
-rw-r--r--cphalcon-nominifier.patch22
-rw-r--r--php-phalcon3.spec31
4 files changed, 42 insertions, 19 deletions
diff --git a/PHPINFO b/PHPINFO
index 45f6cfa..367537b 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -5,9 +5,9 @@ phalcon
Web framework delivered as a C-extension for PHP
phalcon => enabled
Author => Phalcon Team and contributors
-Version => 3.4.2
-Build Date => Dec 3 2018 08:51:20
-Powered by Zephir => Version 0.10.14
+Version => 3.4.3
+Build Date => Feb 25 2019 09:22:27
+Powered by Zephir => Version 0.10.15
Directive => Local Value => Master Value
phalcon.db.escape_identifiers => On => On
diff --git a/REFLECTION b/REFLECTION
index 31d2d89..5d452eb 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #192 phalcon version 3.4.2 ] {
+Extension [ <persistent> extension #193 phalcon version 3.4.3 ] {
- INI {
Entry [ phalcon.db.escape_identifiers <ALL> ]
diff --git a/cphalcon-nominifier.patch b/cphalcon-nominifier.patch
new file mode 100644
index 0000000..e2bd442
--- /dev/null
+++ b/cphalcon-nominifier.patch
@@ -0,0 +1,22 @@
+diff -up phalcon/assets/filters/cssmin.zep.orig phalcon/assets/filters/cssmin.zep
+--- phalcon/assets/filters/cssmin.zep.orig 2019-02-25 09:14:47.881823280 +0100
++++ phalcon/assets/filters/cssmin.zep 2019-02-25 09:14:53.915856132 +0100
+@@ -36,6 +36,6 @@ class Cssmin implements FilterInterface
+ */
+ public function filter(string! content) -> string
+ {
+- return phalcon_cssmin(content);
++ return content;
+ }
+ }
+diff -up phalcon/assets/filters/jsmin.zep.orig phalcon/assets/filters/jsmin.zep
+--- phalcon/assets/filters/jsmin.zep.orig 2019-02-25 09:15:05.946921636 +0100
++++ phalcon/assets/filters/jsmin.zep 2019-02-25 09:15:18.133987990 +0100
+@@ -36,6 +36,6 @@ class Jsmin implements FilterInterface
+ */
+ public function filter(string! content) -> string
+ {
+- return phalcon_jsmin(content);
++ return content;
+ }
+ }
diff --git a/php-phalcon3.spec b/php-phalcon3.spec
index fbcbe8f..f6ecd5d 100644
--- a/php-phalcon3.spec
+++ b/php-phalcon3.spec
@@ -1,6 +1,6 @@
# remirepo spec file for php-phalcon3
#
-# Copyright (c) 2014-2018 Remi Collet
+# Copyright (c) 2014-2019 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -17,15 +17,14 @@
%global pkg_name %{name}
%endif
-%global gh_commit 2f55ebb91a37cdcd2bc0709c0cb313dc139bf91c
+%global gh_commit 08e7bfc7091250349bcbb39f22f99399ad0c09c4
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner phalcon
%global gh_project cphalcon
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global with_tests 0%{?_with_tests:1}
%global ext_name phalcon
-%global zephir_min 0.10.14
-%global zephir_max 0.11
+%global zephir_ver 0.10.15
%if "%{php_version}" < "5.6"
# after pdo.ini, json.ini, igbinary.ini
%global ini_name z-%{ext_name}.ini
@@ -35,11 +34,10 @@
%endif
Name: %{?sub_prefix}php-phalcon3
-Version: 3.4.2
+Version: 3.4.3
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Summary: Phalcon Framework
-Group: Development/Libraries
License: MIT
URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: %{gh_project}-%{version}-strip.tar.xz
@@ -50,19 +48,16 @@ Source2: cssminifier.c
Source3: cssminifier.h
Source4: jsminifier.c
Source5: jsminifier.h
+# Backported from 4.x
+Patch0: %{gh_project}-nominifier.patch
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel > 5.5
BuildRequires: %{?scl_prefix}php-json
BuildRequires: %{?scl_prefix}php-pdo
# For sources generation
-%if 0%{?zephir_min:1}
-%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-BuildRequires: (%{?scl_prefix}zephir >= %{zephir_min} with %{?scl_prefix}zephir < %{zephir_max})
-%else
-BuildRequires: %{?scl_prefix}zephir < %{zephir_max}
-BuildRequires: %{?scl_prefix}zephir >= %{zephir_min}
-%endif
+%if 0%{?zephir_ver:1}
+BuildRequires: %{?scl_prefix}zephir = %{zephir_ver}
BuildRequires: %{?scl_prefix}php-gd
BuildRequires: %{?scl_prefix}php-pecl(libsodium)
BuildRequires: %{?scl_prefix}php-mbstring
@@ -119,6 +114,7 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
cp %{SOURCE2} %{SOURCE3} %{SOURCE4} %{SOURCE5} \
ext/phalcon/assets/filters/
+%patch0 -p0 -b .nominifier
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_PHALCON_VERSION/{s/.* "//;s/".*$//;p}' ext/php_phalcon.h)
@@ -166,13 +162,13 @@ peclconf() {
: Generate the SAFE sources - optimization seems no more needed
%if "%{php_version}" > "7.0"
-%if 0%{?zephir_min:1}
+%if 0%{?zephir_ver:1}
%{_bindir}/zephir generate --backend=ZendEngine3
%endif
%{__php} build/gen-build.php
mv build/php7/safe build/NTS
%else
-%if 0%{?zephir_min:1}
+%if 0%{?zephir_ver:1}
%{_bindir}/zephir generate --backend=ZendEngine2
%endif
%{__php} build/gen-build.php
@@ -265,6 +261,11 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Mon Feb 25 2019 Remi Collet <remi@remirepo.net> - 3.4.3-1
+- update to 3.4.3 using zephir 0.10.15
+- make minifiers return unchanged input value
+ backported from upstream version 4.x
+
* Mon Dec 3 2018 Remi Collet <remi@remirepo.net> - 3.4.2-1
- update to 3.4.2 using zephir 0.10.14