summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-05-28 12:29:55 +0200
committerRemi Collet <remi@remirepo.net>2018-05-28 12:29:55 +0200
commit2b9943dbb802afe322eb8f5bd928af2966bc09f7 (patch)
tree73e617805557793a8f6df995336f5744382e0cb5
parent8ec0827973217043ae6c9ab51e575e9f7f969bc8 (diff)
update to 3.4.0 using zephir 0.10.10
-rw-r--r--REFLECTION230
-rw-r--r--composer.json5
-rw-r--r--php-phalcon3.spec9
3 files changed, 224 insertions, 20 deletions
diff --git a/REFLECTION b/REFLECTION
index c0e3ab9..3f75be8 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #186 phalcon version 3.3.2 ] {
+Extension [ <persistent> extension #190 phalcon version 3.4.0 ] {
- INI {
Entry [ phalcon.db.escape_identifiers <ALL> ]
@@ -45,7 +45,7 @@ Extension [ <persistent> extension #186 phalcon version 3.3.2 ] {
}
}
- - Classes [396] {
+ - Classes [398] {
Interface [ <internal:phalcon> interface Phalcon\Di\InjectionAwareInterface ] {
- Constants [0] {
@@ -11941,6 +11941,63 @@ Extension [ <persistent> extension #186 phalcon version 3.3.2 ] {
}
}
+ Class [ <internal:phalcon> class Phalcon\Crypt\Exception extends Phalcon\Exception implements Throwable ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [4] {
+ Property [ <default> protected $message ]
+ Property [ <default> protected $code ]
+ Property [ <default> protected $file ]
+ Property [ <default> protected $line ]
+ }
+
+ - Methods [10] {
+ Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <optional> $message ]
+ Parameter #1 [ <optional> $code ]
+ Parameter #2 [ <optional> $previous ]
+ }
+ }
+
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
+ }
+ }
+ }
+
Class [ <internal:phalcon> class Phalcon\Di\FactoryDefault extends Phalcon\Di implements ArrayAccess, Phalcon\DiInterface ] {
- Constants [0] {
@@ -12232,7 +12289,7 @@ Extension [ <persistent> extension #186 phalcon version 3.3.2 ] {
Property [ <default> protected $_notFoundPaths ]
}
- - Methods [41] {
+ - Methods [42] {
Method [ <internal:phalcon, ctor> public method __construct ] {
- Parameters [1] {
@@ -12322,6 +12379,14 @@ Extension [ <persistent> extension #186 phalcon version 3.3.2 ] {
}
}
+ Method [ <internal:phalcon> public method attach ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> Phalcon\Mvc\Router\RouteInterface $route ]
+ Parameter #1 [ <optional> $position ]
+ }
+ }
+
Method [ <internal:phalcon, prototype Phalcon\Mvc\RouterInterface> public method add ] {
- Parameters [4] {
@@ -18083,13 +18148,25 @@ Extension [ <persistent> extension #186 phalcon version 3.3.2 ] {
- Static methods [0] {
}
- - Properties [3] {
+ - Properties [7] {
Property [ <default> protected $_key ]
Property [ <default> protected $_padding ]
Property [ <default> protected $_cipher ]
+ Property [ <default> protected $availableCiphers ]
+ Property [ <default> protected $ivLength ]
+ Property [ <default> protected $hashAlgo ]
+ Property [ <default> protected $useSigning ]
}
- - Methods [12] {
+ - Methods [21] {
+ Method [ <internal:phalcon, ctor> public method __construct ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <optional> $cipher ]
+ Parameter #1 [ <optional> $useSigning ]
+ }
+ }
+
Method [ <internal:phalcon> public method setPadding ] {
- Parameters [1] {
@@ -18117,6 +18194,23 @@ Extension [ <persistent> extension #186 phalcon version 3.3.2 ] {
Method [ <internal:phalcon, prototype Phalcon\CryptInterface> public method getKey ] {
}
+ Method [ <internal:phalcon> public method setHashAlgo ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $hashAlgo ]
+ }
+ }
+
+ Method [ <internal:phalcon> public method getHashAlgo ] {
+ }
+
+ Method [ <internal:phalcon> public method useSigning ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $useSigning ]
+ }
+ }
+
Method [ <internal:phalcon> protected method _cryptPadText ] {
- Parameters [4] {
@@ -18173,10 +18267,37 @@ Extension [ <persistent> extension #186 phalcon version 3.3.2 ] {
Method [ <internal:phalcon, prototype Phalcon\CryptInterface> public method getAvailableCiphers ] {
}
+
+ Method [ <internal:phalcon> public method getAvailableHashAlgos ] {
+ }
+
+ Method [ <internal:phalcon> protected method assertCipherIsAvailable ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $cipher ]
+ }
+ }
+
+ Method [ <internal:phalcon> protected method assertHashAlgorithmAvailable ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $hashAlgo ]
+ }
+ }
+
+ Method [ <internal:phalcon> protected method getIvLength ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $cipher ]
+ }
+ }
+
+ Method [ <internal:phalcon> protected method initializeAvailableCiphers ] {
+ }
}
}
- Class [ <internal:phalcon> class Phalcon\Crypt\Exception extends Phalcon\Exception implements Throwable ] {
+ Class [ <internal:phalcon> class Phalcon\Crypt\Mismatch extends Phalcon\Crypt\Exception implements Throwable ] {
- Constants [0] {
}
@@ -26522,7 +26643,7 @@ Extension [ <persistent> extension #186 phalcon version 3.3.2 ] {
- Static methods [0] {
}
- - Properties [12] {
+ - Properties [13] {
Property [ <default> protected $_readed ]
Property [ <default> protected $_restored ]
Property [ <default> protected $_useEncryption ]
@@ -26535,9 +26656,10 @@ Extension [ <persistent> extension #186 phalcon version 3.3.2 ] {
Property [ <default> protected $_domain ]
Property [ <default> protected $_secure ]
Property [ <default> protected $_httpOnly ]
+ Property [ <default> protected $signKey ]
}
- - Methods [22] {
+ - Methods [24] {
Method [ <internal:phalcon, ctor> public method __construct ] {
- Parameters [7] {
@@ -26551,6 +26673,13 @@ Extension [ <persistent> extension #186 phalcon version 3.3.2 ] {
}
}
+ Method [ <internal:phalcon> public method setSignKey ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> $signKey ]
+ }
+ }
+
Method [ <internal:phalcon, prototype Phalcon\Di\InjectionAwareInterface> public method setDI ] {
- Parameters [1] {
@@ -26650,6 +26779,13 @@ Extension [ <persistent> extension #186 phalcon version 3.3.2 ] {
Method [ <internal:phalcon> public method __toString ] {
}
+
+ Method [ <internal:phalcon> protected method assertSignKeyIsLongEnough ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $signKey ]
+ }
+ }
}
}
@@ -26730,7 +26866,7 @@ Extension [ <persistent> extension #186 phalcon version 3.3.2 ] {
Property [ <default> protected $_strictHostCheck ]
}
- - Methods [64] {
+ - Methods [65] {
Method [ <internal:phalcon> public method getHttpMethodParameterOverride ] {
}
@@ -27011,6 +27147,9 @@ Extension [ <persistent> extension #186 phalcon version 3.3.2 ] {
Method [ <internal:phalcon> public method getHeaders ] {
}
+ Method [ <internal:phalcon> protected method resolveAuthorizationHeaders ] {
+ }
+
Method [ <internal:phalcon, prototype Phalcon\Http\RequestInterface> public method getHTTPReferer ] {
}
@@ -27203,7 +27342,7 @@ Extension [ <persistent> extension #186 phalcon version 3.3.2 ] {
Property [ <default> protected $_dependencyInjector ]
}
- - Methods [30] {
+ - Methods [31] {
Method [ <internal:phalcon, ctor> public method __construct ] {
- Parameters [3] {
@@ -27234,6 +27373,9 @@ Extension [ <persistent> extension #186 phalcon version 3.3.2 ] {
Method [ <internal:phalcon> public method getStatusCode ] {
}
+ Method [ <internal:phalcon> public method getReasonPhrase ] {
+ }
+
Method [ <internal:phalcon> public method setHeaders ] {
- Parameters [1] {
@@ -27394,15 +27536,28 @@ Extension [ <persistent> extension #186 phalcon version 3.3.2 ] {
- Static methods [0] {
}
- - Properties [4] {
+ - Properties [5] {
Property [ <default> protected $_dependencyInjector ]
Property [ <default> protected $_registered ]
Property [ <default> protected $_useEncryption ]
Property [ <default> protected $_cookies ]
+ Property [ <default> protected $signKey ]
}
- - Methods [11] {
+ - Methods [12] {
Method [ <internal:phalcon, ctor> public method __construct ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <optional> $useEncryption ]
+ Parameter #1 [ <optional> $signKey ]
+ }
+ }
+
+ Method [ <internal:phalcon> public method setSignKey ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> $signKey ]
+ }
}
Method [ <internal:phalcon, prototype Phalcon\Di\InjectionAwareInterface> public method setDI ] {
@@ -28375,7 +28530,7 @@ Extension [ <persistent> extension #186 phalcon version 3.3.2 ] {
- Static methods [0] {
}
- - Properties [9] {
+ - Properties [10] {
Property [ <default> protected $_eventsManager ]
Property [ <default> protected $_foundPath ]
Property [ <default> protected $_checkedPath ]
@@ -28385,9 +28540,17 @@ Extension [ <persistent> extension #186 phalcon version 3.3.2 ] {
Property [ <default> protected $_directories ]
Property [ <default> protected $_files ]
Property [ <default> protected $_registered ]
+ Property [ <default> protected $fileCheckingCallback ]
}
- - Methods [19] {
+ - Methods [20] {
+ Method [ <internal:phalcon> public method setFileCheckingCallback ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> $callback ]
+ }
+ }
+
Method [ <internal:phalcon, prototype Phalcon\Events\EventsAwareInterface> public method setEventsManager ] {
- Parameters [1] {
@@ -30026,8 +30189,9 @@ Extension [ <persistent> extension #186 phalcon version 3.3.2 ] {
Method [ <internal:phalcon> static public method aggregate ] {
- - Parameters [1] {
+ - Parameters [2] {
Parameter #0 [ <optional> array or NULL $parameters ]
+ Parameter #1 [ <optional> array or NULL $options ]
}
}
@@ -38107,7 +38271,7 @@ Extension [ <persistent> extension #186 phalcon version 3.3.2 ] {
Property [ <default> protected $_routePrefix ]
}
- - Methods [48] {
+ - Methods [49] {
Method [ <internal:phalcon> public method addResource ] {
- Parameters [2] {
@@ -38250,6 +38414,14 @@ Extension [ <persistent> extension #186 phalcon version 3.3.2 ] {
Method [ <internal:phalcon, inherits Phalcon\Mvc\Router> public method getDefaults ] {
}
+ Method [ <internal:phalcon, inherits Phalcon\Mvc\Router> public method attach ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> Phalcon\Mvc\Router\RouteInterface $route ]
+ Parameter #1 [ <optional> $position ]
+ }
+ }
+
Method [ <internal:phalcon, inherits Phalcon\Mvc\Router, prototype Phalcon\Mvc\RouterInterface> public method add ] {
- Parameters [4] {
@@ -45543,7 +45715,7 @@ Extension [ <persistent> extension #186 phalcon version 3.3.2 ] {
Method [ <internal:phalcon> final public method __invoke ] {
- Parameters [1] {
- Parameter #0 [ <required> $element ]
+ Parameter #0 [ <required> $file ]
}
}
}
@@ -45572,6 +45744,30 @@ Extension [ <persistent> extension #186 phalcon version 3.3.2 ] {
}
}
}
+
+ Class [ <internal:phalcon> final class phalcon\2__closure ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [1] {
+ Method [ <internal:phalcon> final public method __invoke ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $element ]
+ }
+ }
+ }
+ }
}
}
diff --git a/composer.json b/composer.json
index d59ea21..970b5e4 100644
--- a/composer.json
+++ b/composer.json
@@ -12,6 +12,11 @@
"php": ">=5.5"
},
"require-dev": {
+ "ext-dom": "*",
+ "ext-json": "*",
+ "ext-libxml": "*",
+ "ext-mbstring": "*",
+ "ext-xml": "*",
"doctrine/instantiator": "1.0.5",
"phpdocumentor/reflection-docblock": "^2.0",
"phpunit/phpunit": "^4.8",
diff --git a/php-phalcon3.spec b/php-phalcon3.spec
index 04f80de..d8f7a28 100644
--- a/php-phalcon3.spec
+++ b/php-phalcon3.spec
@@ -17,14 +17,14 @@
%global pkg_name %{name}
%endif
-%global gh_commit 9073ca32cd23c19f958cabd8373575a22db56d02
+%global gh_commit 65183349743e899977adc643f103b887612ffe98
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner phalcon
%global gh_project cphalcon
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global with_tests 0%{?_with_tests:1}
%global ext_name phalcon
-%global zephir_ver 0.10.7
+%global zephir_ver 0.10.10
%if "%{php_version}" < "5.6"
# after pdo.ini, json.ini, igbinary.ini
%global ini_name z-%{ext_name}.ini
@@ -34,7 +34,7 @@
%endif
Name: %{?sub_prefix}php-phalcon3
-Version: 3.3.2
+Version: 3.4.0
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Summary: Phalcon Framework
@@ -256,6 +256,9 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Mon May 28 2018 Remi Collet <remi@remirepo.net> - 3.4.0-1
+- update to 3.4.0 using zephir 0.10.10
+
* Wed Mar 7 2018 Remi Collet <remi@remirepo.net> - 3.3.2-1
- update to 3.3.2 using zephir 0.10.7