summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-05-05 11:15:39 +0200
committerRemi Collet <fedora@famillecollet.com>2016-05-05 11:15:39 +0200
commit9c61600b89cd75ac62322cd176e2664e1e41c797 (patch)
tree85919ece82357e9bb6eaaab8da37f0cbd00735f9
parent4b44cccf8ff0c9aa7628b930691522062b272aa0 (diff)
php-phalcon2: 2.0.11
-rw-r--r--REFLECTION216
-rw-r--r--php-phalcon2.spec16
2 files changed, 175 insertions, 57 deletions
diff --git a/REFLECTION b/REFLECTION
index dcb35dc..594c1ef 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #202 phalcon version 2.0.10 ] {
+Extension [ <persistent> extension #204 phalcon version 2.0.11 ] {
- INI {
Entry [ phalcon.db.escape_identifiers <ALL> ]
@@ -39,7 +39,7 @@ Extension [ <persistent> extension #202 phalcon version 2.0.10 ] {
}
}
- - Classes [359] {
+ - Classes [360] {
Interface [ <internal:phalcon> interface Phalcon\Di\InjectionAwareInterface ] {
- Constants [0] {
@@ -1139,6 +1139,33 @@ Extension [ <persistent> extension #202 phalcon version 2.0.10 ] {
}
}
+ Interface [ <internal:phalcon> interface Phalcon\Logger\FormatterInterface ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [1] {
+ Method [ <internal:phalcon> abstract public method format ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $message ]
+ Parameter #1 [ <required> $type ]
+ Parameter #2 [ <required> $timestamp ]
+ Parameter #3 [ <optional> $context ]
+ }
+ }
+ }
+ }
+
Interface [ <internal:phalcon> interface Phalcon\Db\AdapterInterface ] {
- Constants [0] {
@@ -1690,33 +1717,6 @@ Extension [ <persistent> extension #202 phalcon version 2.0.10 ] {
}
}
- Interface [ <internal:phalcon> interface Phalcon\Logger\FormatterInterface ] {
-
- - Constants [0] {
- }
-
- - Static properties [0] {
- }
-
- - Static methods [0] {
- }
-
- - Properties [0] {
- }
-
- - Methods [1] {
- Method [ <internal:phalcon> abstract public method format ] {
-
- - Parameters [4] {
- Parameter #0 [ <required> $message ]
- Parameter #1 [ <required> $type ]
- Parameter #2 [ <required> $timestamp ]
- Parameter #3 [ <optional> $context ]
- }
- }
- }
- }
-
Interface [ <internal:phalcon> interface Phalcon\Mvc\EntityInterface ] {
- Constants [0] {
@@ -9055,7 +9055,7 @@ Extension [ <persistent> extension #202 phalcon version 2.0.10 ] {
}
}
- Class [ <internal:phalcon> abstract class Phalcon\Logger\Formatter ] {
+ Class [ <internal:phalcon> abstract class Phalcon\Logger\Formatter implements Phalcon\Logger\FormatterInterface ] {
- Constants [0] {
}
@@ -9069,7 +9069,7 @@ Extension [ <persistent> extension #202 phalcon version 2.0.10 ] {
- Properties [0] {
}
- - Methods [2] {
+ - Methods [3] {
Method [ <internal:phalcon> public method getTypeString ] {
- Parameters [1] {
@@ -9084,6 +9084,16 @@ Extension [ <persistent> extension #202 phalcon version 2.0.10 ] {
Parameter #1 [ <optional> $context ]
}
}
+
+ Method [ <internal:phalcon, inherits Phalcon\Logger\FormatterInterface> abstract public method format ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $message ]
+ Parameter #1 [ <required> $type ]
+ Parameter #2 [ <required> $timestamp ]
+ Parameter #3 [ <optional> $context ]
+ }
+ }
}
}
@@ -16243,6 +16253,14 @@ Extension [ <persistent> extension #202 phalcon version 2.0.10 ] {
}
}
+ Method [ <internal:phalcon, overwrites Phalcon\Db\Adapter, prototype Phalcon\Db\AdapterInterface> public method describeReferences ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $table ]
+ Parameter #1 [ <optional> $schema ]
+ }
+ }
+
Method [ <internal:phalcon, inherits Phalcon\Db\Adapter\Pdo, prototype Phalcon\Db\AdapterInterface, ctor> public method __construct ] {
- Parameters [1] {
@@ -16643,14 +16661,6 @@ Extension [ <persistent> extension #202 phalcon version 2.0.10 ] {
}
}
- Method [ <internal:phalcon, inherits Phalcon\Db\Adapter, prototype Phalcon\Db\AdapterInterface> public method describeReferences ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> $table ]
- Parameter #1 [ <optional> $schema ]
- }
- }
-
Method [ <internal:phalcon, inherits Phalcon\Db\Adapter, prototype Phalcon\Db\AdapterInterface> public method tableOptions ] {
- Parameters [2] {
@@ -27901,7 +27911,7 @@ Extension [ <persistent> extension #202 phalcon version 2.0.10 ] {
Method [ <internal:phalcon> public method labelsEnabled ] {
}
- Method [ <internal:phalcon, prototype Phalcon\Logger\FormatterInterface> public method format ] {
+ Method [ <internal:phalcon, overwrites Phalcon\Logger\FormatterInterface, prototype Phalcon\Logger\FormatterInterface> public method format ] {
- Parameters [4] {
Parameter #0 [ <required> $message ]
@@ -27936,7 +27946,7 @@ Extension [ <persistent> extension #202 phalcon version 2.0.10 ] {
}
- Methods [3] {
- Method [ <internal:phalcon, prototype Phalcon\Logger\FormatterInterface> public method format ] {
+ Method [ <internal:phalcon, overwrites Phalcon\Logger\FormatterInterface, prototype Phalcon\Logger\FormatterInterface> public method format ] {
- Parameters [4] {
Parameter #0 [ <required> $message ]
@@ -28008,7 +28018,7 @@ Extension [ <persistent> extension #202 phalcon version 2.0.10 ] {
}
}
- Method [ <internal:phalcon, prototype Phalcon\Logger\FormatterInterface> public method format ] {
+ Method [ <internal:phalcon, overwrites Phalcon\Logger\FormatterInterface, prototype Phalcon\Logger\FormatterInterface> public method format ] {
- Parameters [4] {
Parameter #0 [ <required> $message ]
@@ -28050,7 +28060,7 @@ Extension [ <persistent> extension #202 phalcon version 2.0.10 ] {
}
- Methods [3] {
- Method [ <internal:phalcon, prototype Phalcon\Logger\FormatterInterface> public method format ] {
+ Method [ <internal:phalcon, overwrites Phalcon\Logger\FormatterInterface, prototype Phalcon\Logger\FormatterInterface> public method format ] {
- Parameters [4] {
Parameter #0 [ <required> $message ]
@@ -28131,18 +28141,22 @@ Extension [ <persistent> extension #202 phalcon version 2.0.10 ] {
- Static methods [0] {
}
- - Properties [2] {
+ - Properties [3] {
Property [ <default> protected $_loggers ]
Property [ <default> protected $_formatter ]
+ Property [ <default> protected $_logLevel ]
}
- - Methods [13] {
+ - Methods [15] {
Method [ <internal:phalcon> public method getLoggers ] {
}
Method [ <internal:phalcon> public method getFormatter ] {
}
+ Method [ <internal:phalcon> public method getLogLevel ] {
+ }
+
Method [ <internal:phalcon> public method push ] {
- Parameters [1] {
@@ -28157,6 +28171,13 @@ Extension [ <persistent> extension #202 phalcon version 2.0.10 ] {
}
}
+ Method [ <internal:phalcon> public method setLogLevel ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $level ]
+ }
+ }
+
Method [ <internal:phalcon> public method log ] {
- Parameters [3] {
@@ -28931,7 +28952,7 @@ Extension [ <persistent> extension #202 phalcon version 2.0.10 ] {
Property [ <default> protected $_behaviors ]
}
- - Methods [16] {
+ - Methods [17] {
Method [ <internal:phalcon, prototype Phalcon\Di\InjectionAwareInterface> public method setDI ] {
- Parameters [1] {
@@ -28992,6 +29013,13 @@ Extension [ <persistent> extension #202 phalcon version 2.0.10 ] {
}
}
+ Method [ <internal:phalcon> public method getConnectionService ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> Phalcon\Mvc\CollectionInterface $model ]
+ }
+ }
+
Method [ <internal:phalcon> public method useImplicitObjectIds ] {
- Parameters [2] {
@@ -30017,7 +30045,7 @@ Extension [ <persistent> extension #202 phalcon version 2.0.10 ] {
Property [ <default> protected $_snapshot ]
}
- - Methods [75] {
+ - Methods [77] {
Method [ <internal:phalcon, ctor> final public method __construct ] {
- Parameters [2] {
@@ -30446,6 +30474,21 @@ Extension [ <persistent> extension #202 phalcon version 2.0.10 ] {
}
}
+ Method [ <internal:phalcon> final protected method _possibleSetter ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $property ]
+ Parameter #1 [ <required> $value ]
+ }
+ }
+
+ Method [ <internal:phalcon> final protected method _isVisible ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $property ]
+ }
+ }
+
Method [ <internal:phalcon> public method __get ] {
- Parameters [1] {
@@ -35789,7 +35832,7 @@ Extension [ <persistent> extension #202 phalcon version 2.0.10 ] {
- Static methods [0] {
}
- - Properties [24] {
+ - Properties [23] {
Property [ <default> protected $_dependencyInjector ]
Property [ <default> protected $_eventsManager ]
Property [ <default> protected $_uriSource ]
@@ -35810,7 +35853,6 @@ Extension [ <persistent> extension #202 phalcon version 2.0.10 ] {
Property [ <default> protected $_removeExtraSlashes ]
Property [ <default> protected $_notFoundPaths ]
Property [ <default> protected $_handlers ]
- Property [ <default> protected $_processed ]
Property [ <default> protected $_controllerSuffix ]
Property [ <default> protected $_actionSuffix ]
Property [ <default> protected $_routePrefix ]
@@ -38126,7 +38168,7 @@ Extension [ <persistent> extension #202 phalcon version 2.0.10 ] {
- Parameters [2] {
Parameter #0 [ <required> $data ]
- Parameter #1 [ <optional> $options ]
+ Parameter #1 [ <optional> array or NULL $options ]
}
}
@@ -40442,7 +40484,7 @@ Extension [ <persistent> extension #202 phalcon version 2.0.10 ] {
}
}
- Method [ <internal:phalcon> private method prepareOptions ] {
+ Method [ <internal:phalcon> protected method prepareOptions ] {
- Parameters [1] {
Parameter #0 [ <required> array $options ]
@@ -41463,6 +41505,78 @@ Extension [ <persistent> extension #202 phalcon version 2.0.10 ] {
}
}
+ Class [ <internal:phalcon> class Phalcon\Validation\Validator\Date extends Phalcon\Validation\Validator implements Phalcon\Validation\ValidatorInterface ] {
+
+ - Constants [1] {
+ Constant [ string DEFAULT_DATE_FORMAT ] { Y-m-d }
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [1] {
+ Property [ <default> protected $_options ]
+ }
+
+ - Methods [7] {
+ Method [ <internal:phalcon, overwrites Phalcon\Validation\Validator, prototype Phalcon\Validation\Validator> public method validate ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> Phalcon\Validation $validation ]
+ Parameter #1 [ <required> $field ]
+ }
+ }
+
+ Method [ <internal:phalcon> private method checkDate ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $value ]
+ Parameter #1 [ <required> $format ]
+ }
+ }
+
+ Method [ <internal:phalcon, inherits Phalcon\Validation\Validator, ctor> public method __construct ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> array or NULL $options ]
+ }
+ }
+
+ Method [ <internal:phalcon, inherits Phalcon\Validation\Validator, prototype Phalcon\Validation\ValidatorInterface> public method isSetOption ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $key ]
+ }
+ }
+
+ Method [ <internal:phalcon, inherits Phalcon\Validation\Validator, prototype Phalcon\Validation\ValidatorInterface> public method hasOption ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $key ]
+ }
+ }
+
+ Method [ <internal:phalcon, inherits Phalcon\Validation\Validator, prototype Phalcon\Validation\ValidatorInterface> public method getOption ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $key ]
+ Parameter #1 [ <optional> $defaultValue ]
+ }
+ }
+
+ Method [ <internal:phalcon, inherits Phalcon\Validation\Validator> public method setOption ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $key ]
+ Parameter #1 [ <required> $value ]
+ }
+ }
+ }
+ }
+
Class [ <internal:phalcon> class Phalcon\Validation\Validator\Digit extends Phalcon\Validation\Validator implements Phalcon\Validation\ValidatorInterface ] {
- Constants [0] {
diff --git a/php-phalcon2.spec b/php-phalcon2.spec
index 91f8d66..af38a7b 100644
--- a/php-phalcon2.spec
+++ b/php-phalcon2.spec
@@ -12,13 +12,12 @@
%else
%global sub_prefix %{scl_prefix}
%endif
+%scl_package php-phalcon2
+%else
+%global pkg_name %{name}
%endif
-%{?scl: %scl_package php-phalcon2}
-%{!?scl: %global pkg_name %{name}}
-%{!?__php: %global __php %{_bindir}/php}
-
-%global gh_commit cf3c1fe62184d36d24c543c0b4f9993ea8f2445b
+%global gh_commit 1d8b41e0bb8d834a4da4aaa50e29fcd074090909
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner phalcon
%global gh_project cphalcon
@@ -34,7 +33,7 @@
%endif
Name: %{?sub_prefix}php-phalcon2
-Version: 2.0.10
+Version: 2.0.11
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Summary: Phalcon Framework
@@ -79,8 +78,10 @@ Requires: %{?scl_prefix}php-pecl(igbinary)%{?_isa}
Provides: %{?scl_prefix}php-phalcon = %{version}-%{release}
Provides: %{?scl_prefix}php-phalcon%{?_isa} = %{version}-%{release}
+%if "%{?scl_prefix}" != "%{?sub_prefix}"
Provides: %{?scl_prefix}php-phalcon2 = %{version}-%{release}
Provides: %{?scl_prefix}php-phalcon2%{?_isa} = %{version}-%{release}
+%endif
# Only one version can be installed
Conflicts: %{?scl_prefix}php-phalcon < 2
@@ -243,6 +244,9 @@ rm -rf %{buildroot}
%changelog
+* Thu May 5 2016 Remi Collet <remi@fedoraproject.org> - 2.0.11-1
+- update to 2.0.11
+
* Sun Feb 7 2016 Remi Collet <remi@fedoraproject.org> - 2.0.10-1
- update to 2.0.10