summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO10
-rw-r--r--REFLECTION9
-rw-r--r--php-pdlib.spec11
3 files changed, 24 insertions, 6 deletions
diff --git a/PHPINFO b/PHPINFO
index 4e6a38c..14acbe9 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,5 +2,13 @@
pdlib
pdlib support => enabled
-pdlib extension version => 1.0.1
+pdlib extension version => 1.0.2
dlib library version => 19.20.0
+DLIB_USE_CUDA => false
+DLIB_USE_BLAS => true
+DLIB_USE_LAPACK => true
+USE_AVX_INSTRUCTIONS => false
+USE_AVX2_INSTRUCTIONS => false
+USE_NEON_INSTRUCTIONS => false
+USE_SSE2_INSTRUCTIONS => true
+USE_SSE4_INSTRUCTIONS => false
diff --git a/REFLECTION b/REFLECTION
index 35124a3..6b5e5f0 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #90 pdlib version 1.0.1 ] {
+Extension [ <persistent> extension #90 pdlib version 1.0.2 ] {
- Functions {
Function [ <internal:pdlib> function dlib_chinese_whispers ] {
@@ -21,6 +21,13 @@ Extension [ <persistent> extension #90 pdlib version 1.0.1 ] {
Parameter #1 [ <required> string $img_path ]
}
}
+ Function [ <internal:pdlib> function dlib_vector_length ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> array $x_arg ]
+ Parameter #1 [ <required> array $y_arg ]
+ }
+ }
}
- Classes [3] {
diff --git a/php-pdlib.spec b/php-pdlib.spec
index 0f8f6e9..072339a 100644
--- a/php-pdlib.spec
+++ b/php-pdlib.spec
@@ -13,7 +13,7 @@
%global pkg_name %{name}
%endif
-%global gh_commit c7d57a7a1b12865096e98c08e6eb2b6daed1dc52
+%global gh_commit 1153e3e2eb28db09ed207a904096d8d6deb693a1
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner goodspb
%global gh_project pdlib
@@ -36,9 +36,9 @@ BuildRequires: devtoolset-7-toolchain
Summary: A PHP extension for Dlib
Name: %{?sub_prefix}php-%{pecl_name}
-Version: 1.0.1
+Version: 1.0.2
%if 0%{?gh_date:1}
-Release: 1.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%else
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%endif
@@ -53,7 +53,7 @@ Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
-%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
+%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
# Other third party repo stuff
%if "%{php_version}" > "7.2"
Obsoletes: php72u-%{pecl_name} <= %{version}
@@ -189,6 +189,9 @@ TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so" \
%changelog
+* Mon Aug 3 2020 Remi Collet <remi@remirepo.net> - 1.0.2-1
+- update to 1.0.2
+
* Mon Jul 6 2020 Remi Collet <remi@remirepo.net> - 1.0.1-1
- update to 1.0.1
- drop patches merged upstream