summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-07-06 10:01:27 +0200
committerRemi Collet <remi@php.net>2023-07-06 10:01:27 +0200
commit53be94f69a997ebfacbc9372c438175220ee6dae (patch)
treed9da958ebe2087f2641409e24c5f6fd005575bc8
parent20ecfd217408256f4a70dd4b5ba526c90b8df082 (diff)
build out of sources treeHEADmaster
add option to skip tests fix extension version
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION2
-rw-r--r--php-pdlib.spec62
3 files changed, 42 insertions, 24 deletions
diff --git a/PHPINFO b/PHPINFO
index 2af56e7..a2e03db 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,7 +2,7 @@
pdlib
pdlib support => enabled
-pdlib extension version => 1.0.2
+pdlib extension version => 1.1.0
dlib library version => 19.24.99
DLIB_USE_CUDA => false
DLIB_USE_BLAS => true
diff --git a/REFLECTION b/REFLECTION
index 1b1cac1..0cd7be0 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #90 pdlib version 1.0.2 ] {
+Extension [ <persistent> extension #90 pdlib version 1.1.0 ] {
- Functions {
Function [ <internal:pdlib> function dlib_chinese_whispers ] {
diff --git a/php-pdlib.spec b/php-pdlib.spec
index 46ef65f..50300e2 100644
--- a/php-pdlib.spec
+++ b/php-pdlib.spec
@@ -12,6 +12,8 @@
%global pkg_name %{name}
%endif
+%bcond_without tests
+
%global gh_commit 84436d5b9200e3388ca16851110d61b7c1439a8a
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner goodspb
@@ -20,13 +22,9 @@
%global pecl_name pdlib
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global ini_name 40-%{pecl_name}.ini
+%global sources %{gh_project}-%{gh_commit}
+%global _configure ../%{sources}/configure
-%if ! 0%{?dtsversion}
-%if 0%{?rhel} == 7
-%global dtsenable source /opt/rh/devtoolset-7/enable
-BuildRequires: devtoolset-7-toolchain
-%endif
-%endif
Summary: A PHP extension for Dlib
Name: %{?scl_prefix}php-%{pecl_name}
@@ -34,14 +32,23 @@ Version: 1.1.0
%if 0%{?gh_date:1}
Release: 1%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%else
-Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%endif
License: MIT
URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{gh_short}.tar.gz
+%if 0%{?rhel} == 7 && 0%{?dtsversion} == 0
+%global dtsversion 7
+%global dtsenable source /opt/rh/devtoolset-7/enable
+%global dtsprefix devtoolset-7-
+BuildRequires: devtoolset-7-toolchain
+%endif
+BuildRequires: make
+BuildRequires: %{?dtsprefix}gcc
+BuildRequires: %{?dtsprefix}gcc-c++
BuildRequires: %{?scl_prefix}php-devel >= 7.0
-BuildRequires: dlib-devel
+BuildRequires: dlib-devel >= 19.22
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
@@ -55,20 +62,22 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
%prep
%setup -qc
-mv %{gh_project}-%{gh_commit} NTS
-cd NTS
+cd %{sources}
+sed -e '/PHP_PDLIB_VERSION/s/1.0.2/%{version}/' -i php_pdlib.h
+sed -e 's/1.0.2/%{version}/' -i tests/version.phpt
+
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_PDLIB_VERSION/{s/.* "//;s/".*$//;p}' php_pdlib.h)
if test "x${extver}" != "x%{version}%{?gh_date:-dev}"; then
: Error: Upstream extension version is ${extver}, expecting %{version}%{?gh_date:-dev}.
- #exit 1
+ exit 1
fi
cd ..
+mkdir NTS
%if %{with_zts}
-# duplicate for ZTS build
-cp -pr NTS ZTS
+mkdir ZTS
%endif
# Drop in the bit of configuration
@@ -81,8 +90,10 @@ EOF
%build
%{?dtsenable}
-cd NTS
+cd %{sources}
%{__phpize}
+
+cd ../NTS
%configure \
--with-php-config=%{__phpconfig} \
--with-libdir=%{_lib} \
@@ -91,7 +102,6 @@ make %{?_smp_mflags}
%if %{with_zts}
cd ../ZTS
-%{__ztsphpize}
%configure \
--with-php-config=%{__ztsphpconfig} \
--with-libdir=%{_lib} \
@@ -120,35 +130,38 @@ export NO_INTERACTION=1
export SKIP_ONLINE_TESTS=1
export REPORT_EXIT_STATUS=1
-cd NTS
+cd %{sources}
: Minimal load test for NTS extension
%{__php} --no-php-ini \
--define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
- --modules | grep %{pecl_name}
+ --modules | grep '^%{pecl_name}$'
+%if %{with tests}
: Upstream test suite for NTS extension
TEST_PHP_EXECUTABLE=%{__php} \
TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_extdir}/%{pecl_name}.so" \
-%{__php} -n run-tests.php --show-diff || : ignore
+%{__php} -n run-tests.php --show-diff
+%endif
%if %{with_zts}
-cd ../ZTS
: Minimal load test for ZTS extension
%{__ztsphp} --no-php-ini \
--define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
- --modules | grep %{pecl_name}
+ --modules | grep '^%{pecl_name}$'
+%if %{with tests}
: Upstream test suite for ZTS extension
TEST_PHP_EXECUTABLE=%{__ztsphp} \
TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so" \
%{__ztsphp} -n run-tests.php --show-diff
%endif
+%endif
%files
%{!?_licensedir:%global license %%doc}
-%license NTS/LICENSE
-%doc NTS/README.md
+%license %{sources}/LICENSE
+%doc %{sources}/README.md
%config(noreplace) %{php_inidir}/%{ini_name}
%{php_extdir}/%{pecl_name}.so
@@ -160,6 +173,11 @@ TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so" \
%changelog
+* Thu Jul 6 2023 Remi Collet <remi@remirepo.net> - 1.1.0-2
+- build out of sources tree
+- add option to skip tests
+- fix extension version
+
* Wed Jul 5 2023 Remi Collet <remi@remirepo.net> - 1.1.0-1
- update to 1.1.0
- drop patch merged upstream