summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-03-11 16:04:00 +0100
committerRemi Collet <remi@remirepo.net>2021-03-11 16:04:00 +0100
commit1c5b8e6922eda5e9781fade2da0f1b3943cd2d72 (patch)
treee93295de3a389a9f74036772e0cbf3243ffb5793
parent2431749c7c099174df43c8d4b880230ec4bae921 (diff)
update to 2.9.0
-rw-r--r--.gitignore2
-rw-r--r--composer.json4
-rw-r--r--php-pdepend-PHP-Depend.spec18
3 files changed, 16 insertions, 8 deletions
diff --git a/.gitignore b/.gitignore
index 1ab5c4f..01f0400 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1,7 @@
+clog
package-*.xml
*.tgz
+*.tar.bz2
*.tar.gz
*.tar.xz
*.tar.xz.asc
diff --git a/composer.json b/composer.json
index fd08e2a..6dcf008 100644
--- a/composer.json
+++ b/composer.json
@@ -10,10 +10,10 @@
"symfony/config": "^2.3.0|^3|^4|^5"
},
"require-dev": {
- "phpunit/phpunit": "^4.8.35|^5.7",
+ "phpunit/phpunit": "^4.8.36|^5.7.27",
"squizlabs/php_codesniffer": "^2.0.0",
"gregwar/rst": "^1.0",
- "easy-doc/easy-doc": "0.0.0 || ^1.2.3"
+ "easy-doc/easy-doc": "0.0.0|^1.2.3"
},
"bin": ["src/bin/pdepend"],
"autoload": {
diff --git a/php-pdepend-PHP-Depend.spec b/php-pdepend-PHP-Depend.spec
index 56d224b..d845ea6 100644
--- a/php-pdepend-PHP-Depend.spec
+++ b/php-pdepend-PHP-Depend.spec
@@ -7,7 +7,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit c64472f8e76ca858c79ad9a4cf1e2734b3f8cc38
+%global gh_commit b6452ce4b570f540be3a4f46276dd8d8f4fa5ead
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner pdepend
%global gh_project pdepend
@@ -17,16 +17,18 @@
%global php_home %{_datadir}/php/PDepend
%global with_tests 0%{!?_without_tests:1}
-%if 0%{?fedora} >= 28 || 0%{?rhel} >= 8 || "%{?vendor}" == "Remi Collet"
+# remirepo:1
+%if 0%{?fedora} >= 28 || 0%{?rhel} >= 8 || "%{?packager}" == "Remi Collet"
%global sym_pref php-symfony4
%global sym_path %{_datadir}/php/Symfony4
+# remirepo:4
%else
%global sym_pref php-symfony
%global sym_path %{_datadir}/php/Symfony
%endif
Name: php-pdepend-PHP-Depend
-Version: 2.8.0
+Version: 2.9.0
Release: 1%{?dist}
Summary: PHP_Depend design quality metrics for PHP package
@@ -42,9 +44,9 @@ Patch0: %{name}-rpm.patch
BuildArch: noarch
%if %{with_tests}
# From composer/json, "require-dev": {
-# "phpunit/phpunit": "^4.8|^5.7",
+# "phpunit/phpunit": "^4.8.36|^5.7.27",
# "squizlabs/php_codesniffer": "^2.0.0"
-BuildRequires: php-composer(phpunit/phpunit) >= 4.8
+BuildRequires: php-composer(phpunit/phpunit) >= 5.7.27
BuildRequires: php(language) >= 5.3.7
BuildRequires: %{sym_pref}-dependency-injection
BuildRequires: %{sym_pref}-filesystem
@@ -152,7 +154,7 @@ EOF
# testBinCanReadInput rely on git layout
ret=0
-for cmd in php php72 php73 php74; do
+for cmd in php php73 php74 php80; do
if which $cmd; then
$cmd %{_bindir}/phpunit -d memory_limit=1G \
--no-coverage \
@@ -174,6 +176,7 @@ fi
%files
+# remirepo:1
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc composer.json
@@ -184,6 +187,9 @@ fi
%changelog
+* Thu Mar 11 2021 Remi Collet <remi@remirepo.net> - 2.9.0-1
+- update to 2.9.0
+
* Tue Jun 23 2020 Remi Collet <remi@remirepo.net> - 2.8.0-1
- update to 2.8.0