summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-03-10 18:22:31 +0100
committerRemi Collet <fedora@famillecollet.com>2016-03-10 18:22:31 +0100
commit14d46a5eb0ca7a1758d1a142c6bdd0d789064dfe (patch)
tree3bb28000e9ddaf1e52f10de2efc74b46a7363f07
parentf82f2df68950f2391b67b445e7810a5e525b46ad (diff)
php-pdepend-PHP-Depend: 2.2.4
-rw-r--r--php-pdepend-PHP-Depend.spec23
1 files changed, 18 insertions, 5 deletions
diff --git a/php-pdepend-PHP-Depend.spec b/php-pdepend-PHP-Depend.spec
index 7a46fc7..656fed9 100644
--- a/php-pdepend-PHP-Depend.spec
+++ b/php-pdepend-PHP-Depend.spec
@@ -7,7 +7,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 9d816dfa565b9c47685057761acaf432c9e8066a
+%global gh_commit b086687f3a01dc6bb92d633aef071d2c5dd0db06
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner pdepend
%global gh_project pdepend
@@ -18,7 +18,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-pdepend-PHP-Depend
-Version: 2.2.3
+Version: 2.2.4
Release: 1%{?dist}
Summary: PHP_Depend design quality metrics for PHP package
@@ -137,10 +137,20 @@ require '%{buildroot}%{php_home}/autoload.php';
$fedoraClassLoader->addPrefix('PDepend\\', dirname(__DIR__));
EOF
-%{_bindir}/phpunit -d memory_limit=1G --verbose
-
+run=0
if which php70; then
- php70 %{_bindir}/phpunit -d memory_limit=1G --verbose
+ php70 %{_bindir}/phpunit -d memory_limit=1G --verbose
+ run=1
+fi
+
+if which php56; then
+ php56 %{_bindir}/phpunit -d memory_limit=1G --verbose
+ run=1
+fi
+
+if [ $run -eq 0 ]; then
+ # No SCL available, run using with default PHP
+ %{_bindir}/phpunit -d memory_limit=1G --verbose
fi
%else
: Test suite disabled
@@ -170,6 +180,9 @@ rm -rf %{buildroot}
%changelog
+* Thu Mar 10 2016 Remi Collet <remi@fedoraproject.org> - 2.2.4-1
+- update to 2.2.4
+
* Tue Feb 23 2016 Remi Collet <remi@fedoraproject.org> - 2.2.3-1
- update to 2.2.3