summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2013-01-29 15:22:14 +0100
committerRemi Collet <fedora@famillecollet.com>2013-01-29 15:22:14 +0100
commit2b8c63e163519a6dfdba6f5d23d411eb1159d580 (patch)
tree12652b1a17bcf7242e93a8eaa172dad3b29b0254
parentb07bedbab6ed125796f74fc5a84559a595b51c85 (diff)
php-password-compat: backport
-rw-r--r--Makefile10
-rw-r--r--php-password-compat.spec5
2 files changed, 15 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..d095534
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,10 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+INCL1 := $(shell php-config --includes)
+INCL2 := -I $(shell php-config --include-dir)/sapi/embed
+LIBS := -lphp5 $(shell php-config --libs)
+
+include ../../common/Makefile
+
+tembed: tembed.c
+ gcc -Wall $(INCL1) $(INCL2) tembed.c $(LIBS) -o tembed
diff --git a/php-password-compat.spec b/php-password-compat.spec
index a3fe75a..bce1137 100644
--- a/php-password-compat.spec
+++ b/php-password-compat.spec
@@ -13,6 +13,7 @@ License: MIT
URL: https://github.com/ircmaxell/password_compat
Source0: https://github.com/ircmaxell/%{real_name}/archive/%{commit}/%{real_name}-%{version}-%{shortcommit}.tar.gz
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
BuildRequires: php-pear(pear.phpunit.de/PHPUnit)
@@ -51,6 +52,7 @@ cd test
%files
+%defattr(-,root,root,-)
%doc LICENSE.md README.md composer.json
%dir %{_datadir}/php/%{real_name}
%{_datadir}/php/%{real_name}/*
@@ -60,6 +62,9 @@ cd test
%changelog
+* Tue Jan 29 2013 Remi Collet <rpms@fedoraproject.org> - 1.0.0-4.git5815cf
+- backport for remi repo
+
* Tue Jan 29 2013 Johan Cwiklinski <johan AT x-tnd DOT be> - 1.0.0-4.git5815cf
- License was not incorrect...
- Directory not owned