summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-05-30 07:25:20 +0200
committerRemi Collet <remi@remirepo.net>2017-05-30 07:25:20 +0200
commitb917f662e60e92c010ba312891625cb09c0f1d7c (patch)
treeef51edacc0c33d2ea31dd77fe6ec3a06ae2863b9
parentd834817f67edf5dc69b8af5eb0e94b5411728ad6 (diff)
sync with Fedora
-rw-r--r--php-opencloud.spec28
1 files changed, 14 insertions, 14 deletions
diff --git a/php-opencloud.spec b/php-opencloud.spec
index 36c8653..f8a607b 100644
--- a/php-opencloud.spec
+++ b/php-opencloud.spec
@@ -49,7 +49,7 @@
Name: php-opencloud
Version: %{github_version}
-Release: 1%{?github_release}%{?dist}
+Release: 2%{?github_release}%{?dist}
Summary: PHP SDK for OpenStack/Rackspace APIs
Group: Development/Libraries
@@ -97,7 +97,7 @@ Requires: php-json
Requires: php-pcre
Requires: php-spl
# Autoloader
-Requires: php-composer(symfony/class-loader)
+Requires: php-composer(fedora/autoloader)
# Composer
Provides: php-composer(%{composer_vendor}/%{composer_project}) = %{version}
@@ -113,6 +113,8 @@ a separate Rackspace subclass is provided so that you can still use the SDK
with a pure OpenStack instance (for example, see the OpenStack class (for
OpenStack) and the Rackspace subclass).
+Autoloader: %{phpdir}/OpenCloud/autoload.php
+
%package doc
Summary: Documentation for PHP SDK for OpenStack/Rackspace APIs
@@ -158,10 +160,6 @@ cp -rp \
%{buildroot}%{phpdir}/OpenCloud/mikemccabe/JsonPatch/
-%clean
-rm -rf %{buildroot}
-
-
%check
%if %{with_tests}
: Create mock Composer autoloader
@@ -193,16 +191,15 @@ sed \
-e 's/function test_Member_Schema/function SKIP_test_Member_Schema/' \
-i tests/OpenCloud/Tests/Image/ServiceTest.php
-%{_bindir}/phpunit --verbose
-
-: Upstream tests with SCLs if available
-SCL_RETURN_CODE=0
-for SCL in %{?rhel:php55} php56 php70 php71; do
- if which $SCL; then
- $SCL %{_bindir}/phpunit --verbose || SCL_RETURN_CODE=1
+: Upstream tests
+RETURN_CODE=0
+PHPUNIT=$(which phpunit)
+for PHP_EXEC in "" %{?rhel:php55} php56 php70 php71; do
+ if [ -z "$PHP_EXEC" ] || which $PHP_EXEC; then
+ $PHP_EXEC $PHPUNIT --verbose || RETURN_CODE=1
fi
done
-exit $SCL_RETURN_CODE
+exit $RETURN_CODE
%else
: Tests skipped
%endif
@@ -222,6 +219,9 @@ exit $SCL_RETURN_CODE
%changelog
+* Mon May 29 2017 Shawn Iwinski <shawn.iwinski@gmail.com> - 1.16.0-2
+- Fix autoloader dependency
+
* Sun Feb 26 2017 Shawn Iwinski <shawn.iwinski@gmail.com> - 1.16.0-1
- Update to 1.16.0 (RHBZ #1312624)
- Fix FTBFS (skip tests known to fail)