summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-01-30 12:03:59 +0100
committerRemi Collet <fedora@famillecollet.com>2014-01-30 12:03:59 +0100
commit283ef853a7a781471ef6dd4f463be7b59cb044a6 (patch)
treeeb6547532e2b049f4a8198b2554f975882d0d881
parentaaf721f9266454f6f892a4594e36d7420e27484f (diff)
php-opencloud: backport
-rw-r--r--Makefile4
-rw-r--r--php-opencloud.spec14
2 files changed, 17 insertions, 1 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..91b0fd5
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../common/Makefile
+
diff --git a/php-opencloud.spec b/php-opencloud.spec
index a7ed244..384e570 100644
--- a/php-opencloud.spec
+++ b/php-opencloud.spec
@@ -6,11 +6,13 @@ Name: php-opencloud
Version: 1.6.0
Release: 4%{?dist}
Summary: PHP SDK for OpenStack/Rackspace APIs
+Group: Development/Libraries
-License: ASL 2.0
+License: ASL 2.0
URL: http://php-opencloud.com/
Source0: https://github.com/rackspace/php-opencloud/archive/%{commit}/%{name}-%{version}-%{shortcommit}.tar.gz
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: php-phpunit-PHPUnit
Requires: php-spl php-curl php-date php-fileinfo php-hash php-json
@@ -31,6 +33,7 @@ and the Rackspace subclass).
%package doc
Summary: Documentation for OpenStack/Rackspace APIs PHP SDK
+Group: Development/Libraries
%description doc
%{summary}
@@ -48,16 +51,22 @@ sed -i 's/\r$//' docs/api/css/jquery.treeview.css
%install
+rm -rf %{buildroot}
INSTALL_DIR=%{buildroot}%{_datadir}/php
mkdir -p $INSTALL_DIR
cp -a lib/%{vendor} $INSTALL_DIR
+%clean
+rm -rf %{buildroot}
+
+
%check
phpunit -d date.timezone=UTC .
%files
+%defattr(-,root,root,-)
%doc LICENSE README.md TODO.md composer.json CONTRIBUTORS.md TODO.md
%{_datadir}/php/%{vendor}
@@ -66,6 +75,9 @@ phpunit -d date.timezone=UTC .
%changelog
+* Thu Jan 30 2014 Remi Collet <rpms@famillecollet.com> - 1.6.0-4
+- backport 1.6.0 for remi repo
+
* Thu Jan 30 2014 Gregor Tätzner <brummbq@fedoraproject.org> - 1.6.0-4
- obsolete php-cloudfiles