summaryrefslogtreecommitdiffstats
path: root/php-morris-lessql.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-morris-lessql.spec')
-rw-r--r--php-morris-lessql.spec37
1 files changed, 12 insertions, 25 deletions
diff --git a/php-morris-lessql.spec b/php-morris-lessql.spec
index 2925207..2e9dfc3 100644
--- a/php-morris-lessql.spec
+++ b/php-morris-lessql.spec
@@ -1,12 +1,12 @@
# remirepo/fedora spec file for php-morris-lessql
#
-# Copyright (c) 2016-2017 Remi Collet
+# Copyright (c) 2016-2018 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
-%global gh_commit ff6c631e3abf1d3ee618f5262be4cc6ed09f6957
+%global gh_commit 338966185fc052e7ee769360d19950cf90c0fd42
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner morris
#global gh_date 20150820
@@ -15,16 +15,15 @@
%global psr0 LessQL
Name: php-%{gh_owner}-%{gh_project}
-Version: 0.3.4
+Version: 0.3.5
Release: 1%{?gh_date?%{gh_date}git%{gh_short}}%{?dist}
Summary: The agile PHP ORM alternative
Group: Development/Libraries
License: MIT
URL: http://lessql.net/
-Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{?gh_short}.tar.gz
+Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{name}-%{version}-%{?gh_short}.tar.gz
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
%if %{with_tests}
BuildRequires: php(language) >= 5.3.4
@@ -70,8 +69,6 @@ Autoloader: %{_datadir}/php/%{psr0}/autoload.php
%install
-rm -rf %{buildroot}
-
: Library
mkdir -p %{buildroot}%{_datadir}/php
cp -pr src/%{psr0} %{buildroot}%{_datadir}/php/%{psr0}
@@ -86,32 +83,19 @@ require '%{buildroot}%{_datadir}/php/%{psr0}/autoload.php';
EOF
# remirepo:11
-run=0
ret=0
-if which php56; then
- php56 %{_bindir}/phpunit --no-coverage tests || ret=1
- run=1
-fi
-if which php71; then
- php71 %{_bindir}/phpunit --no-coverage tests || ret=1
- run=1
-fi
-if [ $run -eq 0 ]; then
-%{_bindir}/phpunit --verbose tests
-# remirepo:2
-fi
+for cmd in php php56 php70 php71 php72; do
+ if which $cmd; then
+ $cmd %{_bindir}/phpunit --no-coverage tests || ret=1
+ fi
+done
exit $ret
%else
: Test suite disabled
%endif
-%clean
-rm -rf %{buildroot}
-
-
%files
-%defattr(-,root,root,-)
%{!?_licensedir:%global license %%doc}
%license LICENSE.md
%doc composer.json
@@ -121,6 +105,9 @@ rm -rf %{buildroot}
%changelog
+* Mon Jan 29 2018 Remi Collet <remi@remirepo.net> - 0.3.5-1
+- Update to 0.3.5
+
* Tue Sep 27 2016 Remi Collet <remi@fedoraproject.org> - 0.3.4-1
- initial package