summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-05-11 14:33:28 +0200
committerRemi Collet <remi@remirepo.net>2020-05-11 14:33:28 +0200
commitdd9e8396721550c789a3b1bf88552c2c2babcb39 (patch)
tree7160b76ad20faea352c59fec31cc44e79c480ed3
parent519530c70df530149e2728a71d2c7ca18aac7e27 (diff)
update to 1.0.0HEADmaster
-rw-r--r--composer.json19
-rw-r--r--php-morris-lessql.spec34
2 files changed, 31 insertions, 22 deletions
diff --git a/composer.json b/composer.json
index d1e8531..bdc5788 100644
--- a/composer.json
+++ b/composer.json
@@ -1,7 +1,7 @@
{
"name": "morris/lessql",
- "description": "LessQL: The agile PHP ORM alternative",
- "keywords": [ "orm", "notorm", "sql", "pdo", "database" ],
+ "description": "LessQL: A lightweight and performant PHP ORM alternative",
+ "keywords": ["orm", "notorm", "sql", "pdo", "database"],
"license": "MIT",
"homepage": "https://github.com/morris/lessql",
"authors": [
@@ -10,19 +10,20 @@
"homepage": "https://morrisbrodersen.de"
}
],
-
"autoload": {
- "psr-0": {
- "": "src"
+ "psr-4": {
+ "LessQL\\": "src/LessQL"
}
},
-
"require": {
"php": ">=5.3.4"
},
-
"require-dev": {
- "phpunit/phpunit": "~4.6",
- "codeclimate/php-test-reporter": "dev-master"
+ "phpunit/phpunit": "~4.6|~5|~6|~7",
+ "friendsofphp/php-cs-fixer": "^2.16"
+ },
+ "scripts": {
+ "test": "vendor/bin/phpunit --bootstrap=tests/sqlite.php --coverage-html=coverage tests",
+ "format": "vendor/bin/php-cs-fixer fix ."
}
}
diff --git a/php-morris-lessql.spec b/php-morris-lessql.spec
index 2e9dfc3..eade775 100644
--- a/php-morris-lessql.spec
+++ b/php-morris-lessql.spec
@@ -1,12 +1,12 @@
# remirepo/fedora spec file for php-morris-lessql
#
-# Copyright (c) 2016-2018 Remi Collet
+# Copyright (c) 2016-2020 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
-%global gh_commit 338966185fc052e7ee769360d19950cf90c0fd42
+%global gh_commit 86eff1d9faef067bd6682f5d291ee08a4b61e7b8
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner morris
#global gh_date 20150820
@@ -15,11 +15,10 @@
%global psr0 LessQL
Name: php-%{gh_owner}-%{gh_project}
-Version: 0.3.5
+Version: 1.0.0
Release: 1%{?gh_date?%{gh_date}git%{gh_short}}%{?dist}
Summary: The agile PHP ORM alternative
-Group: Development/Libraries
License: MIT
URL: http://lessql.net/
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{name}-%{version}-%{?gh_short}.tar.gz
@@ -31,14 +30,15 @@ BuildRequires: php-json
BuildRequires: php-pcre
BuildRequires: php-spl
# For tests, from composer.json "require-dev": {
-# "phpunit/phpunit": "~4.6",
-# "codeclimate/php-test-reporter": "dev-master"
-BuildRequires: php-composer(phpunit/phpunit) >= 4.6
+# "phpunit/phpunit": "~4.6|~5|~6|~7",
+# "friendsofphp/php-cs-fixer": "^2.16"
+%global phpunit %{_bindir}/phpunit7
+BuildRequires: %{phpunit}
BuildRequires: php-pdo
BuildRequires: php-date
%endif
# For autoloader
-BuildRequires: php-composer(theseer/autoload)
+BuildRequires: php-fedora-autoloader-devel
# From composer.json, "require": {
# "php": ">=5.3.4"
@@ -65,7 +65,7 @@ Autoloader: %{_datadir}/php/%{psr0}/autoload.php
%build
: generate an simple autoloader
-%{_bindir}/phpab --output src/%{psr0}/autoload.php src/%{psr0}
+%{_bindir}/phpab --template fedora --output src/%{psr0}/autoload.php src/%{psr0}
%install
@@ -82,11 +82,13 @@ cat << 'EOF' | tee vendor/autoload.php
require '%{buildroot}%{_datadir}/php/%{psr0}/autoload.php';
EOF
-# remirepo:11
ret=0
-for cmd in php php56 php70 php71 php72; do
- if which $cmd; then
- $cmd %{_bindir}/phpunit --no-coverage tests || ret=1
+for cmdarg in "php %{phpunit}" php72 php73 php74 php80; do
+ if which $cmdarg; then
+ set $cmdarg
+ $1 ${2:-%{_bindir}/phpunit7} \
+ --bootstrap=tests/sqlite.php \
+ --no-coverage tests || ret=1
fi
done
exit $ret
@@ -105,6 +107,12 @@ exit $ret
%changelog
+* Mon May 11 2020 Remi Collet <remi@remirepo.net> - 1.0.0-1
+- update to 1.0.0
+
+* Mon May 6 2019 Remi Collet <remi@remirepo.net> - 0.4.1-1
+- update to 0.4.1
+
* Mon Jan 29 2018 Remi Collet <remi@remirepo.net> - 0.3.5-1
- Update to 0.3.5