summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-01-04 18:44:08 +0100
committerRemi Collet <fedora@famillecollet.com>2016-01-04 18:44:08 +0100
commitfe948df5c5898be089513ffe12aeda11d68624d6 (patch)
tree5899baf9d31435819b3678cff0dc236db8f51a47
parentc9755005fe0697c4f9652c8a7d954c1fe242887f (diff)
php-mongodb: 1.0.0beta2
-rw-r--r--php-mongodb-autoload.patch13
-rw-r--r--php-mongodb.spec21
2 files changed, 14 insertions, 20 deletions
diff --git a/php-mongodb-autoload.patch b/php-mongodb-autoload.patch
deleted file mode 100644
index df451b1..0000000
--- a/php-mongodb-autoload.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff -up tests/PedantryTest.php.rpm tests/PedantryTest.php
---- tests/PedantryTest.php.rpm 2015-11-02 17:58:41.319791130 +0100
-+++ tests/PedantryTest.php 2015-11-02 17:58:45.599811089 +0100
-@@ -65,6 +65,9 @@ class PedantryTest extends \PHPUnit_Fram
- if ($file->getFilename() === 'functions.php') {
- continue;
- }
-+ if ($file->getFilename() === 'autoload.php') {
-+ continue;
-+ }
-
- $classNames[][] = 'MongoDB\\' . str_replace(DIRECTORY_SEPARATOR, '\\', substr($file->getRealPath(), strlen($srcDir) + 1, -4));
- }
diff --git a/php-mongodb.spec b/php-mongodb.spec
index 8205a6b..451ef6e 100644
--- a/php-mongodb.spec
+++ b/php-mongodb.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 34b74f852af43fc70f49308bfbd3555f91db593c
+%global gh_commit e8177e87efe74437b812915887d416f5b68b4e30
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner mongodb
#global gh_date 20151102
@@ -17,14 +17,14 @@
%global with_tests 0%{?_with_tests:1}
%endif
%global psr0 MongoDB
-%global prever beta1
+%global prever beta2
Name: php-%{gh_owner}
Version: 1.0.0
%if 0%{?gh_date}
Release: 0.2.%{gh_date}git%{gh_short}%{?dist}
%else
-Release: 0.3.%{prever}%{?dist}
+Release: 0.4.%{prever}%{?dist}
%endif
Summary: MongoDB driver library
@@ -35,7 +35,6 @@ Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit
# Autoloader
Source1: %{name}-autoload.php
-Patch0: %{name}-autoload.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
@@ -52,9 +51,9 @@ BuildRequires: php-composer(symfony/class-loader)
# From composer.json, "require": {
# "php": ">=5.4"
-# "ext-mongodb": "^1.0.0"
+# "ext-mongodb": "^1.1.1"
Requires: php(language) >= 5.4
-Requires: php-pecl(mongodb)
+Requires: php-pecl(mongodb) >= 1.1.1
# From phpcompatinfo report for 1.0.0alpha1
Requires: php-reflection
Requires: php-spl
@@ -83,7 +82,6 @@ To use this library, you just have to add, in your project:
%setup -q -n %{gh_project}-%{gh_commit}
cp %{SOURCE1} src/autoload.php
-%patch0 -p0
%build
@@ -128,6 +126,10 @@ EOF
: Run the test suite
%{_bindir}/phpunit --verbose || RET=1
+if which php70; then
+ php70 %{_bindir}/phpunit --verbose || RET=1
+fi
+
: Cleanup
[ -s server.pid ] && kill $(cat server.pid)
@@ -154,6 +156,11 @@ rm -rf %{buildroot}
%changelog
+* Mon Jan 4 2016 Remi Collet <remi@fedoraproject.org> - 1.0.0-0.4.beta2
+- update to 1.0.0beta2
+- raise dependency on pecl/mongodb ^1.1.1
+- run test suite with both PHP 5 and 7 when available
+
* Tue Nov 3 2015 Remi Collet <remi@fedoraproject.org> - 1.0.0-0.3.beta1
- update to 1.0.0beta1