summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-11-14 15:20:11 +0100
committerRemi Collet <remi@remirepo.net>2017-11-14 15:20:11 +0100
commitf2de4806f9d1dfd966951acfd4355968a010d792 (patch)
treec1c41d6939b709e34617842066d535df02d6a1a5
parentaf3fc0def59c5b88aa1f77e63cd0c8e56b766dd1 (diff)
Update to 1.2.0
raise dependency on PHP 5.5 raise dependency on mongodb extension 1.3.0
-rw-r--r--composer.json6
-rw-r--r--php-mongodb.spec32
2 files changed, 25 insertions, 13 deletions
diff --git a/composer.json b/composer.json
index 4e426b2..7c772ca 100644
--- a/composer.json
+++ b/composer.json
@@ -10,8 +10,10 @@
{ "name": "Derick Rethans", "email": "github@derickrethans.nl" }
],
"require": {
- "php": ">=5.4",
- "ext-mongodb": "^1.2.0"
+ "php": ">=5.5",
+ "ext-hash": "*",
+ "ext-json": "*",
+ "ext-mongodb": "^1.3.0"
},
"require-dev": {
"phpunit/phpunit": "^4.8"
diff --git a/php-mongodb.spec b/php-mongodb.spec
index 90513eb..0819b5b 100644
--- a/php-mongodb.spec
+++ b/php-mongodb.spec
@@ -6,25 +6,28 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit a307dd60e71e1291c60927ea4f3a1905146063f5
+%global gh_commit 5cffeb33b893b6bb04195b99ddc3955a29252339
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner mongodb
#global gh_date 20151102
%global gh_project mongo-php-library
# Upstream only support 64bits, see https://jira.mongodb.org/browse/CDRIVER-1186
-# Server only available on LE arch (ExcludeArch: ppc ppc64 %{sparc} s390 s390x)
+# Server only available on LE arch (ExcludeArch: ppc ppc64 %%{sparc} s390 s390x)
%global with_tests 0%{?_with_tests:1}
-# remirepo:1
+# remirepo:4
+# encoutent too many openfile error in F27 with 3.4
+%if 0%{?fedora} < 27
%global with_tests 0%{!?_without_tests:1}
+%endif
%global psr0 MongoDB
#global prever beta2
Name: php-%{gh_owner}
-Version: 1.1.2
+Version: 1.2.0
%if 0%{?gh_date}
-Release: 0.2.%{gh_date}git%{gh_short}%{?dist}
+Release: 1%{gh_date}git%{gh_short}%{?dist}
%else
-Release: 2%{?dist}
+Release: 1%{?dist}
%endif
Summary: MongoDB driver library
@@ -38,7 +41,7 @@ Source1: %{name}-autoload.php
BuildArch: noarch
%if %{with_tests}
-BuildRequires: php(language) >= 5.4
+BuildRequires: php(language) >= 5.5
BuildRequires: php-hash
BuildRequires: php-json
BuildRequires: php-spl
@@ -52,13 +55,15 @@ BuildRequires: php-composer(fedora/autoloader)
%endif
# From composer.json, "require": {
-# "php": ">=5.4"
-# "ext-mongodb": "^1.2.0"
+# "php": ">=5.5"
+# "ext-hash": "*",
+# "ext-json": "*",
+# "ext-mongodb": "^1.3.0"
Requires: php(language) >= 5.4
-Requires: php-pecl(mongodb) >= 1.2.0
-# From phpcompatinfo report for 1.1.1
Requires: php-hash
Requires: php-json
+Requires: php-pecl(mongodb) >= 1.3.0
+# From phpcompatinfo report for 1.2.0
Requires: php-spl
# For autoloader
Requires: php-composer(fedora/autoloader)
@@ -147,6 +152,11 @@ exit $ret
%changelog
+* Tue Nov 14 2017 Remi Collet <remi@remirepo.net> - 1.2.0-1
+- Update to 1.2.0
+- raise dependency on PHP 5.5
+- raise dependency on mongodb extension 1.3.0
+
* Sun May 14 2017 Remi Collet <remi@remirepo.net> - 1.1.2-2
- ensure fedora/autoloader is used