summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-09-27 07:48:33 +0200
committerRemi Collet <fedora@famillecollet.com>2016-09-27 07:48:33 +0200
commita652aa90d70938f1d3e2e5f4f9a017dbc349d129 (patch)
treec538b7ba0b6ca4be20b15d9f27fb6a71da720076
parentba03cb522542bc6df39e28aa44bfa41076d03dcd (diff)
php-mongodb: 1.0.3
-rw-r--r--composer.json23
-rw-r--r--php-mongodb.spec10
2 files changed, 29 insertions, 4 deletions
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..259835f
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,23 @@
+{
+ "name": "mongodb/mongodb",
+ "description": "MongoDB driver library",
+ "keywords": ["database", "driver", "mongodb", "persistence"],
+ "homepage": "https://jira.mongodb.org/browse/PHPLIB",
+ "license": "Apache-2.0",
+ "authors": [
+ { "name": "Hannes Magnusson", "email": "bjori@mongodb.com" },
+ { "name": "Jeremy Mikola", "email": "jmikola@gmail.com" },
+ { "name": "Derick Rethans", "email": "github@derickrethans.nl" }
+ ],
+ "require": {
+ "php": ">=5.4",
+ "ext-mongodb": "^1.1.0"
+ },
+ "autoload": {
+ "psr-4": { "MongoDB\\": "src/" },
+ "files": [ "src/functions.php" ]
+ },
+ "autoload-dev": {
+ "psr-4": { "MongoDB\\Tests\\": "tests/" }
+ }
+}
diff --git a/php-mongodb.spec b/php-mongodb.spec
index b49e0e3..f3f972f 100644
--- a/php-mongodb.spec
+++ b/php-mongodb.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit faf8a1d86b5c10684ef91fa6c81475b0c7f95240
+%global gh_commit 3c742f3ceffc4dc67fee02dc6ebfc2e7cb403b7c
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner mongodb
#global gh_date 20151102
@@ -22,11 +22,11 @@
#global prever beta2
Name: php-%{gh_owner}
-Version: 1.0.2
+Version: 1.0.3
%if 0%{?gh_date}
Release: 0.2.%{gh_date}git%{gh_short}%{?dist}
%else
-Release: 2%{?dist}
+Release: 1%{?dist}
%endif
Summary: MongoDB driver library
@@ -162,11 +162,13 @@ rm -rf %{buildroot}
%doc README.md
%doc RELEASE-*
%doc docs
-%doc examples
%{_datadir}/php/%{psr0}
%changelog
+* Tue Sep 27 2016 Remi Collet <remi@fedoraproject.org> - 1.0.3-1
+- update to 1.0.3
+
* Thu Jul 28 2016 Remi Collet <remi@fedoraproject.org> - 1.0.2-2
- only run upstream test suite when build --with tests