summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-04-04 14:23:41 +0200
committerRemi Collet <remi@remirepo.net>2018-04-04 14:23:41 +0200
commit3753be59ccf392b829fc7dc94d09b8bd74d1da09 (patch)
tree11064cb4c171366c7da8e328d023445b6a48c1cf
parent0c6e06a2f5f5f59d4d4a5a3106096d7e97625648 (diff)
v1.3.1
-rw-r--r--composer.json2
-rw-r--r--php-mongodb.spec23
2 files changed, 17 insertions, 8 deletions
diff --git a/composer.json b/composer.json
index 11d5c2d..c4950a5 100644
--- a/composer.json
+++ b/composer.json
@@ -16,7 +16,7 @@
"ext-mongodb": "^1.4.0"
},
"require-dev": {
- "phpunit/phpunit": "^4.8.36"
+ "phpunit/phpunit": "^4.8.36 || ^6.4"
},
"autoload": {
"psr-4": { "MongoDB\\": "src/" },
diff --git a/php-mongodb.spec b/php-mongodb.spec
index 5a3dc23..3bb820c 100644
--- a/php-mongodb.spec
+++ b/php-mongodb.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 07ffd2438658342b776803323cfaa7c156a6099a
+%global gh_commit 7417ecf1ca5aef263d3e2fdc4ace214f7fd1b750
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner mongodb
#global gh_date 20151102
@@ -18,7 +18,7 @@
#global prever beta2
Name: php-%{gh_owner}
-Version: 1.3.0
+Version: 1.3.1
%if 0%{?gh_date}
Release: 1%{gh_date}git%{gh_short}%{?dist}
%else
@@ -42,8 +42,13 @@ BuildRequires: php-spl
BuildRequires: php-pecl(mongodb) >= 1.3.0
BuildRequires: mongodb-server >= 2.4
# From composer.json, "require-dev": {
-# "phpunit/phpunit": "^4.8.36"
-BuildRequires: php-composer(phpunit/phpunit) >= 4.8.36
+# "phpunit/phpunit": "^4.8.36 || ^6.4"
+%if 0%{?fedora} >= 26 || 0%{?rhel} >= 8
+%global phpunit %{_bindir}/phpunit6
+%else
+%global phpunit %{_bindir}/phpunit
+%endif
+BuildRequires: %{phpunit}
# For autoloader
BuildRequires: php-composer(fedora/autoloader)
%endif
@@ -121,9 +126,10 @@ EOF
: Run the test suite
ret=0
-for cmd in php php56 php70 php71 php72; do
- if which $cmd; then
- $cmd %{_bindir}/phpunit --verbose || ret=1
+for cmdarg in "php %{phpunit}" "php56 %{_bindir}/phpunit" php70 php71 php72; do
+ if which $cmdarg; then
+ set $cmdarg
+ $1 ${2:-%{_bindir}/phpunit6} --verbose || ret=1
fi
done
@@ -146,6 +152,9 @@ exit $ret
%changelog
+* Wed Apr 4 2018 Remi Collet <remi@remirepo.net> - 1.3.1-1
+- update to 1.3.1
+
* Fri Feb 9 2018 Remi Collet <remi@remirepo.net> - 1.3.0-1
- Update to 1.3.0
- raise dependency on mongodb extension 1.4.0