summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-06-22 14:11:31 +0200
committerRemi Collet <remi@php.net>2023-06-22 14:11:31 +0200
commit17f93dd5650aff729d8f2f5a2c56f1d7610a51e4 (patch)
tree3eef4e124102a188db90960d14a9d8bd5d0f9d75
parent01b33a0bf7aa6b59e1929753d107b4510a670a7b (diff)
update to 1.16.0
raise dependency on mongodb extension version 1.16 raise dependency on symfony/polyfill 1.27
-rw-r--r--composer.json18
-rw-r--r--php-mongodb.spec48
2 files changed, 39 insertions, 27 deletions
diff --git a/composer.json b/composer.json
index 8e55fab..fe9698d 100644
--- a/composer.json
+++ b/composer.json
@@ -12,13 +12,16 @@
"php": "^7.2 || ^8.0",
"ext-hash": "*",
"ext-json": "*",
- "ext-mongodb": "^1.15.0",
- "jean85/pretty-package-versions": "^1.2 || ^2.0.1",
- "symfony/polyfill-php80": "^1.19"
+ "ext-mongodb": "^1.16.0",
+ "jean85/pretty-package-versions": "^2.0.1",
+ "symfony/polyfill-php73": "^1.27",
+ "symfony/polyfill-php80": "^1.27",
+ "symfony/polyfill-php81": "^1.27"
},
"require-dev": {
- "squizlabs/php_codesniffer": "^3.6",
- "doctrine/coding-standard": "^9.0",
+ "doctrine/coding-standard": "^11.1",
+ "rector/rector": "^0.16.0",
+ "squizlabs/php_codesniffer": "^3.7",
"symfony/phpunit-bridge": "^5.2",
"vimeo/psalm": "^4.28"
},
@@ -32,12 +35,13 @@
},
"extra": {
"branch-alias": {
- "dev-master": "1.15.x-dev"
+ "dev-master": "1.16.x-dev"
}
},
"config": {
"allow-plugins": {
"dealerdirect/phpcodesniffer-composer-installer": true
- }
+ },
+ "sort-packages": true
}
}
diff --git a/php-mongodb.spec b/php-mongodb.spec
index 8ed9031..f10b5ef 100644
--- a/php-mongodb.spec
+++ b/php-mongodb.spec
@@ -1,7 +1,7 @@
# remirepo/fedora spec file for php-mongodb
#
-# Copyright (c) 2015-2022 Remi Collet
-# License: CC-BY-SA
+# Copyright (c) 2015-2023 Remi Collet
+# License: CC-BY-SA-4.0
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
@@ -9,31 +9,28 @@
# disabled for https://fedoraproject.org/wiki/Changes/MongoDB_Removal
%bcond_with tests
-%global gh_commit 3a681a3b2f2c0ebac227a3b86bb9057d0e6eb8f8
+%global gh_commit d4cdf057a67cb99a32db8984a16959bfa7ca7eb5
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner mongodb
-#global gh_date 20151102
%global gh_project mongo-php-library
%global psr0 MongoDB
-%global upstream_version 1.15.0
+%global upstream_version 1.16.0
#global upstream_prever alpha1
#global upstream_lower alpha1
-%global ext_version 1.15.0
+%global ext_version 1.16.0
Name: php-%{gh_owner}
Version: %{upstream_version}%{?upstream_prever:~%{upstream_lower}}
-%if 0%{?gh_date}
-Release: 1%{gh_date}git%{gh_short}%{?dist}
-%else
Release: 1%{?dist}
-%endif
Summary: MongoDB driver library
-License: ASL 2.0
+License: Apache-2.0
URL: https://github.com/%{gh_owner}/%{gh_project}
-Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{name}-%{upstream_version}%{?upstream_prever}-%{gh_short}.tar.gz
+# use git snapshot to retrieve full sources with tests
+Source0: %{name}-%{upstream_version}%{?upstream_prever}-%{gh_short}.tgz
+Source1: makesrc.sh
# Get rid of jean85/pretty-package-versions
Patch0: %{name}-rpm.patch
@@ -49,11 +46,13 @@ BuildRequires: php-json
BuildRequires: php-spl
# remirepo:1
%if 0%{?fedora} >= 31 || 0%{?rhel} >= 8
-BuildRequires: (php-composer(symfony/polyfill-php80) >= 1.19 with php-composer(symfony/polyfill-php80) < 2)
+BuildRequires: (php-composer(symfony/polyfill-php73) >= 1.27 with php-composer(symfony/polyfill-php73) < 2)
+BuildRequires: (php-composer(symfony/polyfill-php80) >= 1.27 with php-composer(symfony/polyfill-php80) < 2)
+BuildRequires: (php-composer(symfony/polyfill-php81) >= 1.27 with php-composer(symfony/polyfill-php81) < 2)
# remirepo:4
%else
BuildRequires: php-symfony-polyfill < 2
-BuildRequires: php-symfony-polyfill >= 1.19
+BuildRequires: php-symfony-polyfill >= 1.27
%endif
%if %{with tests}
BuildRequires: mongodb-server >= 2.4
@@ -77,20 +76,24 @@ BuildRequires: php-composer(fedora/autoloader)
# "php": "^7.2 || ^8.0"
# "ext-hash": "*",
# "ext-json": "*",
-# "ext-mongodb": "^1.15.0"
-# "jean85/pretty-package-versions": "^1.2 || ^2.0.1"
-# "symfony/polyfill-php80": "^1.19"
+# "ext-mongodb": "^1.16.0",
+# "jean85/pretty-package-versions": "^2.0.1",
+# "symfony/polyfill-php73": "^1.27",
+# "symfony/polyfill-php80": "^1.27",
+# "symfony/polyfill-php81": "^1.27"
Requires: php(language) >= 7.2
Requires: php-hash
Requires: php-json
Requires: php-pecl(mongodb) >= %{ext_version}
# remirepo:1
%if 0%{?fedora} >= 31 || 0%{?rhel} >= 8
-Requires: (php-composer(symfony/polyfill-php80) >= 1.19 with php-composer(symfony/polyfill-php80) < 2)
+Requires: (php-composer(symfony/polyfill-php73) >= 1.27 with php-composer(symfony/polyfill-php73) < 2)
+Requires: (php-composer(symfony/polyfill-php80) >= 1.27 with php-composer(symfony/polyfill-php80) < 2)
+Requires: (php-composer(symfony/polyfill-php81) >= 1.27 with php-composer(symfony/polyfill-php81) < 2)
# remirepo:4
%else
Requires: php-symfony-polyfill < 2
-Requires: php-symfony-polyfill >= 1.19
+Requires: php-symfony-polyfill >= 1.27
%endif
# From phpcompatinfo report for 1.8.0
Requires: php-reflection
@@ -132,7 +135,7 @@ require_once __DIR__. '/functions.php';
EOF
# Get rid of jean85/pretty-package-versions
-%patch0 -p1 -b .rpm
+%patch -P0 -p1 -b .rpm
sed -e 's/@VERSION@/%{upstream_version}%{?upstream_prever:-%{upstream_lower}}/' -i src/Client.php
find src -name \*.rpm -delete
grep -F '%{upstream_version}' src/Client.php
@@ -209,6 +212,11 @@ exit $ret
%changelog
+* Thu Jun 22 2023 Remi Collet <remi@remirepo.net> - 1.16.0-1
+- update to 1.16.0
+- raise dependency on mongodb extension version 1.16
+- raise dependency on symfony/polyfill 1.27
+
* Wed Nov 23 2022 Remi Collet <remi@remirepo.net> - 1.15.0-1
- update to 1.15.0
- raise dependency on mongodb extension version 1.15