summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-06-16 07:13:28 +0200
committerRemi Collet <fedora@famillecollet.com>2016-06-16 07:13:28 +0200
commit13a676daf6a3716aae2e056a584e68c6bddc4993 (patch)
tree3b8216019660850d42756a88fd17d919b7325e68
parentcfccac64e11bd09792baa71fb618a9e886bfa48f (diff)
php-mock-phpunit: 1.1.2
-rw-r--r--php-mock-phpunit/composer.json30
-rw-r--r--php-mock-phpunit/php-mock-phpunit-upstream.patch60
-rw-r--r--php-mock-phpunit/php-mock-phpunit.spec20
3 files changed, 41 insertions, 69 deletions
diff --git a/php-mock-phpunit/composer.json b/php-mock-phpunit/composer.json
new file mode 100644
index 0000000..9a1aa20
--- /dev/null
+++ b/php-mock-phpunit/composer.json
@@ -0,0 +1,30 @@
+{
+ "name": "php-mock/php-mock-phpunit",
+ "type": "library",
+ "description": "Mock built-in PHP functions (e.g. time()) with PHPUnit. This package relies on PHP's namespace fallback policy. No further extension is needed.",
+ "keywords": ["phpunit", "mock", "stub", "test double", "function", "test", "TDD", "BDD"],
+ "homepage": "https://github.com/php-mock/php-mock-phpunit",
+ "license": "WTFPL",
+ "authors": [
+ {
+ "name": "Markus Malkusch",
+ "email": "markus@malkusch.de",
+ "homepage": "http://markus.malkusch.de",
+ "role": "Developer"
+ }
+ ],
+ "autoload": {
+ "psr-4": {"phpmock\\phpunit\\": "classes/"}
+ },
+ "require": {
+ "php": ">=5.5",
+ "phpunit/phpunit": "^4.0.0 || ^5.0.0",
+ "php-mock/php-mock-integration": "^1"
+ },
+ "archive": {
+ "exclude": ["/tests"]
+ },
+ "conflict": {
+ "phpunit/phpunit-mock-objects": "3.2.0"
+ }
+}
diff --git a/php-mock-phpunit/php-mock-phpunit-upstream.patch b/php-mock-phpunit/php-mock-phpunit-upstream.patch
deleted file mode 100644
index bdb776a..0000000
--- a/php-mock-phpunit/php-mock-phpunit-upstream.patch
+++ /dev/null
@@ -1,60 +0,0 @@
-From 1dad555b26c919ac42803f4d84b72af4aeb529d0 Mon Sep 17 00:00:00 2001
-From: Markus Malkusch <markus@malkusch.de>
-Date: Wed, 11 Nov 2015 23:43:41 +0100
-Subject: [PATCH] [refactor] moved testDefineFunctionMock() into php-mock
-
----
- tests/PHPMockTest.php | 33 +++++----------------------------
- 1 file changed, 5 insertions(+), 28 deletions(-)
-
-diff --git a/tests/PHPMockTest.php b/tests/PHPMockTest.php
-index dd0171c..fe59f78 100644
---- a/tests/PHPMockTest.php
-+++ b/tests/PHPMockTest.php
-@@ -17,6 +17,11 @@ class PHPMockTest extends AbstractMockTest
-
- use PHPMock;
-
-+ protected function defineFunction($namespace, $functionName)
-+ {
-+ self::defineFunctionMock($namespace, $functionName);
-+ }
-+
- protected function mockFunction($namespace, $functionName, callable $function)
- {
- $mock = $this->getFunctionMock($namespace, $functionName);
-@@ -28,34 +33,6 @@ protected function disableMocks()
- }
-
- /**
-- * Tests defineFunctionMock().
-- *
-- * @test
-- */
-- public function testDefineFunctionMock()
-- {
-- self::defineFunctionMock(__NAMESPACE__, "escapeshellcmd");
-- self::escapeshellcmd("foo");
--
-- $mock = $this->getFunctionMock(__NAMESPACE__, "escapeshellcmd");
-- $mock->expects($this->once())->willReturn("bar");
--
-- $this->assertEquals("bar", self::escapeshellcmd("foo"));
-- }
--
-- /**
-- * Returns the built-in call to escapeshellcmd().
-- *
-- * @param string $command Shell command.
-- *
-- * @return string The built-in call.
-- */
-- private static function escapeshellcmd($command)
-- {
-- return escapeshellcmd($command);
-- }
--
-- /**
- * Tests building a mock with arguments.
- *
- * @test
diff --git a/php-mock-phpunit/php-mock-phpunit.spec b/php-mock-phpunit/php-mock-phpunit.spec
index 4fe898a..cc669aa 100644
--- a/php-mock-phpunit/php-mock-phpunit.spec
+++ b/php-mock-phpunit/php-mock-phpunit.spec
@@ -6,15 +6,15 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit d2edb32ec05584bb6bd8f1b7e94284022fb12d75
+%global gh_commit 359e3038c016cee4c8f8db6387bcab3fcdebada0
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner php-mock
%global gh_project php-mock-phpunit
%global with_tests 0%{!?_without_tests:1}
Name: php-mock-phpunit
-Version: 1.1.1
-Release: 2%{?dist}
+Version: 1.1.2
+Release: 1%{?dist}
Summary: Mock built-in PHP functions with PHPUnit.
Group: Development/Libraries
@@ -22,8 +22,6 @@ License: WTFPL
URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{gh_short}.tar.gz
-Patch0: %{name}-upstream.patch
-
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
BuildRequires: php(language) >= 5.5
@@ -36,6 +34,8 @@ BuildRequires: php-composer(phpunit/phpunit) > 4
# "php": ">=5.5",
# "phpunit/phpunit": "^4.0.0 || ^5.0.0",
# "php-mock/php-mock-integration": "^1"
+# "conflict": {
+# "phpunit/phpunit-mock-objects": "3.2.0"
Requires: php(language) >= 5.5
Requires: php-composer(phpunit/phpunit) >= 4
Requires: php-composer(phpunit/phpunit) < 6
@@ -55,7 +55,6 @@ No further extension is needed.
%prep
%setup -q -n %{gh_project}-%{gh_commit}
-%patch0 -p1
# Same namespace than php-mock, not specific autoloader needed
@@ -82,8 +81,8 @@ EOF
%{_bindir}/phpunit
-if which php70; then
- php70 %{_bindir}/phpunit
+if which php71; then
+ php71 %{_bindir}/phpunit
fi
%else
: bootstrap build with test suite disabled
@@ -104,8 +103,11 @@ rm -rf %{buildroot}
%changelog
+* Thu Jun 16 2016 Remi Collet <remi@fedoraproject.org> - 1.1.2-1
+- update to 1.1.2 (no change)
+
* Mon Feb 22 2016 Remi Collet <remi@fedoraproject.org> - 1.1.1-2
- Fix: license is WTFPL
* Fri Feb 12 2016 Remi Collet <remi@fedoraproject.org> - 1.1.1-1
-- initial package \ No newline at end of file
+- initial package