summaryrefslogtreecommitdiffstats
path: root/php-maxminddb.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-11-22 15:02:24 +0100
committerRemi Collet <remi@remirepo.net>2018-11-22 15:02:24 +0100
commitbd945fc916ff22adaa3540c39083b932ed51377e (patch)
tree5d65ff3ebfb4329286f42fdd0c3f4ee3c29427af /php-maxminddb.spec
parent122edc9ae0bfe968947801e1ff5c931bbf52c5c8 (diff)
minor
Diffstat (limited to 'php-maxminddb.spec')
-rw-r--r--php-maxminddb.spec12
1 files changed, 7 insertions, 5 deletions
diff --git a/php-maxminddb.spec b/php-maxminddb.spec
index 74b2892..814b96b 100644
--- a/php-maxminddb.spec
+++ b/php-maxminddb.spec
@@ -26,6 +26,7 @@
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner maxmind
%global gh_project MaxMind-DB-Reader-php
+# Extension
%global pecl_name maxminddb
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global ini_name 40-%{pecl_name}.ini
@@ -50,7 +51,7 @@ BuildRequires: pkgconfig(libmaxminddb) >= 1.0.0
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
-# Weak dependencies
+# Weak dependencie on databasess
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Recommends: geolite2-country
Suggests: geolite2-city
@@ -127,6 +128,9 @@ Requires: php(language) >= 5.4
Recommends: php-bcmath
Recommends: php-gmp
Recommends: php-maxminddb
+# Weak dependencies on databases
+Recommends: geolite2-country
+Suggests: geolite2-city
%endif
# From phpcompatifo report for 1.3.0
Requires: php-filter
@@ -262,11 +266,7 @@ for cmd in php php56 php70 php71 php72 php73; do
if which $cmd; then
$cmd %{_bindir}/phpunit \
--bootstrap %{buildroot}%{_datadir}/php/MaxMind/Db/Reader/autoload.php \
-%if %{__isa_bits} == 64
--verbose || ret=1
-%else
- --verbose || : ignore per https://github.com/maxmind/MaxMind-DB-Reader-php/issues/77
-%endif
fi
done
@@ -274,7 +274,9 @@ done
php --define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
%{_bindir}/phpunit \
--bootstrap %{buildroot}%{_datadir}/php/MaxMind/Db/Reader/autoload.php \
+%if %{__isa_bits} < 64
--filter '^((?!(testDecoder)).)*$' \
+%endif
--verbose || ret=1
%endif
exit $ret