summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-12-20 10:20:21 +0100
committerRemi Collet <remi@remirepo.net>2019-12-20 10:20:21 +0100
commit2267d05734f4ae794170fb9ee2aa80fb7773a112 (patch)
treecf30bc08c450ef5a3c5a5e180c2b81952ef74b34
parente97a67eac7fc088fb87c144c7dd07e7db27306fb (diff)
v1.6.0
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION2
-rw-r--r--composer.json3
-rw-r--r--php-maxminddb.spec12
4 files changed, 14 insertions, 5 deletions
diff --git a/PHPINFO b/PHPINFO
index bfdb1fe..52e1263 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,5 +2,5 @@
maxminddb
MaxMind DB Reader => enabled
-maxminddb extension version => 1.5.1
+maxminddb extension version => 1.6.0
libmaxminddb library version => 1.2.0
diff --git a/REFLECTION b/REFLECTION
index 4161390..2c77dba 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #105 maxminddb version 1.5.1 ] {
+Extension [ <persistent> extension #107 maxminddb version 1.6.0 ] {
- Classes [1] {
Class [ <internal:maxminddb> class MaxMind\Db\Reader ] {
diff --git a/composer.json b/composer.json
index 4ddcc36..39cdfe2 100644
--- a/composer.json
+++ b/composer.json
@@ -20,6 +20,9 @@
"ext-gmp": "bcmath or gmp is required for decoding larger integers with the pure PHP decoder",
"ext-maxminddb": "A C-based database decoder that provides significantly faster lookups"
},
+ "conflict": {
+ "ext-maxminddb": "<1.6.0,>=2.0.0"
+ },
"require-dev": {
"friendsofphp/php-cs-fixer": "2.*",
"phpunit/phpunit": "5.*",
diff --git a/php-maxminddb.spec b/php-maxminddb.spec
index 70e8abe..6b9f366 100644
--- a/php-maxminddb.spec
+++ b/php-maxminddb.spec
@@ -17,7 +17,7 @@
%global with_tests 0%{!?_without_tests:1}
-%global gh_commit f096bbe4d37e3d93e62626297bfc2179472a972d
+%global gh_commit febd4920bf17c1da84cef58e56a8227dfb37fbe4
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner maxmind
%global gh_project MaxMind-DB-Reader-php
@@ -31,8 +31,8 @@
Summary: MaxMind DB Reader extension
Name: %{?sub_prefix}php-maxminddb
-Version: 1.5.1
-%global rpmrel 2
+Version: 1.6.0
+%global rpmrel 1
Release: %{rpmrel}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: ASL 2.0
URL: https://github.com/%{gh_owner}/%{gh_project}
@@ -131,6 +131,9 @@ Recommends: php-maxminddb
Recommends: geolite2-country
Suggests: geolite2-city
%endif
+# from composer.json "conflict": {
+# "ext-maxminddb": "<1.6.0,>=2.0.0"
+Conflicts: php-maxminddb < %{version}
# From phpcompatifo report for 1.3.0
Requires: php-filter
Requires: php-spl
@@ -305,6 +308,9 @@ exit $ret
# when using pkgup, CHECK Release!
%changelog
+* Fri Dec 20 2019 Remi Collet <remi@remirepo.net> - 1.6.0-1
+- update to 1.6.0
+
* Fri Dec 13 2019 Remi Collet <remi@remirepo.net> - 1.5.1-2
- update to 1.5.1
- drop patch merged upstream