summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-11-22 14:54:48 +0100
committerRemi Collet <remi@remirepo.net>2018-11-22 14:54:48 +0100
commite43d4d0000bf8672860209c94ddcafc142fb4e7d (patch)
treecc0c9ae88f8d99923c45f1fa83bbe706bfb58cd0
parent122edc9ae0bfe968947801e1ff5c931bbf52c5c8 (diff)
cleanup for Fedora reviewfedora
-rw-r--r--php-maxminddb.spec114
1 files changed, 32 insertions, 82 deletions
diff --git a/php-maxminddb.spec b/php-maxminddb.spec
index 74b2892..ddd2e71 100644
--- a/php-maxminddb.spec
+++ b/php-maxminddb.spec
@@ -1,3 +1,6 @@
+# Fedora spec file for php-maxminddb
+# Without SCL compatibility from:
+#
# remirepo spec file for php-maxminddb
#
# Copyright (c) 2018 Remi Collet
@@ -6,85 +9,41 @@
#
# Please, preserve the changelog entries
#
-%if 0%{?scl:1}
-%global sub_prefix %{scl_prefix}
-%scl_package php-maxminddb
-%global with_lib 0
-%else
-%global pkg_name %{name}
-%global with_lib 1
-%endif
-# for the pure PHP library - disabled on EL < 8 because of PHPUnit dependency
-%if 0%{?fedora} >= 20 || 0%{?rhel} >= 8
-%global with_tests 0%{!?_without_tests:1}
-%else
-%global with_tests 0%{?_with_tests:1}
-%endif
-
-
%global gh_commit 2f1086e38939e808cc23b17daa469da094af9125
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner maxmind
%global gh_project MaxMind-DB-Reader-php
+# Extension
%global pecl_name maxminddb
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global ini_name 40-%{pecl_name}.ini
# pure PHP library
%global pk_vendor maxmind-db
%global pk_project reader
+%global with_tests 0%{!?_without_tests:1}
Summary: MaxMind DB Reader extension
-Name: %{?sub_prefix}php-maxminddb
+Name: php-maxminddb
Version: 1.4.0
-%global rpmrel 1
-Release: %{rpmrel}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1%{?dist}
License: ASL 2.0
URL: https://github.com/%{gh_owner}/%{gh_project}
-Source0: %{pkg_name}-%{version}-%{gh_short}.tgz
+Source0: %{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
-BuildRequires: %{?scl_prefix}php-devel
+BuildRequires: php-devel > 5.4
BuildRequires: pkgconfig(libmaxminddb) >= 1.0.0
-Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
-Requires: %{?scl_prefix}php(api) = %{php_core_api}
-%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
-# Weak dependencies
+Requires: php(zend-abi) = %{php_zend_api}
+Requires: php(api) = %{php_core_api}
+
+# Weak dependencies on databases
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Recommends: geolite2-country
Suggests: geolite2-city
%endif
-%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
-%if "%{php_version}" > "5.6"
-Obsoletes: php56u-%{pecl_name} <= %{version}
-Obsoletes: php56w-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.0"
-Obsoletes: php70u-%{pecl_name} <= %{version}
-Obsoletes: php70w-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.1"
-Obsoletes: php71u-%{pecl_name} <= %{version}
-Obsoletes: php71w-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.2"
-Obsoletes: php72u-%{pecl_name} <= %{version}
-Obsoletes: php72w-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.3"
-Obsoletes: php73u-%{pecl_name} <= %{version}
-Obsoletes: php73w-%{pecl_name} <= %{version}
-%endif
-%endif
-
-%if 0%{?fedora} < 20 && 0%{?rhel} < 7
-# Filter shared private
-%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
-%{?filter_setup}
-%endif
-
%description
MaxMind DB is a binary file format that stores data indexed by
@@ -95,13 +54,9 @@ MaxMind\Db\Reader.
Databases are available in geolite2-country and geolite2-city packages.
-Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{?scl_vendor}%{!?scl_vendor:rh})}.
-
-%if %{with_lib}
%package -n php-%{pk_vendor}-%{pk_project}
Summary: MaxMind DB Reader
-Release: %{rpmrel}%{?dist}
BuildArch: noarch
BuildRequires: php-fedora-autoloader-devel
@@ -127,6 +82,9 @@ Requires: php(language) >= 5.4
Recommends: php-bcmath
Recommends: php-gmp
Recommends: php-maxminddb
+# Weak dependencies on databases
+Recommends: geolite2-country
+Suggests: geolite2-city
%endif
# From phpcompatifo report for 1.3.0
Requires: php-filter
@@ -147,17 +105,14 @@ The extension available in php-maxminddb package allow better
performance.
Autoloader: %{_datadir}/php/MaxMind/Db/Reader/autoload.php
-%endif
%prep
%setup -q -n %{gh_project}-%{gh_commit}
-%if %{with_lib}
%{_bindir}/phpab \
--template fedora \
--output src/MaxMind/Db/Reader/autoload.php \
src/MaxMind/Db
-%endif
mv ext NTS
@@ -184,8 +139,6 @@ EOF
%build
-%{?dtsenable}
-
cd NTS
%{_bindir}/phpize
%configure \
@@ -206,8 +159,6 @@ make %{?_smp_mflags}
%install
-%{?dtsenable}
-
# Install the NTS stuff
make -C NTS install INSTALL_ROOT=%{buildroot}
install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
@@ -218,21 +169,27 @@ make -C ZTS install INSTALL_ROOT=%{buildroot}
install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
%endif
-%if %{with_lib}
mkdir -p %{buildroot}%{_datadir}/php/MaxMind
cp -pr src/MaxMind/Db %{buildroot}%{_datadir}/php/MaxMind/Db
-%endif
%check
-ret=0
-
-cd NTS
: Minimal load test for NTS extension
%{__php} --no-php-ini \
--define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
--modules | grep %{pecl_name}
+%if %{with_zts}
+: Minimal load test for ZTS extension
+%{__ztsphp} --no-php-ini \
+ --define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
+ --modules | grep %{pecl_name}
+%endif
+
+%if %{with_tests}
+ret=0
+
+cd NTS
: Upstream test suite for NTS extension
TEST_PHP_EXECUTABLE=%{__php} \
TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_extdir}/%{pecl_name}.so" \
@@ -242,11 +199,6 @@ REPORT_EXIT_STATUS=1 \
%if %{with_zts}
cd ../ZTS
-: Minimal load test for ZTS extension
-%{__ztsphp} --no-php-ini \
- --define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
- --modules | grep %{pecl_name}
-
: Upstream test suite for ZTS extension
TEST_PHP_EXECUTABLE=%{__ztsphp} \
TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so" \
@@ -255,18 +207,13 @@ REPORT_EXIT_STATUS=1 \
%{__ztsphp} -n run-tests.php --show-diff || ret=1
%endif
-%if %{with_lib} && %{with_tests}
cd ..
: Upstream test suite for the library
for cmd in php php56 php70 php71 php72 php73; do
if which $cmd; then
$cmd %{_bindir}/phpunit \
--bootstrap %{buildroot}%{_datadir}/php/MaxMind/Db/Reader/autoload.php \
-%if %{__isa_bits} == 64
--verbose || ret=1
-%else
- --verbose || : ignore per https://github.com/maxmind/MaxMind-DB-Reader-php/issues/77
-%endif
fi
done
@@ -274,7 +221,9 @@ done
php --define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
%{_bindir}/phpunit \
--bootstrap %{buildroot}%{_datadir}/php/MaxMind/Db/Reader/autoload.php \
+%if %{__isa_bits} < 64
--filter '^((?!(testDecoder)).)*$' \
+%endif
--verbose || ret=1
%endif
exit $ret
@@ -294,18 +243,19 @@ exit $ret
%endif
-%if %{with_lib}
%files -n php-%{pk_vendor}-%{pk_project}
%license LICENSE
%doc composer.json
%doc *.md
%dir %{_datadir}/php/MaxMind
%{_datadir}/php/MaxMind/Db
-%endif
%changelog
* Wed Nov 21 2018 Remi Collet <remi@remirepo.net> - 1.4.0-1
+- cleanup for Fedora review
+
+* Wed Nov 21 2018 Remi Collet <remi@remirepo.net> - 1.4.0-1
- update to 1.4.0
- open https://github.com/maxmind/MaxMind-DB-Reader-php/issues/79
to report test failure on 32-bit