summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-12-04 07:43:34 +0100
committerRemi Collet <remi@php.net>2023-12-04 07:43:34 +0100
commit1854538096581e4a86a7b878084b3a791b785201 (patch)
tree1fd2dc6c130cc9573135aba55c919e345236670f
parent4f0ecd649d9349b110ceff7bfbe603d9c5555b9b (diff)
update to 1.11.1HEADmaster
-rw-r--r--PHPINFO4
-rw-r--r--REFLECTION82
-rw-r--r--php-maxminddb.spec13
3 files changed, 69 insertions, 30 deletions
diff --git a/PHPINFO b/PHPINFO
index bae7c65..8cd2e02 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,5 +2,5 @@
maxminddb
MaxMind DB Reader => enabled
-maxminddb extension version => 1.11.0
-libmaxminddb library version => 1.5.2
+maxminddb extension version => 1.11.1
+libmaxminddb library version => 1.8.0
diff --git a/REFLECTION b/REFLECTION
index 84e2310..a369086 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,7 +1,7 @@
-Extension [ <persistent> extension #126 maxminddb version 1.11.0 ] {
+Extension [ <persistent> extension #65 maxminddb version 1.11.1 ] {
- Classes [3] {
- Class [ <internal:maxminddb> class MaxMind\Db\Reader\InvalidDatabaseException extends Exception implements Throwable ] {
+ Class [ <internal:maxminddb> class MaxMind\Db\Reader\InvalidDatabaseException extends Exception implements Throwable, Stringable ] {
- Constants [0] {
}
@@ -13,47 +13,82 @@ Extension [ <persistent> extension #126 maxminddb version 1.11.0 ] {
}
- Properties [4] {
- Property [ <default> protected $message ]
- Property [ <default> protected $code ]
- Property [ <default> protected $file ]
- Property [ <default> protected $line ]
+ Property [ protected $message = '' ]
+ Property [ protected $code = 0 ]
+ Property [ protected string $file = '' ]
+ Property [ protected int $line = 0 ]
}
- Methods [10] {
Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
- Parameters [3] {
- Parameter #0 [ <optional> $message ]
- Parameter #1 [ <optional> $code ]
- Parameter #2 [ <optional> $previous ]
+ Parameter #0 [ <optional> string $message = "" ]
+ Parameter #1 [ <optional> int $code = 0 ]
+ Parameter #2 [ <optional> ?Throwable $previous = null ]
}
}
Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+
+ - Parameters [0] {
+ }
+ - Tentative return [ void ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+
+ - Parameters [0] {
+ }
+ - Return [ ?Throwable ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
+ Method [ <internal:Core, inherits Exception, prototype Stringable> public method __toString ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
}
}
@@ -61,7 +96,7 @@ Extension [ <persistent> extension #126 maxminddb version 1.11.0 ] {
Class [ <internal:maxminddb> class MaxMind\Db\Reader ] {
- Constants [1] {
- Constant [ public string MMDB_LIB_VERSION ] { 1.5.2 }
+ Constant [ public string MMDB_LIB_VERSION ] { 1.8.0 }
}
- Static properties [0] {
@@ -92,6 +127,7 @@ Extension [ <persistent> extension #126 maxminddb version 1.11.0 ] {
- Parameters [1] {
Parameter #0 [ <required> string $ip_address ]
}
+ - Return [ mixed ]
}
Method [ <internal:maxminddb> public method getWithPrefixLen ] {
@@ -99,7 +135,7 @@ Extension [ <persistent> extension #126 maxminddb version 1.11.0 ] {
- Parameters [1] {
Parameter #0 [ <required> string $ip_address ]
}
- - Return [ array or NULL ]
+ - Return [ ?array ]
}
Method [ <internal:maxminddb> public method metadata ] {
@@ -122,17 +158,17 @@ Extension [ <persistent> extension #126 maxminddb version 1.11.0 ] {
}
- Properties [11] {
- Property [ <default> public $binaryFormatMajorVersion ]
- Property [ <default> public $binaryFormatMinorVersion ]
- Property [ <default> public $buildEpoch ]
- Property [ <default> public $databaseType ]
- Property [ <default> public $description ]
- Property [ <default> public $ipVersion ]
- Property [ <default> public $languages ]
- Property [ <default> public $nodeByteSize ]
- Property [ <default> public $nodeCount ]
- Property [ <default> public $recordSize ]
- Property [ <default> public $searchTreeSize ]
+ Property [ public $binaryFormatMajorVersion = NULL ]
+ Property [ public $binaryFormatMinorVersion = NULL ]
+ Property [ public $buildEpoch = NULL ]
+ Property [ public $databaseType = NULL ]
+ Property [ public $description = NULL ]
+ Property [ public $ipVersion = NULL ]
+ Property [ public $languages = NULL ]
+ Property [ public $nodeByteSize = NULL ]
+ Property [ public $nodeCount = NULL ]
+ Property [ public $recordSize = NULL ]
+ Property [ public $searchTreeSize = NULL ]
}
- Methods [1] {
diff --git a/php-maxminddb.spec b/php-maxminddb.spec
index e8ccbbf..ff767e2 100644
--- a/php-maxminddb.spec
+++ b/php-maxminddb.spec
@@ -15,7 +15,7 @@
%endif
%bcond_without tests
-%global gh_commit f7cc1a1472868f25a02636c99d1054232292bc26
+%global gh_commit 1e66f73ffcf25e17c7a910a1317e9720a95497c7
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner maxmind
%global gh_project MaxMind-DB-Reader-php
@@ -30,8 +30,8 @@
Summary: MaxMind DB Reader extension
Name: %{?scl_prefix}php-maxminddb
-Version: 1.11.0
-Release: 5%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Version: 1.11.1
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: Apache-2.0
URL: https://github.com/%{gh_owner}/%{gh_project}
@@ -104,7 +104,7 @@ Recommends: geolite2-country
Suggests: geolite2-city
%endif
# from composer.json "conflict": {
-# "ext-maxminddb": "<1.10.0,>=2.0.0"
+# "ext-maxminddb": "<1.11.1,>=2.0.0"
Conflicts: php-maxminddb < %{version}
# From phpcompatifo report for 1.3.0
Requires: php-filter
@@ -236,7 +236,7 @@ REPORT_EXIT_STATUS=1 \
%if %{with_lib} && %{with tests}
cd ..
: Upstream test suite for the library
-for cmd in php php72 php73 php74 php80 php81; do
+for cmd in php php80 php81 php82 php83; do
if which $cmd; then
$cmd %{_bindir}/phpunit8 \
--bootstrap %{buildroot}%{_datadir}/php/MaxMind/Db/Reader/autoload.php \
@@ -300,6 +300,9 @@ fi
# when using pkgup, CHECK Release!
%changelog
+* Mon Dec 4 2023 Remi Collet <remi@remirepo.net> - 1.11.1-1
+- update to 1.11.1
+
* Fri Sep 29 2023 Remi Collet <remi@remirepo.net> - 1.11.0-5
- add missing dependency on fedora/autoloader