summaryrefslogtreecommitdiffstats
path: root/php-lz4.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-lz4.spec')
-rw-r--r--php-lz4.spec94
1 files changed, 41 insertions, 53 deletions
diff --git a/php-lz4.spec b/php-lz4.spec
index 1b4a1c8..9771762 100644
--- a/php-lz4.spec
+++ b/php-lz4.spec
@@ -1,18 +1,18 @@
# remirepo spec file for php-lz4
#
-# Copyright (c) 2016-2021 Remi Collet
-# License: CC-BY-SA
+# Copyright (c) 2016-2024 Remi Collet
+# License: CC-BY-SA-4.0
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
%if 0%{?scl:1}
-%global sub_prefix %{scl_prefix}
%scl_package php-lz4
%else
%global pkg_name %{name}
%endif
+%bcond_without tests
# To build with PHP 5.x use --without apcu
%bcond_without apcu
@@ -22,23 +22,20 @@
%bcond_with liblz4
%endif
-%global gh_commit 554722c1068a7db15f87a49ab14abae33d4db83d
+%global gh_commit 4835fb5eb2bba6e1a30b8573bca2a5b855b08f64
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner kjdev
%global gh_project php-ext-lz4
-#global gh_date 20160608
%global pecl_name lz4
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global ini_name 40-%{pecl_name}.ini
+%global sources %{gh_project}-%{gh_commit}
+%global _configure ../%{sources}/configure
Summary: LZ4 Extension for PHP
-Name: %{?sub_prefix}php-lz4
-Version: 0.4.3
-%if 0%{?gh_date:1}
-Release: 1%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
-%else
+Name: %{?scl_prefix}php-lz4
+Version: 0.4.4
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
-%endif
License: MIT
Group: Development/Languages
URL: https://github.com/%{gh_owner}/%{gh_project}
@@ -56,24 +53,11 @@ BuildRequires: %{?scl_prefix}php-devel
%if %{with liblz4}
BuildRequires: lz4-devel >= 1.9
%else
-Provides: bundled(lz4) = 1.9.3
+Provides: bundled(lz4) = 1.10.0
%endif
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
-%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
-
-%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
-%if "%{php_version}" > "7.3"
-Obsoletes: php73-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.4"
-Obsoletes: php74-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "8.0"
-Obsoletes: php80-%{pecl_name} <= %{version}
-%endif
-%endif
%description
@@ -84,9 +68,8 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
%prep
%setup -qc
-mv %{gh_project}-%{gh_commit} NTS
-cd NTS
+cd %{sources}
%if %{with liblz4}
# Use the system library
rm -r lz4
@@ -94,15 +77,15 @@ rm -r lz4
# Sanity check, really often broken
extver=$(sed -n '/#define LZ4_EXT_VERSION/{s/.* "//;s/".*$//;p}' php_lz4.h)
-if test "x${extver}" != "x%{version}%{?gh_date:-dev}"; then
- : Error: Upstream extension version is ${extver}, expecting %{version}%{?gh_date:-dev}.
+if test "x${extver}" != "x%{version}"; then
+ : Error: Upstream extension version is ${extver}, expecting %{version}.
exit 1
fi
cd ..
+mkdir NTS
%if %{with_zts}
-# duplicate for ZTS build
-cp -pr NTS ZTS
+mkdir ZTS
%endif
# Drop in the bit of configuration
@@ -115,28 +98,33 @@ EOF
%build
%{?dtsenable}
-cd NTS
-%{_bindir}/phpize
+cd %{sources}
+%{__phpize}
+[ -f Makefile.global ] && GLOBAL=Makefile.global || GLOBAL=build/Makefile.global
+sed -e 's/INSTALL_ROOT/DESTDIR/' -i $GLOBAL
+
+cd ../NTS
%configure \
- --with-php-config=%{_bindir}/php-config \
+ --with-php-config=%{__phpconfig} \
%if %{with liblz4}
--with-lz4-includedir=/usr \
%endif
--with-libdir=%{_lib} \
--enable-lz4
-make %{?_smp_mflags}
+
+%make_build
%if %{with_zts}
cd ../ZTS
-%{_bindir}/zts-phpize
%configure \
- --with-php-config=%{_bindir}/zts-php-config \
+ --with-php-config=%{__ztsphpconfig} \
%if %{with liblz4}
--with-lz4-includedir=/usr \
%endif
--with-libdir=%{_lib} \
--enable-lz4
-make %{?_smp_mflags}
+
+%make_build
%endif
@@ -144,19 +132,19 @@ make %{?_smp_mflags}
%{?dtsenable}
# Install the NTS stuff
-make -C NTS install INSTALL_ROOT=%{buildroot}
+%make_install -C NTS
install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
%if %{with_zts}
# Install the ZTS stuff
-make -C ZTS install INSTALL_ROOT=%{buildroot}
+%make_install -C ZTS
install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
%endif
%check
-cd NTS
+cd %{sources}
: Minimal load test for NTS extension
%{__php} --no-php-ini \
--define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
@@ -172,34 +160,27 @@ cd NTS
--ri apcu | grep '%{pecl_name}'
%endif
+%if %{with tests}
: Upstream test suite for NTS extension
TEST_PHP_EXECUTABLE=%{__php} \
TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_extdir}/%{pecl_name}.so" \
NO_INTERACTION=1 \
REPORT_EXIT_STATUS=1 \
%{__php} -n run-tests.php --show-diff || : ignore
+%endif
%if %{with_zts}
-cd ../ZTS
: Minimal load test for ZTS extension
%{__ztsphp} --no-php-ini \
--define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
--modules | grep '^%{pecl_name}$'
-
-: Upstream test suite for ZTS extension
-TEST_PHP_EXECUTABLE=%{__ztsphp} \
-TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so" \
-NO_INTERACTION=1 \
-REPORT_EXIT_STATUS=1 \
-%{__ztsphp} -n run-tests.php --show-diff
%endif
%files
-%{!?_licensedir:%global license %%doc}
-%license NTS/LICENSE
-%doc NTS/CREDITS
-%doc NTS/README.md
+%license %{sources}/LICENSE
+%doc %{sources}/CREDITS
+%doc %{sources}/README.md
%config(noreplace) %{php_inidir}/%{ini_name}
%{php_extdir}/%{pecl_name}.so
@@ -211,6 +192,13 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Fri Nov 8 2024 Remi Collet <remi@remirepo.net> - 0.4.4-1
+- update to 0.4.4 (no change)
+- update bundled libliz4 to 0.10.0
+
+* Fri Sep 1 2023 Remi Collet <remi@remirepo.net> - 0.4.3-2
+- build out of sources tree
+
* Mon Jan 25 2021 Remi Collet <remi@remirepo.net> - 0.4.3-1
- update to 0.4.3