summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-12-18 07:28:03 +0100
committerRemi Collet <remi@remirepo.net>2020-12-18 07:28:03 +0100
commit261781e4ec0e5e140bc1e16602b5c476ecaeff1f (patch)
tree2eec045c14f3cbb2f6bc4f831415500c6de5f94a
parent829f911bce8ecf4b596ffcf22964d5213de9ec4e (diff)
update to 0.4.1 with bundled liblz4 version 1.9.3
-rw-r--r--PHPINFO4
-rw-r--r--REFLECTION4
-rw-r--r--php-lz4.spec35
3 files changed, 20 insertions, 23 deletions
diff --git a/PHPINFO b/PHPINFO
index 28325ee..6fa3ea8 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,6 +2,6 @@
lz4
LZ4 support => enabled
-Extension Version => 0.4.0
-LZ4 Version => 1.9.2
+Extension Version => 0.4.1
+LZ4 Version => 1.9.3
LZ4 APCu serializer ABI => 0
diff --git a/REFLECTION b/REFLECTION
index 708ed72..22c9a44 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #82 lz4 version 0.4.0 ] {
+Extension [ <persistent> extension #83 lz4 version 0.4.1 ] {
- Dependencies {
Dependency [ apcu (Optional) ]
@@ -7,7 +7,7 @@ Extension [ <persistent> extension #82 lz4 version 0.4.0 ] {
- Constants [3] {
Constant [ int LZ4_CLEVEL_MIN ] { 3 }
Constant [ int LZ4_CLEVEL_MAX ] { 12 }
- Constant [ int LZ4_VERSION ] { 10902 }
+ Constant [ int LZ4_VERSION ] { 10903 }
}
- Functions {
diff --git a/php-lz4.spec b/php-lz4.spec
index 34bb95b..b8b9218 100644
--- a/php-lz4.spec
+++ b/php-lz4.spec
@@ -16,13 +16,13 @@
# To build with PHP 5.x use --without apcu
%bcond_without apcu
-%if 0%{?fedora} >= 32 || 0%{?rhel} >= 9
-%global with_liblz4 1
+%if 0%{?fedora} >= 34 || 0%{?rhel} >= 9
+%bcond_without liblz4
%else
-%global with_liblz4 0
+%bcond_with liblz4
%endif
-%global gh_commit ec815d0e0919a3aa79e5423e3d97393f86bef82f
+%global gh_commit ff946d07e22ab8667ea858159c4f271d04523281
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner kjdev
%global gh_project php-ext-lz4
@@ -33,7 +33,7 @@
Summary: LZ4 Extension for PHP
Name: %{?sub_prefix}php-lz4
-Version: 0.4.0
+Version: 0.4.1
%if 0%{?gh_date:1}
Release: 1%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%else
@@ -53,10 +53,10 @@ BuildRequires: %{?scl_prefix}php-pecl-apcu-devel
%else
BuildRequires: %{?scl_prefix}php-devel
%endif
-%if %{?with_liblz4}
+%if %{with liblz4}
BuildRequires: lz4-devel >= 1.9
%else
-Provides: bundled(lz4) = 1.9.2
+Provides: bundled(lz4) = 1.9.3
%endif
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
@@ -75,12 +75,6 @@ Obsoletes: php80-%{pecl_name} <= %{version}
%endif
%endif
-%if 0%{?fedora} < 20 && 0%{?rhel} < 7
-# Filter shared private
-%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
-%{?filter_setup}
-%endif
-
%description
This extension allows LZ4, a compression/decompression library.
@@ -93,7 +87,7 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
mv %{gh_project}-%{gh_commit} NTS
cd NTS
-%if %{?with_liblz4}
+%if %{with liblz4}
# Use the system library
rm -r lz4
%endif
@@ -125,7 +119,7 @@ cd NTS
%{_bindir}/phpize
%configure \
--with-php-config=%{_bindir}/php-config \
-%if %{?with_liblz4}
+%if %{with liblz4}
--with-lz4-includedir=/usr \
%endif
--with-libdir=%{_lib} \
@@ -137,7 +131,7 @@ cd ../ZTS
%{_bindir}/zts-phpize
%configure \
--with-php-config=%{_bindir}/zts-php-config \
-%if %{?with_liblz4}
+%if %{with liblz4}
--with-lz4-includedir=/usr \
%endif
--with-libdir=%{_lib} \
@@ -166,10 +160,10 @@ cd NTS
: Minimal load test for NTS extension
%{__php} --no-php-ini \
--define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
- --modules | grep %{pecl_name}
+ --modules | grep '^%{pecl_name}$'
%if "%{php_version}" > "7.0"
-: Check that apcu is aware of snappy serializer
+: Check that apcu is aware of lz4 serializer
%{__php} --no-php-ini \
--define extension=apcu.so \
--define apc.enabled=1 \
@@ -190,7 +184,7 @@ cd ../ZTS
: Minimal load test for ZTS extension
%{__ztsphp} --no-php-ini \
--define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
- --modules | grep %{pecl_name}
+ --modules | grep '^%{pecl_name}$'
: Upstream test suite for ZTS extension
TEST_PHP_EXECUTABLE=%{__ztsphp} \
@@ -217,6 +211,9 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Fri Dec 18 2020 Remi Collet <remi@remirepo.net> - 0.4.1-1
+- update to 0.4.1 with bundled liblz4 version 1.9.3
+
* Fri Oct 9 2020 Remi Collet <remi@remirepo.net> - 0.4.0-1
- update to 0.4.0
- enable apcu serializer with PHP 7+