summaryrefslogtreecommitdiffstats
path: root/php-libvirt.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-libvirt.spec')
-rw-r--r--php-libvirt.spec40
1 files changed, 16 insertions, 24 deletions
diff --git a/php-libvirt.spec b/php-libvirt.spec
index 3d7801a..49ec6f8 100644
--- a/php-libvirt.spec
+++ b/php-libvirt.spec
@@ -13,10 +13,20 @@
%scl_package php-libvirt
%endif
+# The change to redhat-rpm-config to force symbols to be defined breaks all PHP extensions
+# c.f.: https://src.fedoraproject.org/rpms/redhat-rpm-config/c/078af192613e1beec34824a94dc5f6feeeea1568
+# c.f.: https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/message/7EHQUO6JIFRE4KIQQMFVQCAQ72NLKARO/
+%undefine _strict_symbol_defs_build
+
+# The change to gcc10 to default to -fno-common breaks libvirt-php
+# c.f.: https://src.fedoraproject.org/rpms/redhat-rpm-config/c/3e759e70ac919595f45c1dc80c19fc8d3499b459
+# c.f.: https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/message/MXKIKAV4GMS22TGAO5Y6ROQ76EG4GKW2/
+%define _legacy_common_support 1
+
%{!?_pkgdocdir: %global _pkgdocdir %{_docdir}/%{name}-%{version}}
# from upstream 1.2.9 (but seems wrong, missing VIR_STORAGE_VOL_CREATE_REFLINK)
-%global req_libvirt_version 1.2.10
+%global req_libvirt_version 1.2.13
%global extname libvirt-php
%if "%{php_version}" < "5.6"
%global ini_name %{extname}.ini
@@ -25,8 +35,8 @@
%endif
Name: %{?sub_prefix}php-libvirt
-Version: 0.5.4
-Release: 5%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Version: 0.5.5
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Summary: PHP language binding for Libvirt
Group: Development/Libraries
@@ -55,27 +65,6 @@ Provides: %{?scl_prefix}php-libvirt%{?_isa} = %{version}-%{release}
%endif
%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
-# Other third party repo stuff
-Obsoletes: php53-libvirt <= %{version}
-Obsoletes: php53u-libvirt <= %{version}
-Obsoletes: php54-libvirt <= %{version}
-Obsoletes: php54w-libvirt <= %{version}
-%if "%{php_version}" > "5.5"
-Obsoletes: php55u-libvirt <= %{version}
-Obsoletes: php55w-libvirt <= %{version}
-%endif
-%if "%{php_version}" > "5.6"
-Obsoletes: php56u-libvirt <= %{version}
-Obsoletes: php56w-libvirt <= %{version}
-%endif
-%if "%{php_version}" > "7.0"
-Obsoletes: php70u-libvirt <= %{version}
-Obsoletes: php70w-libvirt <= %{version}
-%endif
-%if "%{php_version}" > "7.1"
-Obsoletes: php71u-libvirt <= %{version}
-Obsoletes: php71w-libvirt <= %{version}
-%endif
%if "%{php_version}" > "7.2"
Obsoletes: php72u-libvirt <= %{version}
Obsoletes: php72w-libvirt <= %{version}
@@ -173,6 +162,9 @@ rm %{buildroot}%{php_extdir}/%{extname}.la
%changelog
+* Sun Feb 9 2020 Remi Collet <remi@remirepo.net> - 0.5.5-1
+- Upgrade to 0.5.5
+
* Tue Sep 03 2019 Remi Collet <remi@remirepo.net> - 0.5.4-5
- rebuild for 7.4.0RC1