summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-05-11 19:35:12 +0200
committerRemi Collet <remi@remirepo.net>2017-05-11 19:35:12 +0200
commitd7fbfb65c5fc35409db292cbc860cd9a5d30e2c0 (patch)
treece5b79e70cc93ae8a86e4acb08473c803250d9e3
parent4b78dd7f1889c211084663a4a7baf953c8b0d164 (diff)
v0.5.3 (backported from Fedora)
-rw-r--r--.gitignore7
-rw-r--r--REFLECTION105
-rw-r--r--php-libvirt.spec38
3 files changed, 126 insertions, 24 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..1ab5c4f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/REFLECTION b/REFLECTION
index 31d2e69..e567a2a 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #122 libvirt version 0.5.2 ] {
+Extension [ <persistent> extension #102 libvirt version 0.5.3 ] {
- INI {
Entry [ libvirt.longlong_to_string <ALL> ]
@@ -15,7 +15,7 @@ Extension [ <persistent> extension #122 libvirt version 0.5.2 ] {
}
}
- - Constants [167] {
+ - Constants [183] {
Constant [ integer VIR_DOMAIN_XML_SECURE ] { 1 }
Constant [ integer VIR_DOMAIN_XML_INACTIVE ] { 2 }
Constant [ integer VIR_DOMAIN_XML_UPDATE_CPU ] { 4 }
@@ -78,6 +78,12 @@ Extension [ <persistent> extension #122 libvirt version 0.5.2 ] {
Constant [ integer VIR_NETWORKS_ACTIVE ] { 1 }
Constant [ integer VIR_NETWORKS_INACTIVE ] { 2 }
Constant [ integer VIR_NETWORKS_ALL ] { 3 }
+ Constant [ integer VIR_CONNECT_LIST_NETWORKS_INACTIVE ] { 1 }
+ Constant [ integer VIR_CONNECT_LIST_NETWORKS_ACTIVE ] { 2 }
+ Constant [ integer VIR_CONNECT_LIST_NETWORKS_PERSISTENT ] { 4 }
+ Constant [ integer VIR_CONNECT_LIST_NETWORKS_TRANSIENT ] { 8 }
+ Constant [ integer VIR_CONNECT_LIST_NETWORKS_AUTOSTART ] { 16 }
+ Constant [ integer VIR_CONNECT_LIST_NETWORKS_NO_AUTOSTART ] { 32 }
Constant [ integer VIR_CRED_USERNAME ] { 1 }
Constant [ integer VIR_CRED_AUTHNAME ] { 2 }
Constant [ integer VIR_CRED_LANGUAGE ] { 3 }
@@ -177,12 +183,22 @@ Extension [ <persistent> extension #122 libvirt version 0.5.2 ] {
Constant [ integer VIR_CONNECT_GET_ALL_DOMAINS_STATS_RUNNING ] { 16 }
Constant [ integer VIR_CONNECT_GET_ALL_DOMAINS_STATS_SHUTOFF ] { 64 }
Constant [ integer VIR_CONNECT_GET_ALL_DOMAINS_STATS_TRANSIENT ] { 8 }
- Constant [ integer VIR_CONNECT_GET_ALL_DOMAINS_STATS_ENFORCE_STATS ] { -2147483648 }
+ Constant [ integer VIR_CONNECT_GET_ALL_DOMAINS_STATS_ENFORCE_STATS ] { 2147483648 }
Constant [ integer VIR_DOMAIN_MEM_CONFIG ] { 2 }
Constant [ integer VIR_DOMAIN_MEM_CURRENT ] { 0 }
Constant [ integer VIR_DOMAIN_MEM_LIVE ] { 1 }
Constant [ integer VIR_DOMAIN_MEM_MAXIMUM ] { 4 }
Constant [ integer VIR_CONNECT_FLAG_SOUNDHW_GET_NAMES ] { 1 }
+ Constant [ integer VIR_KEYCODE_SET_LINUX ] { 0 }
+ Constant [ integer VIR_KEYCODE_SET_XT ] { 1 }
+ Constant [ integer VIR_KEYCODE_SET_ATSET1 ] { 2 }
+ Constant [ integer VIR_KEYCODE_SET_ATSET2 ] { 3 }
+ Constant [ integer VIR_KEYCODE_SET_ATSET3 ] { 4 }
+ Constant [ integer VIR_KEYCODE_SET_OSX ] { 5 }
+ Constant [ integer VIR_KEYCODE_SET_XT_KBD ] { 6 }
+ Constant [ integer VIR_KEYCODE_SET_USB ] { 7 }
+ Constant [ integer VIR_KEYCODE_SET_WIN32 ] { 8 }
+ Constant [ integer VIR_KEYCODE_SET_RFB ] { 9 }
}
- Functions {
@@ -314,19 +330,19 @@ Extension [ <persistent> extension #122 libvirt version 0.5.2 ] {
Parameter #0 [ <required> $conn ]
}
}
- Function [ <internal:libvirt> function libvirt_stream_send ] {
+ Function [ <internal:libvirt> function &libvirt_stream_send ] {
- Parameters [3] {
Parameter #0 [ <required> $conn ]
- Parameter #1 [ <required> $data ]
+ Parameter #1 [ <required> &$data ]
Parameter #2 [ <optional> $len ]
}
}
- Function [ <internal:libvirt> function libvirt_stream_recv ] {
+ Function [ <internal:libvirt> function &libvirt_stream_recv ] {
- Parameters [3] {
Parameter #0 [ <required> $conn ]
- Parameter #1 [ <required> $data ]
+ Parameter #1 [ <required> &$data ]
Parameter #2 [ <optional> $len ]
}
}
@@ -451,6 +467,22 @@ Extension [ <persistent> extension #122 libvirt version 0.5.2 ] {
Parameter #2 [ <optional> $flags ]
}
}
+ Function [ <internal:libvirt> function libvirt_domain_attach_device ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $conn ]
+ Parameter #1 [ <required> $xml ]
+ Parameter #2 [ <optional> $flags ]
+ }
+ }
+ Function [ <internal:libvirt> function libvirt_domain_detach_device ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $conn ]
+ Parameter #1 [ <required> $xml ]
+ Parameter #2 [ <optional> $flags ]
+ }
+ }
Function [ <internal:libvirt> function libvirt_domain_get_info ] {
- Parameters [1] {
@@ -573,6 +605,22 @@ Extension [ <persistent> extension #122 libvirt version 0.5.2 ] {
Parameter #1 [ <required> $xml ]
}
}
+ Function [ <internal:libvirt> function libvirt_domain_xml_from_native ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $conn ]
+ Parameter #1 [ <required> $format ]
+ Parameter #2 [ <required> $config_data ]
+ }
+ }
+ Function [ <internal:libvirt> function libvirt_domain_xml_to_native ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $conn ]
+ Parameter #1 [ <required> $format ]
+ Parameter #2 [ <required> $xml_data ]
+ }
+ }
Function [ <internal:libvirt> function libvirt_domain_memory_peek ] {
- Parameters [4] {
@@ -616,7 +664,7 @@ Extension [ <persistent> extension #122 libvirt version 0.5.2 ] {
- Parameters [4] {
Parameter #0 [ <required> $res ]
Parameter #1 [ <required> $disk ]
- Parameter #2 [ <required> $base ]
+ Parameter #2 [ <optional> $base ]
Parameter #3 [ <optional> $top ]
}
}
@@ -809,6 +857,16 @@ Extension [ <persistent> extension #122 libvirt version 0.5.2 ] {
Parameter #2 [ <required> $scancode ]
}
}
+ Function [ <internal:libvirt> function libvirt_domain_send_key_api ] {
+
+ - Parameters [5] {
+ Parameter #0 [ <required> $conn ]
+ Parameter #1 [ <required> $codeset ]
+ Parameter #2 [ <required> $holdime ]
+ Parameter #3 [ <required> $keycodes ]
+ Parameter #4 [ <optional> $flags ]
+ }
+ }
Function [ <internal:libvirt> function libvirt_domain_send_pointer_event ] {
- Parameters [6] {
@@ -1128,6 +1186,24 @@ Extension [ <persistent> extension #122 libvirt version 0.5.2 ] {
Parameter #1 [ <optional> $flags ]
}
}
+ Function [ <internal:libvirt> function libvirt_network_get_uuid_string ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $conn ]
+ }
+ }
+ Function [ <internal:libvirt> function libvirt_network_get_uuid ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $conn ]
+ }
+ }
+ Function [ <internal:libvirt> function libvirt_network_get_name ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $conn ]
+ }
+ }
Function [ <internal:libvirt> function libvirt_node_get_info ] {
- Parameters [1] {
@@ -1154,6 +1230,12 @@ Extension [ <persistent> extension #122 libvirt version 0.5.2 ] {
Parameter #0 [ <required> $conn ]
}
}
+ Function [ <internal:libvirt> function libvirt_node_get_free_memory ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $conn ]
+ }
+ }
Function [ <internal:libvirt> function libvirt_nodedev_get ] {
- Parameters [1] {
@@ -1205,6 +1287,13 @@ Extension [ <persistent> extension #122 libvirt version 0.5.2 ] {
Parameter #1 [ <optional> $cap ]
}
}
+ Function [ <internal:libvirt> function libvirt_list_all_networks ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $conn ]
+ Parameter #1 [ <optional> $flags ]
+ }
+ }
Function [ <internal:libvirt> function libvirt_list_networks ] {
- Parameters [2] {
diff --git a/php-libvirt.spec b/php-libvirt.spec
index cf162d7..886ccdb 100644
--- a/php-libvirt.spec
+++ b/php-libvirt.spec
@@ -3,9 +3,6 @@
#
# Fedora spec file for php-libvirt
#
-# Copyright (c) 2012-2017 Remi Collet
-# Copyright (c) 2011 Michal Novotny
-#
# License: MIT
# http://opensource.org/licenses/MIT
#
@@ -28,12 +25,13 @@
%endif
Name: %{?sub_prefix}php-libvirt
-Version: 0.5.2
-Release: 4%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Version: 0.5.3
+Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Summary: PHP language binding for Libvirt
Group: Development/Libraries
-License: PHP
+# libvirt-php is under the same terms as libvirt
+License: LGPLv2+
URL: http://libvirt.org/php
Source0: http://libvirt.org/sources/php/libvirt-php-%{version}.tar.gz
@@ -41,6 +39,8 @@ BuildRequires: %{?scl_prefix}php-devel
BuildRequires: libvirt-devel >= %{req_libvirt_version}
BuildRequires: libxml2-devel
BuildRequires: libxslt
+# obviously NOT needed, checked by configure as used by examples :(
+BuildRequires: %{?scl_prefix}php-pecl-imagick
BuildRequires: xhtml1-dtds
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
@@ -75,6 +75,10 @@ Obsoletes: php70w-libvirt <= %{version}
Obsoletes: php71u-libvirt <= %{version}
Obsoletes: php71w-libvirt <= %{version}
%endif
+%if "%{php_version}" > "7.2"
+Obsoletes: php72u-libvirt <= %{version}
+Obsoletes: php72w-libvirt <= %{version}
+%endif
%endif
# Filter shared private - always as libvirt-php.so is a very bad name
@@ -92,12 +96,8 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
%package doc
Summary: Document of php-libvirt
Group: Development/Libraries
-%if 0%{?fedora} >= 11 || 0%{?rhel} >= 6
BuildArch: noarch
Requires: %{name} = %{version}-%{release}
-%else
-Requires: %{name}%{_isa} = %{version}-%{release}
-%endif
%if "%{?scl_prefix}" != "%{?sub_prefix}"
Provides: %{?scl_prefix}php-libvirt-doc = %{version}-%{release}
Provides: %{?scl_prefix}php-libvirt-doc%{?_isa} = %{version}-%{release}
@@ -115,7 +115,9 @@ This package contain the document for php-libvirt.
%build
+%{?dtsenable}
%{?scl:. %{_scl_scripts}/enable}
+
%configure \
--with-html-dir=%{_docdir} \
--with-html-subdir=$(echo %{_pkgdocdir} | sed -e 's|^%{_docdir}/||')/html \
@@ -124,7 +126,9 @@ make %{?_smp_mflags}
%install
+%{?dtsenable}
%{?scl:. %{_scl_scripts}/enable}
+
make install DESTDIR=%{buildroot}
install -pm 644 COPYING %{buildroot}%{_pkgdocdir}
@@ -137,17 +141,13 @@ else
install -Dpm 644 src/libvirt-php.ini %{buildroot}%{php_inidir}/%{ini_name}
fi
-: Fix installation
+# Erase unnecessary libtool archive file
rm %{buildroot}%{php_extdir}/%{extname}.la
-rm %{buildroot}%{php_extdir}/%{extname}.so
-rm %{buildroot}%{php_extdir}/%{extname}.so.0
-mv %{buildroot}%{php_extdir}/%{extname}.so.0.0.0 %{buildroot}%{php_extdir}/%{extname}.so
%check
: simple module load test
-%{?scl:. %{_scl_scripts}/enable}
-php --no-php-ini \
+%{__php} --no-php-ini \
--define extension=%{buildroot}%{php_extdir}/%{extname}.so \
--modules | grep libvirt
@@ -164,6 +164,12 @@ php --no-php-ini \
%changelog
+* Thu May 11 2017 Neal Gompa <ngompa13@gmail.com> - 0.5.3-2
+- Fix license tag to match actual source license
+
+* Thu May 11 2017 Neal Gompa <ngompa13@gmail.com> - 0.5.3-1
+- Upgrade to 0.5.3
+
* Thu Dec 1 2016 Remi Collet <remi@fedoraproject.org> - 0.5.2-4
- rebuild with PHP 7.1.0 GA