summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2024-01-23 14:19:42 +0100
committerRemi Collet <remi@php.net>2024-01-23 14:19:42 +0100
commit32566f939df17843d1735ce18e7ad6fdb6e752c1 (patch)
tree004bb5f53386d99b9c53ca957ebb2664173204cd
parent33da3cf9758e18559ea65f916a608319e5247355 (diff)
Upgrade to 0.5.8HEADmaster
-rw-r--r--PHPINFO4
-rw-r--r--REFLECTION61
-rw-r--r--php-libvirt.spec20
3 files changed, 70 insertions, 15 deletions
diff --git a/PHPINFO b/PHPINFO
index 679c8cd..21fb03e 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -3,8 +3,8 @@ libvirt
Libvirt support => enabled
Debug support => enabled, default maximum log file size: 1024 KiB
-Extension version => 0.5.7
-Libvirt version => 7.6.0
+Extension version => 0.5.8
+Libvirt version => 9.7.0
Max. connections => 5
ISO Image path => /var/lib/libvirt/images
Path for images => /var/lib/libvirt/images
diff --git a/REFLECTION b/REFLECTION
index 9548039..08cbf47 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #123 libvirt version 0.5.7 ] {
+Extension [ <persistent> extension #70 libvirt version 0.5.8 ] {
- INI {
Entry [ libvirt.longlong_to_string <ALL> ]
@@ -18,7 +18,7 @@ Extension [ <persistent> extension #123 libvirt version 0.5.7 ] {
}
}
- - Constants [193] {
+ - Constants [199] {
Constant [ int VIR_DOMAIN_XML_SECURE ] { 1 }
Constant [ int VIR_DOMAIN_XML_INACTIVE ] { 2 }
Constant [ int VIR_DOMAIN_XML_UPDATE_CPU ] { 4 }
@@ -139,6 +139,9 @@ Extension [ <persistent> extension #123 libvirt version 0.5.7 ] {
Constant [ int VIR_DOMAIN_BLOCK_REBASE_COPY_DEV ] { 32 }
Constant [ int VIR_DOMAIN_BLOCK_REBASE_BANDWIDTH_BYTES ] { 64 }
Constant [ int VIR_DOMAIN_BLOCK_RESIZE_BYTES ] { 1 }
+ Constant [ string VIR_DOMAIN_BLOCK_COPY_BANDWIDTH ] { bandwidth }
+ Constant [ string VIR_DOMAIN_BLOCK_COPY_GRANULARITY ] { granularity }
+ Constant [ string VIR_DOMAIN_BLOCK_COPY_BUF_SIZE ] { buf-size }
Constant [ int VIR_MIGRATE_LIVE ] { 1 }
Constant [ int VIR_MIGRATE_PEER2PEER ] { 2 }
Constant [ int VIR_MIGRATE_TUNNELLED ] { 4 }
@@ -212,6 +215,9 @@ Extension [ <persistent> extension #123 libvirt version 0.5.7 ] {
Constant [ int VIR_DOMAIN_UNDEFINE_SNAPSHOTS_METADATA ] { 2 }
Constant [ int VIR_DOMAIN_UNDEFINE_NVRAM ] { 4 }
Constant [ int VIR_DOMAIN_UNDEFINE_KEEP_NVRAM ] { 8 }
+ Constant [ int VIR_DOMAIN_UNDEFINE_CHECKPOINTS_METADATA ] { 16 }
+ Constant [ int VIR_DOMAIN_UNDEFINE_TPM ] { 32 }
+ Constant [ int VIR_DOMAIN_UNDEFINE_KEEP_TPM ] { 64 }
}
- Functions {
@@ -248,6 +254,18 @@ Extension [ <persistent> extension #123 libvirt version 0.5.7 ] {
Parameter #1 [ <optional> $xpath = <default> ]
}
}
+ Function [ <internal:libvirt> function libvirt_connect_get_domain_capabilities ] {
+
+ - Parameters [7] {
+ Parameter #0 [ <required> $conn ]
+ Parameter #1 [ <optional> $emulatorbin = <default> ]
+ Parameter #2 [ <optional> $arch = <default> ]
+ Parameter #3 [ <optional> $machine = <default> ]
+ Parameter #4 [ <optional> $virttype = <default> ]
+ Parameter #5 [ <optional> $flags = <default> ]
+ Parameter #6 [ <optional> $xpath = <default> ]
+ }
+ }
Function [ <internal:libvirt> function libvirt_connect_get_emulator ] {
- Parameters [2] {
@@ -395,9 +413,8 @@ Extension [ <persistent> extension #123 libvirt version 0.5.7 ] {
}
Function [ <internal:libvirt> function libvirt_domain_get_xml_desc ] {
- - Parameters [2] {
+ - Parameters [1] {
Parameter #0 [ <required> $conn ]
- Parameter #1 [ <optional> $xpath = <default> ]
}
}
Function [ <internal:libvirt> function libvirt_domain_get_disk_devices ] {
@@ -689,6 +706,34 @@ Extension [ <persistent> extension #123 libvirt version 0.5.7 ] {
Parameter #3 [ <optional> $top = <default> ]
}
}
+ Function [ <internal:libvirt> function libvirt_domain_block_copy ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $res ]
+ Parameter #1 [ <required> $disk ]
+ Parameter #2 [ <required> $destxml ]
+ Parameter #3 [ <optional> $params = <default> ]
+ }
+ }
+ Function [ <internal:libvirt> function libvirt_domain_block_pull ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $res ]
+ Parameter #1 [ <required> $disk ]
+ Parameter #2 [ <optional> $bandwidth = <default> ]
+ Parameter #3 [ <optional> $flags = <default> ]
+ }
+ }
+ Function [ <internal:libvirt> function libvirt_domain_block_rebase ] {
+
+ - Parameters [5] {
+ Parameter #0 [ <required> $res ]
+ Parameter #1 [ <required> $disk ]
+ Parameter #2 [ <required> $base ]
+ Parameter #3 [ <optional> $bandwidth = <default> ]
+ Parameter #4 [ <optional> $flags = <default> ]
+ }
+ }
Function [ <internal:libvirt> function libvirt_domain_block_stats ] {
- Parameters [2] {
@@ -981,6 +1026,14 @@ Extension [ <persistent> extension #123 libvirt version 0.5.7 ] {
Parameter #1 [ <optional> $flags = <default> ]
}
}
+ Function [ <internal:libvirt> function libvirt_domain_snapshot_create_xml ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $conn ]
+ Parameter #1 [ <required> $xml ]
+ Parameter #2 [ <optional> $flags = <default> ]
+ }
+ }
Function [ <internal:libvirt> function libvirt_domain_snapshot_current ] {
- Parameters [2] {
diff --git a/php-libvirt.spec b/php-libvirt.spec
index b4d3866..100d595 100644
--- a/php-libvirt.spec
+++ b/php-libvirt.spec
@@ -13,21 +13,21 @@
%{!?_pkgdocdir: %global _pkgdocdir %{_docdir}/%{name}-%{version}}
-# from upstream 1.2.9 (but seems wrong, missing VIR_STORAGE_VOL_CREATE_REFLINK)
-%global req_libvirt_version 1.2.13
+# from upstream 1.2.13 (but seems wrong, missing VIR_DOMAIN_UNDEFINE_CHECKPOINTS_METADATA)
+# no more supported on EL-7
+%global req_libvirt_version 8
%global extname libvirt-php
%global ini_name 40-%{extname}.ini
Name: %{?scl_prefix}php-libvirt
-Version: 0.5.7
-Release: 3%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Version: 0.5.8
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Summary: PHP language binding for Libvirt
-Group: Development/Libraries
# libvirt-php is under the same terms as libvirt
License: LGPL-2.1-or-later
-URL: http://libvirt.org/php
-Source0: http://libvirt.org/sources/php/libvirt-php-%{version}.tar.xz
+URL: https://php.libvirt.org/
+Source0: https://download.libvirt.org/php/libvirt-php-%{version}.tar.xz
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
@@ -54,13 +54,12 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
%package doc
Summary: Document of php-libvirt
-Group: Development/Libraries
BuildArch: noarch
Requires: %{name} = %{version}-%{release}
%description doc
PHP language bindings for Libvirt API.
-For more details see: http://www.libvirt.org/php/ http://www.php.net/
+For more details see: https://php.libvirt.org/ http://www.php.net/
This package contain the document for php-libvirt.
@@ -117,6 +116,9 @@ rm %{buildroot}%{php_extdir}/%{extname}.la
%changelog
+* Tue Jan 23 2024 Remi Collet <remi@remirepo.net> - 0.5.8-1
+- Upgrade to 0.5.8
+
* Wed Aug 30 2023 Remi Collet <remi@remirepo.net> - 0.5.7-3
- rebuild for PHP 8.3.0RC1