summaryrefslogtreecommitdiffstats
path: root/php-jsonlint.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-jsonlint.spec')
-rw-r--r--php-jsonlint.spec13
1 files changed, 8 insertions, 5 deletions
diff --git a/php-jsonlint.spec b/php-jsonlint.spec
index 7be26eb..44808b4 100644
--- a/php-jsonlint.spec
+++ b/php-jsonlint.spec
@@ -13,8 +13,8 @@
%global github_owner Seldaek
%global github_name jsonlint
-%global github_version 1.7.1
-%global github_commit d15f59a67ff805a44c50ea0516d2341740f81a38
+%global github_version 1.7.2
+%global github_commit e2e5d290e4d2a4f0eb449f510071392e00e10d19
# "php": "^5.3 || ^7.0"
%global php_min_ver 5.3
@@ -39,7 +39,7 @@ BuildArch: noarch
%if %{with_tests}
# For tests: composer.json
BuildRequires: php(language) >= %{php_min_ver}
-%if 0%{?fedora} >= 26
+%if 0%{?fedora} >= 29 || 0%{?rhel} >= 8
%global phpunit %{_bindir}/phpunit6
BuildRequires: phpunit6
%else
@@ -80,7 +80,7 @@ Autoloader: %{_datadir}/php/Seld/JsonLint/autoload.php
%prep
%setup -q -n %{github_name}-%{github_commit}
-%patch0 -p1
+%patch0 -p1 -b .rpm
%build
@@ -108,7 +108,7 @@ install -pm 0755 bin/jsonlint %{buildroot}%{_bindir}/jsonlint-php
%if %{with_tests}
ret=0
-for cmd in "php %{phpunit}" "php56 %{_bindir}/phpunit" php70 php71 php72; do
+for cmd in "php %{phpunit}" "php56 %{_bindir}/phpunit" php70 php71 php72 php73 php74; do
if which $cmd; then
set $cmd
$1 ${2:-%{_bindir}/phpunit6} \
@@ -134,6 +134,9 @@ exit $ret
%changelog
+* Fri Oct 25 2019 Remi Collet <remi@remirepo.net> - 1.7.2-1
+- update to 1.7.2
+
* Wed Jan 24 2018 Remi Collet <remi@remirepo.net> - 1.7.1-1
- Update to 1.7.1 (no change)