summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2013-02-13 10:40:13 +0100
committerRemi Collet <fedora@famillecollet.com>2013-02-13 10:40:13 +0100
commitc61e3c0ed6b8aeb2d8f276fd71c9f71850601ce4 (patch)
tree941161217ce8d068bea7e899afcd59d3cf761473
parent79322fa6b59d1f6f61dc611b4f5a5273ea959a8d (diff)
php-jsonlint: backport 1.1.1
-rw-r--r--php-jsonlint.spec37
1 files changed, 24 insertions, 13 deletions
diff --git a/php-jsonlint.spec b/php-jsonlint.spec
index 18e2b1e..c084b4b 100644
--- a/php-jsonlint.spec
+++ b/php-jsonlint.spec
@@ -1,26 +1,30 @@
-%global libname jsonlint
-%global php_min_ver 5.3.0
+%global github_owner Seldaek
+%global github_name jsonlint
+%global github_version 1.1.1
+%global github_commit 2b5b57008ec93148fa46110d42c7a201a6677fe0
-Name: php-%{libname}
-Version: 1.1.0
+%global php_min_ver 5.3.0
+
+Name: php-%{github_name}
+Version: %{github_version}
Release: 1%{?dist}
Summary: JSON Lint for PHP
Group: Development/Libraries
License: MIT
-URL: https://github.com/Seldaek/%{libname}
-Source0: %{url}/archive/%{version}.tar.gz
+URL: https://github.com/%{github_owner}/%{github_name}
+Source0: %{url}/archive/%{github_commit}/%{name}-%{github_version}-%{github_commit}.tar.gz
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
-# Test build requires
+# For tests
BuildRequires: php(language) >= %{php_min_ver}
BuildRequires: php-pear(pear.phpunit.de/PHPUnit)
-# Test build requires: phpci
+# For tests: phpci
BuildRequires: php-pcre
Requires: php(language) >= %{php_min_ver}
-# phpci requires
+# phpci
Requires: php-pcre
%description
@@ -31,7 +35,7 @@ This library is a port of the JavaScript jsonlint
%prep
-%setup -q -n %{libname}-%{version}
+%setup -q -n %{github_name}-%{github_commit}
# Create PSR-0 autoloader for tests
( cat <<'AUTOLOAD'
@@ -54,8 +58,8 @@ cp -rp src/Seld/JsonLint %{buildroot}%{_datadir}/php/Seld/
%check
-%{_bindir}/phpunit --bootstrap=autoload.php \
- -d include_path="src:tests:.:/usr/share/pear" .
+%{_bindir}/phpunit --bootstrap=./autoload.php \
+ -d include_path="./src:./tests:.:%{pear_phpdir}" .
%files
@@ -66,8 +70,15 @@ cp -rp src/Seld/JsonLint %{buildroot}%{_datadir}/php/Seld/
%changelog
+* Wed Feb 13 2013 Remi Collet <RPMS@FamilleCollet.com> - 1.1.1-1
+- backport 1.1.1 for remi repo
+
+* Tue Feb 12 2013 Shawn Iwinski <shawn.iwinski@gmail.com> 1.1.1-1
+- Updated to upstream version 1.1.1
+- Updates per new Fedora packaging guidelines for Git repos
+
* Wed Jan 9 2013 Remi Collet <RPMS@FamilleCollet.com> - 1.1.0-1
- backport for remi repo
-* Mon Jan 7 2013 Shawn Iwinski <shawn.iwinski@gmail.com> 1.1.0-1
+* Mon Jan 07 2013 Shawn Iwinski <shawn.iwinski@gmail.com> 1.1.0-1
- Initial package