summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-11-15 06:09:43 +0100
committerRemi Collet <fedora@famillecollet.com>2016-11-15 06:09:43 +0100
commit6f9830cc6362f68434185ea710509e3d3c26979a (patch)
treef501deee6ca687000426a6cf95ddf36cc06b4d3f
parent966e9d6ac91779ae02c14bf99a00f32d808c2919 (diff)
php-jsonlint: 1.5.0
-rw-r--r--php-jsonlint-php71.patch64
-rw-r--r--php-jsonlint.spec17
2 files changed, 9 insertions, 72 deletions
diff --git a/php-jsonlint-php71.patch b/php-jsonlint-php71.patch
deleted file mode 100644
index a1a4dc2..0000000
--- a/php-jsonlint-php71.patch
+++ /dev/null
@@ -1,64 +0,0 @@
-From d73abd9196d739099a26c4daf6dc4eb094824db5 Mon Sep 17 00:00:00 2001
-From: Remi Collet <fedora@famillecollet.com>
-Date: Mon, 14 Nov 2016 18:13:11 +0100
-Subject: [PATCH] fix for 7.1 (_empty_ no more used)
-
----
- src/Seld/JsonLint/JsonParser.php | 12 ++++++++++--
- tests/JsonParserTest.php | 6 ++++++
- 2 files changed, 16 insertions(+), 2 deletions(-)
-
-diff --git a/src/Seld/JsonLint/JsonParser.php b/src/Seld/JsonLint/JsonParser.php
-index acc1868..fc306a5 100644
---- a/src/Seld/JsonLint/JsonParser.php
-+++ b/src/Seld/JsonLint/JsonParser.php
-@@ -376,7 +376,11 @@ private function performAction(stdClass $yyval, $yytext, $yyleng, $yylineno, $yy
- $yyval->token = array($tokens[$len-2], $tokens[$len]);
- break;
- case 16:
-- $property = $tokens[$len][0] === '' ? '_empty_' : $tokens[$len][0];
-+ if (PHP_VERSION_ID < 70100) {
-+ $property = $tokens[$len][0] === '' ? '_empty_' : $tokens[$len][0];
-+ } else {
-+ $property = $tokens[$len][0];
-+ }
- if ($this->flags & self::PARSE_TO_ASSOC) {
- $yyval->token = array();
- $yyval->token[$property] = $tokens[$len][1];
-@@ -404,7 +408,11 @@ private function performAction(stdClass $yyval, $yytext, $yyleng, $yylineno, $yy
- $tokens[$len-2][$key] = $tokens[$len][1];
- } else {
- $yyval->token = $tokens[$len-2];
-- $key = $tokens[$len][0] === '' ? '_empty_' : $tokens[$len][0];
-+ if (PHP_VERSION_ID < 70100) {
-+ $key = $tokens[$len][0] === '' ? '_empty_' : $tokens[$len][0];
-+ } else {
-+ $key = $tokens[$len][0];
-+ }
- if (($this->flags & self::DETECT_KEY_CONFLICTS) && isset($tokens[$len-2]->{$key})) {
- $errStr = 'Parse error on line ' . ($yylineno+1) . ":\n";
- $errStr .= $this->lexer->showPosition() . "\n";
-diff --git a/tests/JsonParserTest.php b/tests/JsonParserTest.php
-index 1c00ff4..a993d17 100644
---- a/tests/JsonParserTest.php
-+++ b/tests/JsonParserTest.php
-@@ -154,6 +154,9 @@ public function testDetectsKeyOverridesWithEmpty()
- {
- $parser = new JsonParser();
-
-+ if (PHP_VERSION_ID >= 70100) {
-+ $this->markTestSkipped('Only for PHP < 7.1');
-+ }
- try {
- $parser->parse('{"":"b", "_empty_":"a"}', JsonParser::DETECT_KEY_CONFLICTS);
- $this->fail('Duplicate keys should not be allowed');
-@@ -182,6 +185,9 @@ public function testDuplicateKeysWithEmpty()
- {
- $parser = new JsonParser();
-
-+ if (PHP_VERSION_ID >= 70100) {
-+ $this->markTestSkipped('Only for PHP < 7.1');
-+ }
- $result = $parser->parse('{"":"a", "_empty_":"b"}', JsonParser::ALLOW_DUPLICATE_KEYS);
- $this->assertThat($result,
- $this->logicalAnd(
diff --git a/php-jsonlint.spec b/php-jsonlint.spec
index a69d4f9..ee65d41 100644
--- a/php-jsonlint.spec
+++ b/php-jsonlint.spec
@@ -13,8 +13,8 @@
%global github_owner Seldaek
%global github_name jsonlint
-%global github_version 1.4.1
-%global github_commit e827b5254d3e58c736ea2c5616710983d80b0b70
+%global github_version 1.5.0
+%global github_commit 19495c181d6d53a0a13414154e52817e3b504189
# "php": "^5.3 || ^7.0"
%global php_min_ver 5.3
@@ -24,7 +24,7 @@
Name: php-%{github_name}
Version: %{github_version}
-Release: 3%{?dist}
+Release: 1%{?dist}
Summary: JSON Lint for PHP
Group: Development/Libraries
@@ -37,8 +37,6 @@ Source1: %{name}-autoload.php
# Bin usage without Composer autoloader
Patch0: %{name}-bin-without-composer-autoloader.patch
-# https://github.com/Seldaek/jsonlint/pull/37
-Patch1: %{name}-php71.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
@@ -46,14 +44,15 @@ BuildArch: noarch
# For tests: composer.json
BuildRequires: php(language) >= %{php_min_ver}
BuildRequires: php-composer(phpunit/phpunit)
-# For tests: phpcompatinfo (computed from version 1.3.1)
+# For tests: phpcompatinfo (computed from version 1.5.0)
+BuildRequires: php-json
BuildRequires: php-pcre
# For autoloader
BuildRequires: php-composer(fedora/autoloader)
%endif
Requires: php(language) >= %{php_min_ver}
-# phpcompatinfo (computed from version 1.3.1)
+# phpcompatinfo (computed from version 1.5.0)
Requires: php-cli
Requires: php-pcre
# For autoloader
@@ -77,7 +76,6 @@ To use this library, you just have to add, in your project:
cp %{SOURCE1} src/Seld/JsonLint/autoload.php
%patch0 -p1
-%patch1 -p1
%build
@@ -131,6 +129,9 @@ exit $ret
%changelog
+* Tue Nov 15 2016 Remi Collet <remi@fedoraproject.org> - 1.5.0-1
+- update to 1.5.0
+
* Mon Nov 14 2016 Remi Collet <remi@fedoraproject.org> - 1.4.1-3
- add patch for PHP 7.1
open https://github.com/Seldaek/jsonlint/pull/37