summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-01-04 10:17:54 +0100
committerRemi Collet <remi@remirepo.net>2018-01-04 10:17:54 +0100
commit6b32d19429b90307d92dc52c42c995125298a35e (patch)
tree78c6190f3b1fe7e4124facd39a68acf77a5fb79b
parentcaac86460c145e43d8f04dcda9b6d2b15ebf5be1 (diff)
v1.7.0
-rw-r--r--composer.json2
-rw-r--r--php-jsonlint.spec10
2 files changed, 7 insertions, 5 deletions
diff --git a/composer.json b/composer.json
index 3f42c4f..a8706ad 100644
--- a/composer.json
+++ b/composer.json
@@ -15,7 +15,7 @@
"php": "^5.3 || ^7.0"
},
"require-dev": {
- "phpunit/phpunit": "^4.5"
+ "phpunit/phpunit": "^4.8.35 || ^5.7 || ^6.0"
},
"autoload": {
"psr-4": { "Seld\\JsonLint\\": "src/Seld/JsonLint/" }
diff --git a/php-jsonlint.spec b/php-jsonlint.spec
index f7feecf..5895b87 100644
--- a/php-jsonlint.spec
+++ b/php-jsonlint.spec
@@ -13,8 +13,8 @@
%global github_owner Seldaek
%global github_name jsonlint
-%global github_version 1.6.2
-%global github_commit 7a30649c67ee0d19faacfd9fa2cfb6cc032d9b19
+%global github_version 1.7.0
+%global github_commit 9b355654ea99460397b89c132b5c1087b6bf4473
# "php": "^5.3 || ^7.0"
%global php_min_ver 5.3
@@ -39,7 +39,6 @@ BuildArch: noarch
%if %{with_tests}
# For tests: composer.json
BuildRequires: php(language) >= %{php_min_ver}
-# See https://github.com/Seldaek/jsonlint/pull/46
%if 0%{?fedora} >= 26
%global phpunit %{_bindir}/phpunit6
BuildRequires: phpunit6
@@ -55,7 +54,7 @@ BuildRequires: php-composer(fedora/autoloader)
%endif
Requires: php(language) >= %{php_min_ver}
-# phpcompatinfo (computed from version 1.6.0)
+# phpcompatinfo (computed from version 1.7.0)
Requires: php-cli
Requires: php-pcre
# For autoloader
@@ -134,6 +133,9 @@ exit $ret
%changelog
+* Thu Jan 4 2018 Remi Collet <remi@remirepo.net> - 1.7.0-1
+- Update to 1.7.0
+
* Wed Dec 20 2017 Remi Collet <remi@remirepo.net> - 1.6.2-1
- Update to 1.6.2 (no change)
- use phpunit6 on Fedora