summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2013-01-09 07:51:31 +0100
committerRemi Collet <fedora@famillecollet.com>2013-01-09 07:51:31 +0100
commit2e72daccd65e72e476d57bced6cb0cd19f60f3e9 (patch)
treea2c2ee0114672798946ce73247c88d1fc582bd1f
php-jsonlint: import from rawhide
-rw-r--r--php-jsonlint.spec68
1 files changed, 68 insertions, 0 deletions
diff --git a/php-jsonlint.spec b/php-jsonlint.spec
new file mode 100644
index 0000000..0571a93
--- /dev/null
+++ b/php-jsonlint.spec
@@ -0,0 +1,68 @@
+%global libname jsonlint
+%global php_min_ver 5.3.0
+
+Name: php-%{libname}
+Version: 1.1.0
+Release: 1%{?dist}
+Summary: JSON Lint for PHP
+
+Group: Development/Libraries
+License: MIT
+URL: https://github.com/Seldaek/%{libname}
+Source0: %{url}/archive/%{version}.tar.gz
+
+BuildArch: noarch
+# Test build requires
+BuildRequires: php-common >= %{php_min_ver}
+BuildRequires: php-pear(pear.phpunit.de/PHPUnit)
+# Test build requires: phpci
+BuildRequires: php-pcre
+
+Requires: php-common >= %{php_min_ver}
+# phpci requires
+Requires: php-pcre
+
+%description
+%{summary}.
+
+This library is a port of the JavaScript jsonlint
+(https://github.com/zaach/jsonlint) library.
+
+
+%prep
+%setup -q -n %{libname}-%{version}
+
+# Create PSR-0 autoloader for tests
+( cat <<'AUTOLOAD'
+<?php
+spl_autoload_register(function ($class) {
+ $src = str_replace('\\', '/', $class).'.php';
+ require_once $src;
+});
+AUTOLOAD
+) > autoload.php
+
+
+%build
+# Empty build section, nothing to build
+
+
+%install
+mkdir -p -m 755 %{buildroot}%{_datadir}/php/Seld
+cp -rp src/Seld/JsonLint %{buildroot}%{_datadir}/php/Seld/
+
+
+%check
+%{_bindir}/phpunit --bootstrap=autoload.php \
+ -d include_path="src:tests:.:/usr/share/pear" .
+
+
+%files
+%doc LICENSE README.mdown composer.json
+%dir %{_datadir}/php/Seld
+ %{_datadir}/php/Seld/JsonLint
+
+
+%changelog
+* Mon Jan 7 2013 Shawn Iwinski <shawn.iwinski@gmail.com> 1.1.0-1
+- Initial package