summaryrefslogtreecommitdiffstats
path: root/php-ioncube-loader.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-ioncube-loader.spec')
-rw-r--r--php-ioncube-loader.spec54
1 files changed, 14 insertions, 40 deletions
diff --git a/php-ioncube-loader.spec b/php-ioncube-loader.spec
index 94b4364..2207475 100644
--- a/php-ioncube-loader.spec
+++ b/php-ioncube-loader.spec
@@ -6,31 +6,25 @@
#
# Please, preserve the changelog entries
#
-%{?scl: %scl_package php-ioncube-loader}
+%{?scl:%scl_package php-ioncube-loader}
+
%global extname ioncube_loader
%global debug_package %{nil}
%global __debug_install_post /bin/true
-%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
%global _build_id_links none
-%endif
+
%ifarch armv7hl aarch64 armv7hl
%global with_zts 0
%else
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%endif
-%if "%{php_version}" < "5.6"
-%global ininame %{extname}.ini
-%else
+
# [ionCube Loader] The Loader must appear as the first entry in the php.ini
%global ininame 01-%{extname}.ini
-%endif
-
-# Open issues
-# http://forum.ioncube.com/viewtopic.php?t=4244 - No version in Reflection
Name: %{?scl_prefix}php-ioncube-loader
Summary: Loader for ionCube Encoded Files with ionCube 24 support
-%global upstream_version 13.0.3
+%global upstream_version 13.3.1
#global upstream_prever beta2
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
@@ -53,35 +47,6 @@ BuildRequires: %{?scl_prefix}php-devel
# ABI check
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
-%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
-
-%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel} == 7
-# Other third party repo stuff
-Obsoletes: php53-ioncube-loader <= %{version}
-Obsoletes: php53u-ioncube-loader <= %{version}
-Obsoletes: php54-ioncube-loader <= %{version}
-%if "%{php_version}" > "5.5"
-Obsoletes: php55u-ioncube-loader <= %{version}
-%endif
-%if "%{php_version}" > "5.6"
-Obsoletes: php56u-ioncube-loader <= %{version}
-%endif
-%if "%{php_version}" > "7.0"
-Obsoletes: php70u-ioncube-loader <= %{version}
-%endif
-%if "%{php_version}" > "7.1"
-Obsoletes: php71u-ioncube-loader <= %{version}
-%endif
-%if "%{php_version}" > "7.2"
-Obsoletes: php72u-ioncube-loader <= %{version}
-%endif
-%if "%{php_version}" > "7.3"
-Obsoletes: php73-ioncube-loader <= %{version}
-%endif
-%if "%{php_version}" > "7.4"
-Obsoletes: php74-ioncube-loader <= %{version}
-%endif
-%endif
%description
@@ -217,6 +182,15 @@ install -D -m 644 %{extname}.zts %{buildroot}%{php_ztsinidir}/%{ininame}
%changelog
+* Fri Aug 2 2024 Remi Collet <remi@remirepo.net> - 13.3.1-1
+- update to 13.3.1 (August 1, 2024)
+
+* Wed Jul 3 2024 Remi Collet <remi@remirepo.net> - 13.3.0-1
+- update to 13.3.0 (July 2, 2024)
+
+* Fri May 31 2024 Remi Collet <remi@remirepo.net> - 13.0.4-1
+- update to 13.0.4 (May 31, 2024)
+
* Wed May 15 2024 Remi Collet <remi@remirepo.net> - 13.0.3-1
- update to 13.0.3 (May 14, 2024)
- open https://support.ioncube.com/index.php?/Tickets/Ticket/View/28121