summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO24
-rw-r--r--REFLECTION198
-rw-r--r--php-ioncube-loader.spec5
3 files changed, 77 insertions, 150 deletions
diff --git a/PHPINFO b/PHPINFO
index d97ab62..e085248 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -3,30 +3,8 @@ ionCube Loader
For Loader updates visit www.ioncube.com/loaders.php
For support visit support.ioncube.com
-This Loader also includes features for real-time error reporting and malware protection. Visit ioncube24.com for more details.
-Loader version => 11.0.1
-ionCube24 features => unconfigured
+Loader version => 12.0.3
Directive => Local Value => Master Value
-ic24.enable => 0 => 0
-ic24.sec.stop_on_error => 1 => 1
-ic24.sec.trusted_include_paths => ******** => ********
-ic24.sec.block_uploaded_files => 1 => 1
-ic24.api_access_key => ******** => ********
-ic24.api_check_ip => 1 => 1
-ic24.slt => 7 => 7
-ic24.sec.enable => auto => auto
-ic24.sec.initial_state => 1 => 1
-ic24.sec.initial_action => block => block
-ic24.sec.initial_notify => always => always
-ic24.sec.initial_cache_all => 1 => 1
-ic24.sec.exclusion_key => ******** => ********
-ic24.home_dir => no value => no value
-ic24.sec.block_stdin => 1 => 1
-ic24.update_domains_retry_interval => 30 => 30
-ic24.phperr.enable => auto => auto
-ic24.phperr.ignore => 0 => 0
-ic24.api.log_msg_errors => 0 => 0
-ic24.api.max_timeout => 7 => 7
ioncube.loader.encoded_paths => no value => no value
diff --git a/REFLECTION b/REFLECTION
index 77d5827..2c1f435 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,66 +1,6 @@
-Extension [ <persistent> extension #15 ionCube Loader version 11.0.1 ] {
+Extension [ <persistent> extension #16 ionCube Loader version 12.0.3 ] {
- INI {
- Entry [ ic24.enable <SYSTEM> ]
- Current = '0'
- }
- Entry [ ic24.sec.stop_on_error <SYSTEM> ]
- Current = '1'
- }
- Entry [ ic24.sec.trusted_include_paths <SYSTEM> ]
- Current = ''
- }
- Entry [ ic24.sec.block_uploaded_files <SYSTEM> ]
- Current = '1'
- }
- Entry [ ic24.api_access_key <PERDIR> ]
- Current = ''
- }
- Entry [ ic24.api_check_ip <SYSTEM> ]
- Current = '1'
- }
- Entry [ ic24.slt <SYSTEM> ]
- Current = '7'
- }
- Entry [ ic24.sec.enable <SYSTEM> ]
- Current = 'auto'
- }
- Entry [ ic24.sec.initial_state <SYSTEM> ]
- Current = '1'
- }
- Entry [ ic24.sec.initial_action <SYSTEM> ]
- Current = 'block'
- }
- Entry [ ic24.sec.initial_notify <SYSTEM> ]
- Current = 'always'
- }
- Entry [ ic24.sec.initial_cache_all <SYSTEM> ]
- Current = '1'
- }
- Entry [ ic24.sec.exclusion_key <SYSTEM> ]
- Current = ''
- }
- Entry [ ic24.home_dir <SYSTEM> ]
- Current = ''
- }
- Entry [ ic24.sec.block_stdin <SYSTEM> ]
- Current = '1'
- }
- Entry [ ic24.update_domains_retry_interval <SYSTEM> ]
- Current = '30'
- }
- Entry [ ic24.phperr.enable <SYSTEM> ]
- Current = 'auto'
- }
- Entry [ ic24.phperr.ignore <ALL> ]
- Current = '0'
- }
- Entry [ ic24.api.log_msg_errors <SYSTEM> ]
- Current = '0'
- }
- Entry [ ic24.api.max_timeout <SYSTEM> ]
- Current = '7'
- }
Entry [ ioncube.loader.encoded_paths <ALL> ]
Current = ''
}
@@ -85,105 +25,111 @@ Extension [ <persistent> extension #15 ionCube Loader version 11.0.1 ] {
- Functions {
Function [ <internal:ionCube Loader> function ioncube_file_is_encoded ] {
+
+ - Parameters [0] {
+ }
+ - Return [ bool ]
}
Function [ <internal:ionCube Loader> function ioncube_file_info ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array|bool ]
}
Function [ <internal:ionCube Loader> function ioncube_file_properties ] {
+
+ - Parameters [0] {
+ }
+ - Return [ ?array ]
}
Function [ <internal:ionCube Loader> function ioncube_file_not_permissioned ] {
+
+ - Parameters [0] {
+ }
+ - Return [ mixed ]
}
Function [ <internal:ionCube Loader> function ioncube_license_properties ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array|bool ]
}
Function [ <internal:ionCube Loader> function ioncube_licensed_servers ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array|bool ]
}
Function [ <internal:ionCube Loader> function ioncube_server_data ] {
- }
- Function [ <internal:ionCube Loader> function ic24_op ] {
- - Parameters [3] {
- Parameter #0 [ <required> $operation ]
- Parameter #1 [ <required> $params ]
- Parameter #2 [ <optional> &$status ]
+ - Parameters [0] {
}
- }
- Function [ <internal:ionCube Loader> function ic24_get_cache_id ] {
- }
- Function [ <internal:ionCube Loader> function ic24_is_authenticated ] {
- }
- Function [ <internal:ionCube Loader> function ic24_authentication_status ] {
- }
- Function [ <internal:ionCube Loader> function ic24_api_version ] {
- }
- Function [ <internal:ionCube Loader> function ic24_enable ] {
- }
- Function [ <internal:ionCube Loader> function ic24_sec_cache_query ] {
- }
- Function [ <internal:ionCube Loader> function ic24_sec_cache_size ] {
- }
- Function [ <internal:ionCube Loader> function ic24_sec_cache_remove_item_by_path ] {
- }
- Function [ <internal:ionCube Loader> function ic24_sec_cache_remove_by_filter ] {
- }
- Function [ <internal:ionCube Loader> function ic24_sec_cache_add_path ] {
- }
- Function [ <internal:ionCube Loader> function ic24_sec_approve_item ] {
- }
- Function [ <internal:ionCube Loader> function ic24_sec_block_item ] {
- }
- Function [ <internal:ionCube Loader> function ic24_sec_unblock_item ] {
- }
- Function [ <internal:ionCube Loader> function ic24_sec_set_default_notify_status ] {
- }
- Function [ <internal:ionCube Loader> function ic24_sec_get_default_notify_status ] {
- }
- Function [ <internal:ionCube Loader> function ic24_sec_set_default_exec_status ] {
- }
- Function [ <internal:ionCube Loader> function ic24_sec_get_default_exec_status ] {
- }
- Function [ <internal:ionCube Loader> function ic24_sec_set_trustpoint ] {
- }
- Function [ <internal:ionCube Loader> function ic24_sec_get_trustpoint ] {
- }
- Function [ <internal:ionCube Loader> function ic24_set_pkv ] {
- }
- Function [ <internal:ionCube Loader> function ic24_get_pkv ] {
- }
- Function [ <internal:ionCube Loader> function ic24_update_domains ] {
- }
- Function [ <internal:ionCube Loader> function ic24_cache_status ] {
- }
- Function [ <internal:ionCube Loader> function ic24_cache_reset_stats ] {
- }
- Function [ <internal:ionCube Loader> function ic24_phperr_set_ignore ] {
- }
- Function [ <internal:ionCube Loader> function ic24_phperr_get_ignore ] {
- }
- Function [ <internal:ionCube Loader> function ic24_phperr_suppress ] {
- }
- Function [ <internal:ionCube Loader> function ic24_phperr_get_suppressions ] {
+ - Return [ ?string ]
}
Function [ <internal:ionCube Loader> function _dyuweyrj4 ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> int $a ]
+ Parameter #1 [ <required> int $b ]
+ }
+ - Return [ mixed ]
}
Function [ <internal:ionCube Loader> function _dyuweyrj4r ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> int $a ]
+ Parameter #1 [ <required> int $b ]
+ }
+ - Return [ mixed ]
}
Function [ <internal:ionCube Loader> function ioncube_check_license_properties ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array|bool ]
}
Function [ <internal:ionCube Loader> function ioncube_license_matches_server ] {
+
+ - Parameters [0] {
+ }
+ - Return [ bool ]
}
Function [ <internal:ionCube Loader> function ioncube_license_has_expired ] {
+
+ - Parameters [0] {
+ }
+ - Return [ bool ]
}
Function [ <internal:ionCube Loader> function ioncube_read_file ] {
- - Parameters [2] {
- Parameter #0 [ <required> $param0 ]
- Parameter #1 [ <required> &$param1 ]
+ - Parameters [3] {
+ Parameter #0 [ <required> string $path ]
+ Parameter #1 [ <optional> bool &$was_encrypted = false ]
+ Parameter #2 [ <optional> string $passphrase = '' ]
}
+ - Return [ string|int ]
}
Function [ <internal:ionCube Loader> function ioncube_write_file ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> string $path ]
+ Parameter #1 [ <required> string $content ]
+ Parameter #2 [ <optional> bool $encrypt = true ]
+ Parameter #3 [ <optional> string $passphrase = '' ]
+ }
+ - Return [ int ]
}
Function [ <internal:ionCube Loader> function ioncube_loader_version ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
Function [ <internal:ionCube Loader> function ioncube_loader_iversion ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
}
}
}
diff --git a/php-ioncube-loader.spec b/php-ioncube-loader.spec
index 4903350..affd841 100644
--- a/php-ioncube-loader.spec
+++ b/php-ioncube-loader.spec
@@ -30,7 +30,7 @@
Name: %{?scl_prefix}php-ioncube-loader
Summary: Loader for ionCube Encoded Files with ionCube 24 support
-%global upstream_version 12.0.2
+%global upstream_version 12.0.3
#global upstream_prever beta2
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
@@ -217,6 +217,9 @@ install -D -m 644 %{extname}.zts %{buildroot}%{php_ztsinidir}/%{ininame}
%changelog
+* Tue Dec 6 2022 Remi Collet <remi@remirepo.net> - 12.0.3-1
+- update to 12.0.3 (Dec 2, 2022)
+
* Tue Sep 13 2022 Remi Collet <remi@remirepo.net> - 12.0.2-1
- update to 12.0.2 (Sep 9, 2022)