summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPablo Greco <pablo@fliagreco.com.ar>2018-01-17 07:51:17 -0300
committerRemi Collet <remi@remirepo.net>2018-01-17 11:59:46 +0100
commitfd1760aabbc8bf1876e12a8c22f58f1d6f37a123 (patch)
tree708d6d93b63f9843f086e04f854c306af9b9246f
parentabebe1f4a5a17b14d443bbc349809237af8be960 (diff)
Add sources and logic to build for armv7hl
-rw-r--r--php-ioncube-loader.spec20
1 files changed, 16 insertions, 4 deletions
diff --git a/php-ioncube-loader.spec b/php-ioncube-loader.spec
index 2ae4c3b..46d6413 100644
--- a/php-ioncube-loader.spec
+++ b/php-ioncube-loader.spec
@@ -13,7 +13,11 @@
%if 0%{?fedora} >= 27
%global _build_id_links none
%endif
+%ifarch armv7hl
+%global with_zts 0
+%else
%global with_zts 0%{?__ztsphp:1}
+%endif
%if "%{php_version}" < "5.6"
%global ininame %{extname}.ini
%else
@@ -27,14 +31,15 @@
Name: %{?scl_prefix}php-ioncube-loader
Summary: Loader for ionCube Encoded Files with ionCube 24 support
Version: 10.1.0
-Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: Distribuable
Group: Development/Languages
URL: http://www.ioncube.com
Source0: http://downloads2.ioncube.com/loader_downloads/%{extname}s_lin_x86_%{version}.tar.gz
Source1: http://downloads2.ioncube.com/loader_downloads/%{extname}s_lin_x86-64_%{version}.tar.gz
-Source2: LICENSE.txt
+Source2: http://downloads2.ioncube.com/loader_downloads/%{extname}s_lin_armv7hl_%{version}.tar.gz
+Source3: LICENSE.txt
BuildRequires: %{?scl_prefix}php-devel
@@ -83,16 +88,20 @@ Package built for PHP %(%{__php} -n -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VER
%prep
%setup -q -T -c
+%ifarch armv7hl
+tar xvf %{SOURCE2}
+%else
%ifarch x86_64
tar xvf %{SOURCE1}
%else
tar xvf %{SOURCE0}
%endif
+%endif
# Drop in the bit of configuration
# Sometime file is missing
# http://forum.ioncube.com/viewtopic.php?t=4245
-[ -f ioncube/LICENSE.txt ] || cp %{SOURCE2} ioncube/
+[ -f ioncube/LICENSE.txt ] || cp %{SOURCE3} ioncube/
sed -e 's/\r//' -i ioncube/*.txt
cat << 'EOF' | tee %{extname}.nts
@@ -187,9 +196,12 @@ install -D -m 644 %{extname}.zts %{buildroot}%{php_ztsinid
%changelog
+* Wed Jan 17 2018 Pablo Greco <pablo@fliagreco.com.ar> - 10.1.0-2
+- add armv7hl as a target
+
* Fri Dec 15 2017 Remi Collet <remi@remirepo.net> - 10.1.0-1
- update to 10.1.0 (Dec 14, 2017)
-
+
* Thu Nov 2 2017 Remi Collet <remi@remirepo.net> - 10.0.4-1
- update to 10.0.4 (Nov 1, 2017)