summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-08-08 08:09:46 +0200
committerRemi Collet <remi@php.net>2022-08-08 08:09:46 +0200
commit13ab7074fdc4411ab577c657e5c15a9c8a9b4849 (patch)
tree78a1562cbad5a71055193cf36466aea0f881b902
parentc93c485713e366df5e9054aa0cfd405784f4fc47 (diff)
update to 12.0.0 (Aug 5, 2022)
open https://support.ioncube.com/index.php?/Tickets/Ticket/View/25726 [12.0.0] undefined symbol: zend_exception_uncaught_error on 8.1
-rw-r--r--php-ioncube-loader.spec56
1 files changed, 33 insertions, 23 deletions
diff --git a/php-ioncube-loader.spec b/php-ioncube-loader.spec
index 9a55e4f..8f92d31 100644
--- a/php-ioncube-loader.spec
+++ b/php-ioncube-loader.spec
@@ -30,7 +30,7 @@
Name: %{?scl_prefix}php-ioncube-loader
Summary: Loader for ionCube Encoded Files with ionCube 24 support
-%global upstream_version 11.0.1
+%global upstream_version 12.0.0
#global upstream_prever beta2
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
@@ -41,16 +41,18 @@ URL: http://www.ioncube.com
Source0: https://www.ioncube.com/php-7.4.0-beta-loaders/ioncube_loaders_lin_x86_7.4_BETA2.tar.gz
Source1: https://www.ioncube.com/php-7.4.0-beta-loaders/ioncube_loaders_lin_x86-64_7.4_BETA2.tar.gz
%else
-Source0: http://downloads2.ioncube.com/loader_downloads/%{extname}s_lin_x86_%{version}.tar.gz
-Source1: http://downloads2.ioncube.com/loader_downloads/%{extname}s_lin_x86-64_%{version}.tar.gz
-Source2: http://downloads2.ioncube.com/loader_downloads/%{extname}s_lin_armv7l_%{version}.tar.gz
-Source3: http://downloads2.ioncube.com/loader_downloads/%{extname}s_lin_aarch64_%{version}.tar.gz
+Source1: https://www.ioncube.com/linux-v12-loaders/ioncube_loaders_lin_x86-64_v12.tar.gz
+#Source0: http://downloads2.ioncube.com/loader_downloads/%%{extname}s_lin_x86_%%{version}.tar.gz
+#Source1: http://downloads2.ioncube.com/loader_downloads/%%{extname}s_lin_x86-64_%%{version}.tar.gz
+#Source2: http://downloads2.ioncube.com/loader_downloads/%%{extname}s_lin_armv7l_%%{version}.tar.gz
+#Source3: http://downloads2.ioncube.com/loader_downloads/%%{extname}s_lin_aarch64_%%{version}.tar.gz
%endif
Source90: LICENSE.txt
Source91: USER-GUIDE.txt
-ExclusiveArch: %{ix86} x86_64 armv7hl aarch64
-BuildRequires: %{?scl_prefix}php-devel < 8.0
+#ExclusiveArch: %%{ix86} x86_64 armv7hl aarch64
+ExclusiveArch: x86_64
+BuildRequires: %{?scl_prefix}php-devel
# ABI check
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
@@ -85,12 +87,6 @@ Obsoletes: php74-ioncube-loader <= %{version}
%endif
%endif
-%if 0%{?fedora} < 20 && 0%{?rhel} < 7
-# Filter private shared object
-%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
-%{?filter_setup}
-%endif
-
%description
Loader for ionCube Encoded Files with ionCube 24 support.
@@ -107,11 +103,7 @@ tar xvf %{SOURCE3}
%ifarch armv7hl
tar xvf %{SOURCE2}
%else
-%ifarch x86_64
tar xvf %{SOURCE1}
-%else
-tar xvf %{SOURCE0}
-%endif
%endif
%endif
@@ -121,6 +113,8 @@ mv ioncube_loader_lin_7.4_%{upstream_version}_%{upstream_prever}.so ioncube/i
mv ioncube_loader_lin_7.4_%{upstream_version}_%{upstream_prever}_ts.so ioncube/ioncube_loader_lin_7.4_ts.so
%endif
+[ -d linux_x86_64 ] && ln -s linux_x86_64 ioncube
+
# Drop in the bit of configuration
# Sometime file is missing
# http://forum.ioncube.com/viewtopic.php?t=4245
@@ -174,17 +168,28 @@ diff %{extname}.nts %{extname}.zts || : ok
%install
ver=$(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')
-if [ ! -f ioncube/%{extname}_lin_${ver}.so ]; then
+if [ -f ioncube/%{extname}_lin_${ver}.so ]; then
+
+ install -D -pm 755 ioncube/%{extname}_lin_${ver}.so %{buildroot}%{php_extdir}/%{extname}.so
+ %if %{with_zts}
+ install -D -pm 755 ioncube/%{extname}_lin_${ver}_ts.so %{buildroot}%{php_ztsextdir}/%{extname}.so
+ %endif
+
+elif [ -f linux_x86_64/${ver}.0/ioncube_loader_%{version}.so ]; then
+
+ install -D -pm 755 linux_x86_64/${ver}.0/ioncube_loader_%{version}.so %{buildroot}%{php_extdir}/%{extname}.so
+ %if %{with_zts}
+ install -D -pm 755 linux_x86_64/${ver}.0-ts/ioncube_loader_%{version}_ts.so %{buildroot}%{php_ztsextdir}/%{extname}.so
+ %endif
+
+else
: Module for PHP $ver not provided
exit 1
fi
-install -D -pm 755 ioncube/%{extname}_lin_${ver}.so %{buildroot}%{php_extdir}/%{extname}.so
-install -D -m 644 %{extname}.nts %{buildroot}%{php_inidir}/%{ininame}
-
+install -D -m 644 %{extname}.nts %{buildroot}%{php_inidir}/%{ininame}
%if %{with_zts}
-install -D -pm 755 ioncube/%{extname}_lin_${ver}_ts.so %{buildroot}%{php_ztsextdir}/%{extname}.so
-install -D -m 644 %{extname}.zts %{buildroot}%{php_ztsinidir}/%{ininame}
+install -D -m 644 %{extname}.zts %{buildroot}%{php_ztsinidir}/%{ininame}
%endif
@@ -216,6 +221,11 @@ install -D -m 644 %{extname}.zts %{buildroot}%{php_ztsinid
%changelog
+* Mon Aug 8 2022 Remi Collet <remi@remirepo.net> - 12.0.0-1
+- update to 12.0.0 (Aug 5, 2022)
+- open https://support.ioncube.com/index.php?/Tickets/Ticket/View/25726
+ [12.0.0] undefined symbol: zend_exception_uncaught_error on 8.1
+
* Thu Jan 13 2022 Remi Collet <remi@remirepo.net> - 11.0.1-1
- update to 11.0.1 (Jan 12, 2022)