summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2012-06-29 17:10:18 +0200
committerRemi Collet <fedora@famillecollet.com>2012-06-29 17:10:18 +0200
commit77090ea2d5914f39b1d6ebeb8f91f964d95f3fe7 (patch)
treeccd4cd552365bb4e765cae1a00e97bef5e5c4f41
rename dir
-rw-r--r--Makefile4
-rw-r--r--php-htmlawed.spec71
2 files changed, 75 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..91b0fd5
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../common/Makefile
+
diff --git a/php-htmlawed.spec b/php-htmlawed.spec
new file mode 100644
index 0000000..c7514c0
--- /dev/null
+++ b/php-htmlawed.spec
@@ -0,0 +1,71 @@
+%global libname htmLawed
+
+Name: php-%{libname}
+Version: 1.1.11
+Release: 1%{?dist}
+Summary: PHP code to purify & filter HTML
+Group: Development/Libraries
+License: LGPLv3+ and GPLv2+
+URL: http://www.bioinformatics.org/phplabware/internal_utilities/htmLawed/
+
+# Latest archive is not versionned
+# No license included
+# see http://www.bioinformatics.org/phplabware/forum/viewtopic.php?id=220
+Source0: http://www.bioinformatics.org/phplabware/downloads/%{libname}.zip
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+BuildArch: noarch
+
+Requires: php-ctype
+Requires: php-pcre
+
+
+%description
+PHP code to purify & filter HTML
+
+* make HTML markup in text secure and standard-compliant
+* process text for use in HTML, XHTML or XML documents
+* restrict HTML elements, attributes or URL protocols
+ using black or white-lists
+* balance tags, check element nesting, transform deprecated
+ attributes and tags, make relative URLs absolute, etc.
+* fast, highly customizable, well-documented
+* single, 48 kb file
+* simple HTML Tidy alternative
+* free and licensed under LGPL v3 and GPL v2+
+* use to filter, secure & sanitize HTML in blog comments or
+ forum posts, generate XML-compatible feed items from web-page
+ excerpts, convert HTML to XHTML, pretty-print HTML, scrape
+ web-pages, reduce spam, remove XSS code, etc.
+
+
+%prep
+%setup -qc
+
+chmod -x htm*
+
+
+%build
+# nothing to build
+
+
+%install
+rm -rf %{buildroot}
+install -d %{buildroot}%{_datadir}/php/%{libname}
+install -pm 0644 htmLawed.php %{buildroot}%{_datadir}/php/%{libname}
+
+
+%clean
+rm -rf %{buildroot}
+
+
+%files
+%defattr(-,root,root,-)
+%doc *README* *TESTCASE* htmLawedTest.php
+%{_datadir}/php/%{libname}
+
+
+%changelog
+* Fri Jun 29 2012 Remi Collet <remi@fedoraproject.org> - 1.1.11-1
+- initial package
+