summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2017-01-05 07:32:28 +0100
committerRemi Collet <fedora@famillecollet.com>2017-01-05 07:32:28 +0100
commit227c71f2c15909e645fed6036a542bf387a75326 (patch)
tree78609faa6b940fad4fbb6cef7b7befa3a4e2b584
parentf11a34407ef30610f126775194107d6ddb6b707e (diff)
php-goutte: 3.2.1
-rw-r--r--php-goutte-pull-request-290.patch31
-rw-r--r--php-goutte.spec16
2 files changed, 6 insertions, 41 deletions
diff --git a/php-goutte-pull-request-290.patch b/php-goutte-pull-request-290.patch
deleted file mode 100644
index 04e859a..0000000
--- a/php-goutte-pull-request-290.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-From c990361e61467c4f4a7ff4f08d3cd6d7c6cd784d Mon Sep 17 00:00:00 2001
-From: Shawn Iwinski <siwinski@redhat.com>
-Date: Fri, 30 Dec 2016 14:19:53 -0500
-Subject: [PATCH] Fix tests after #246 was merged (header case normalization)
-
----
- Goutte/Tests/ClientTest.php | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/Goutte/Tests/ClientTest.php b/Goutte/Tests/ClientTest.php
-index b5b8583..4a633e4 100644
---- a/Goutte/Tests/ClientTest.php
-+++ b/Goutte/Tests/ClientTest.php
-@@ -380,7 +380,7 @@ public function testResetHeaders()
-
- $reflectionProperty = new \ReflectionProperty('Goutte\Client', 'headers');
- $reflectionProperty->setAccessible(true);
-- $this->assertEquals(array('X-Test' => 'test'), $reflectionProperty->getValue($client));
-+ $this->assertEquals(array('x-test' => 'test'), $reflectionProperty->getValue($client));
-
- $client->resetHeaders();
- $this->assertEquals([], $reflectionProperty->getValue($client));
-@@ -394,7 +394,7 @@ public function testRestart()
-
- $headersReflectionProperty = new \ReflectionProperty('Goutte\Client', 'headers');
- $headersReflectionProperty->setAccessible(true);
-- $this->assertEquals(array('X-Test' => 'test'), $headersReflectionProperty->getValue($client));
-+ $this->assertEquals(array('x-test' => 'test'), $headersReflectionProperty->getValue($client));
-
- $authReflectionProperty = new \ReflectionProperty('Goutte\Client', 'auth');
- $authReflectionProperty->setAccessible(true);
diff --git a/php-goutte.spec b/php-goutte.spec
index 4b02c90..485fb49 100644
--- a/php-goutte.spec
+++ b/php-goutte.spec
@@ -2,7 +2,7 @@
#
# Fedora spec file for php-goutte
#
-# Copyright (c) 2014-2016 Shawn Iwinski <shawn@iwin.ski>
+# Copyright (c) 2014-2017 Shawn Iwinski <shawn@iwin.ski>
#
# License: MIT
# http://opensource.org/licenses/MIT
@@ -12,8 +12,8 @@
%global github_owner FriendsOfPHP
%global github_name Goutte
-%global github_version 3.2.0
-%global github_commit 8cc89de5e71daf84051859616891d3320d88a9e8
+%global github_version 3.2.1
+%global github_commit db5c28f4a010b4161d507d5304e28a7ebf211638
%global composer_vendor fabpot
%global composer_project goutte
@@ -45,10 +45,6 @@ License: MIT
URL: https://github.com/%{github_owner}/%{github_name}
Source0: %{url}/archive/%{github_commit}/%{name}-%{github_version}-%{github_commit}.tar.gz
-# Fix tests after #246 was merged (header case normalization)
-# https://patch-diff.githubusercontent.com/raw/FriendsOfPHP/Goutte/pull/290.patch
-Patch0: %{name}-pull-request-290.patch
-
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
# Tests
@@ -99,9 +95,6 @@ Autoloader: %{phpdir}/Goutte/autoload.php
%prep
%setup -qn %{github_name}-%{github_commit}
-: Fix tests after #246 was merged (header case normalization)
-%patch0 -p1
-
%build
: Create autoloader
@@ -164,6 +157,9 @@ rm -rf %{buildroot}
%changelog
+* Thu Jan 5 2017 Remi Collet <remi@remirepo.net> - 3.2.1-1
+- update to 3.2.1
+
* Fri Dec 30 2016 Shawn Iwinski <shawn.iwinski@gmail.com> - 3.2.0-1
- Updated to 3.2.0 (RHBZ #1395456)
- Use php-composer(fedora/autoloader)