summaryrefslogtreecommitdiffstats
path: root/php-gitter.spec
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-07-20 07:24:22 +0200
committerRemi Collet <fedora@famillecollet.com>2014-07-20 07:24:22 +0200
commit7b8faf2e85c3ad6e39c99c35ec8d96ba7249bd9e (patch)
tree5dbff7cfd7699afd54059532cc30e67f01d30f53 /php-gitter.spec
parentebff15582c5ee84f831f77ba5d4bb48600e82458 (diff)
php-gitter: 0.3.0
Diffstat (limited to 'php-gitter.spec')
-rw-r--r--php-gitter.spec82
1 files changed, 60 insertions, 22 deletions
diff --git a/php-gitter.spec b/php-gitter.spec
index 88ca5c2..fcbb962 100644
--- a/php-gitter.spec
+++ b/php-gitter.spec
@@ -1,21 +1,39 @@
-%global github_owner klaussilveira
-%global github_name gitter
-%global github_version 0.2.0
-%global github_commit 786e86a54121d1bb3c768e6bc93e37e431aa6264
-# There are commits after the 0.2.0 version tag
-%global github_release .20131206git%(c=%{github_commit}; echo ${c:0:7})
-
-%global lib_name Gitter
-
-%global php_min_ver 5.3.0
+#
+# RPM spec file for php-gitter
+#
+# Copyright (c) 2014 Shawn Iwinski <shawn.iwinski@gmail.com>
+#
+# License: MIT
+# http://opensource.org/licenses/MIT
+#
+# Please preserve changelog entries
+#
+
+%global github_owner klaussilveira
+%global github_name gitter
+%global github_version 0.3.0
+%global github_commit 6eff42830c336ee9b8b8b9d2f69b62bd9bcbaf3b
+
+%global composer_vendor klaussilveira
+%global composer_project gitter
+
+%global lib_name Gitter
+
+# "php": ">=5.3.0"
+%global php_min_ver 5.3.0
# "phpunit/phpunit": ">=3.7.1"
-%global phpunit_min_ver 3.7.1
+%global phpunit_min_ver 3.7.1
# "symfony/*": ">=2.2"
-%global symfony_min_ver 2.2
+%global symfony_min_ver 2.2
+
+# Build using "--without tests" to disable tests
+%global with_tests %{?_without_tests:0}%{!?_without_tests:1}
+
+%{!?__phpunit: %global __phpunit %{_bindir}/phpunit}
-Name: php-%{github_name}
+Name: php-%{composer_project}
Version: %{github_version}
-Release: 2%{?github_release}%{?dist}
+Release: 1%{?github_release}%{?dist}
Summary: Object oriented interaction with Git repositories
Group: Development/Libraries
@@ -25,25 +43,35 @@ Source0: %{url}/archive/%{github_commit}/%{name}-%{github_version}-%{githu
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
+%if %{with_tests}
# For tests
BuildRequires: git
+# For tests: composer.json
BuildRequires: php(language) >= %{php_min_ver}
+BuildRequires: php-deepend-Mockery
+BuildRequires: php-phpunit-PHPUnit >= %{phpunit_min_ver}
BuildRequires: php-symfony-process >= %{symfony_min_ver}
BuildRequires: php-symfony-filesystem >= %{symfony_min_ver}
-BuildRequires: php-pear(pear.phpunit.de/PHPUnit) >= %{phpunit_min_ver}
-# For tests: phpcompatinfo (computed from version 0.2.0 commit 786e86a54121d1bb3c768e6bc93e37e431aa6264)
+# For tests: phpcompatinfo (computed from version 0.3.0)
BuildRequires: php-date
BuildRequires: php-pcre
+BuildRequires: php-reflection
BuildRequires: php-spl
+%endif
Requires: git
+# composer.json
Requires: php(language) >= %{php_min_ver}
Requires: php-symfony-process >= %{symfony_min_ver}
-# phpcompatinfo (computed from version 0.2.0 commit 786e86a54121d1bb3c768e6bc93e37e431aa6264)
+# phpcompatinfo (computed from version 0.3.0)
Requires: php-date
Requires: php-pcre
+Requires: php-reflection
Requires: php-spl
+# Composer
+Provides: php-composer(%{composer_vendor}/%{composer_project}) = %{version}
+
%description
Gitter allows you to interact in an object oriented manner with Git repositories
via PHP. The main goal of the library is not to replace the system git command,
@@ -69,12 +97,13 @@ cp -rp lib/%{lib_name} %{buildroot}/%{_datadir}/php/
%check
-# Create tests' bootstrap
+%if %{with_tests}
+# Create autoloader
mkdir vendor
cat > vendor/autoload.php <<'AUTOLOAD'
<?php
spl_autoload_register(function ($class) {
- $src = str_replace(array('\\', '_'), '/', $class).'.php';
+ $src = str_replace('\\', '/', $class).'.php';
@include_once $src;
});
AUTOLOAD
@@ -82,20 +111,29 @@ AUTOLOAD
# Create PHPUnit config w/ colors turned off
sed 's/colors="true"/colors="false"/' phpunit.xml.dist > phpunit.xml
-%{_bindir}/phpunit --include-path="./lib:./tests" -d date.timezone="UTC"
-
+%{__phpunit} --include-path="./lib:./tests" -d date.timezone="UTC"
+%else
+: Tests skipped
+%endif
%clean
rm -rf %{buildroot}
+%{!?_licensedir:%global license %%doc}
%files
%defattr(-,root,root,-)
-%doc LICENSE README.md composer.json
+%license LICENSE
+%doc README.md composer.json
%{_datadir}/php/%{lib_name}
%changelog
+* Sat Jul 19 2014 Shawn Iwinski <shawn.iwinski@gmail.com> - 0.3.0-1
+- Updated to 0.3.0 (BZ #1101229)
+- Added "php-composer(klaussilveira/gitter)" virtual provide
+- Added option to build without tests ("--without tests")
+
* Fri Feb 21 2014 Remi Collet <remi@fedoraproject.org> 0.2.0-2.20131206git786e86a
- backport for remi repo