summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-02-21 18:31:11 +0100
committerRemi Collet <fedora@famillecollet.com>2014-02-21 18:31:11 +0100
commit988ea5c82c29d5eb280b9909cc4eccba8958fa5c (patch)
tree94f5ce84621c9dda638032e3aa1b639a6c040c18
php-gitter: import from rawhide
-rw-r--r--php-gitter.spec96
1 files changed, 96 insertions, 0 deletions
diff --git a/php-gitter.spec b/php-gitter.spec
new file mode 100644
index 0000000..e8f96a8
--- /dev/null
+++ b/php-gitter.spec
@@ -0,0 +1,96 @@
+%global github_owner klaussilveira
+%global github_name gitter
+%global github_version 0.2.0
+%global github_commit 786e86a54121d1bb3c768e6bc93e37e431aa6264
+# There are commits after the 0.2.0 version tag
+%global github_release .20131206git%(c=%{github_commit}; echo ${c:0:7})
+
+%global lib_name Gitter
+
+%global php_min_ver 5.3.0
+# "phpunit/phpunit": ">=3.7.1"
+%global phpunit_min_ver 3.7.1
+# "symfony/*": ">=2.2"
+%global symfony_min_ver 2.2
+
+Name: php-%{github_name}
+Version: %{github_version}
+Release: 2%{?github_release}%{?dist}
+Summary: Object oriented interaction with Git repositories
+
+Group: Development/Libraries
+License: BSD
+URL: https://github.com/%{github_owner}/%{github_name}
+Source0: %{url}/archive/%{github_commit}/%{name}-%{github_version}-%{github_commit}.tar.gz
+
+BuildArch: noarch
+# For tests
+BuildRequires: git
+BuildRequires: php(language) >= %{php_min_ver}
+BuildRequires: php-symfony-process >= %{symfony_min_ver}
+BuildRequires: php-symfony-filesystem >= %{symfony_min_ver}
+BuildRequires: php-pear(pear.phpunit.de/PHPUnit) >= %{phpunit_min_ver}
+# For tests: phpcompatinfo (computed from version 0.2.0 commit 786e86a54121d1bb3c768e6bc93e37e431aa6264)
+BuildRequires: php-date
+BuildRequires: php-pcre
+BuildRequires: php-spl
+
+Requires: git
+Requires: php(language) >= %{php_min_ver}
+Requires: php-symfony-process >= %{symfony_min_ver}
+# phpcompatinfo (computed from version 0.2.0 commit 786e86a54121d1bb3c768e6bc93e37e431aa6264)
+Requires: php-date
+Requires: php-pcre
+Requires: php-spl
+
+%description
+Gitter allows you to interact in an object oriented manner with Git repositories
+via PHP. The main goal of the library is not to replace the system git command,
+but provide a coherent, stable and performatic object oriented interface.
+
+Most commands are sent to the system's git command, parsed and then interpreted
+by Gitter. Everything is transparent to you, so you don't have to worry about a
+thing.
+
+
+%prep
+%setup -qn %{github_name}-%{github_commit}
+
+
+%build
+# Empty build section, nothing required
+
+
+%install
+mkdir -p %{buildroot}/%{_datadir}/php
+cp -rp lib/%{lib_name} %{buildroot}/%{_datadir}/php/
+
+
+%check
+# Create tests' bootstrap
+mkdir vendor
+cat > vendor/autoload.php <<'AUTOLOAD'
+<?php
+spl_autoload_register(function ($class) {
+ $src = str_replace(array('\\', '_'), '/', $class).'.php';
+ @include_once $src;
+});
+AUTOLOAD
+
+# Create PHPUnit config w/ colors turned off
+sed 's/colors="true"/colors="false"/' phpunit.xml.dist > phpunit.xml
+
+%{_bindir}/phpunit --include-path="./lib:./tests" -d date.timezone="UTC"
+
+
+%files
+%doc LICENSE README.md composer.json
+%{_datadir}/php/%{lib_name}
+
+
+%changelog
+* Thu Feb 20 2014 Shawn Iwinski <shawn.iwinski@gmail.com> 0.2.0-2.20131206git786e86a
+- Conditional release dist
+
+* Mon Jan 27 2014 Shawn Iwinski <shawn.iwinski@gmail.com> 0.2.0-1.20131206git786e86a
+- Initial package