summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-09-17 08:10:11 +0200
committerRemi Collet <remi@remirepo.net>2019-09-17 08:10:11 +0200
commitfd1bbdedf0f5722482d2cf438b6c88df085a0ea9 (patch)
treec3e0a1ced3d8811c335fb164eeee8617a5759897
parent80a050c456dd4c659fb9e5fa1f609944e1382e13 (diff)
- update to 1.9.18
- use git snapshot for sources
-rwxr-xr-xmakesrc.sh28
-rw-r--r--php-getid3.spec12
2 files changed, 37 insertions, 3 deletions
diff --git a/makesrc.sh b/makesrc.sh
new file mode 100755
index 0000000..7d752c6
--- /dev/null
+++ b/makesrc.sh
@@ -0,0 +1,28 @@
+#!/bin/bash
+
+NAME=$(basename $PWD)
+OWNER=$(sed -n '/^%global gh_owner/{s/.* //;p}' $NAME.spec)
+PROJECT=$(sed -n '/^%global gh_project/{s/.* //;p}' $NAME.spec)
+VERSION=$(sed -n '/^Version:/{s/.* //;p}' $NAME.spec)
+COMMIT=$(sed -n '/^%global gh_commit/{s/.* //;p}' $NAME.spec)
+SHORT=${COMMIT:0:7}
+
+echo -e "\nCreate git snapshot\nName=$NAME, Owner=$OWNER, Project=$PROJECT, Version=$VERSION, Commit=$COMMIT\n"
+
+echo "Cloning..."
+git clone https://github.com/$OWNER/$PROJECT.git $PROJECT-$COMMIT
+
+echo "Getting commit..."
+pushd $PROJECT-$COMMIT
+git checkout $COMMIT
+cp composer.json ../composer.json
+popd
+
+echo "Archiving..."
+tar czf $NAME-$VERSION-$SHORT.tgz --exclude-vcs $PROJECT-$COMMIT
+
+echo "Cleaning..."
+rm -rf $PROJECT-$COMMIT
+
+echo "Done."
+
diff --git a/php-getid3.spec b/php-getid3.spec
index 58a13cf..7f7be99 100644
--- a/php-getid3.spec
+++ b/php-getid3.spec
@@ -7,7 +7,7 @@
#
# Please preserve changelog entries
#
-%global gh_commit d2e45f2c4f75cc7443e158757ad2d678e318685d
+%global gh_commit 0723b77cafe9278618cfb6bc91b75e73705d3de8
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner JamesHeinrich
%global gh_project getID3
@@ -15,13 +15,14 @@
%global pk_project getid3
Name: php-%{pk_project}
-Version: 1.9.17
+Version: 1.9.18
Release: 1%{?dist}
Epoch: 1
License: LGPLv3+
Summary: The PHP media file parser
URL: https://www.getid3.org/
-Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{gh_short}.tar.gz
+Source0: %{name}-%{version}-%{gh_short}.tgz
+Source1: makesrc.sh
BuildArch: noarch
BuildRequires: php-fedora-autoloader-devel
@@ -91,6 +92,7 @@ exit ($ok ? 0 : 1);
%files
+# remirepo:1
%{!?_licensedir:%global license %%doc}
%license licenses license.txt
%doc changelog.txt dependencies.txt readme.txt structure.txt demos
@@ -99,6 +101,10 @@ exit ($ok ? 0 : 1);
%changelog
+* Tue Sep 17 2019 Remi Collet <remi@remirepo.net> - 1.9.18-1
+- update to 1.9.18
+- use git snapshot for sources
+
* Fri Feb 8 2019 Remi Collet <remi@remirepo.net> - 1.9.17-1
- update to 1.9.17
- add weak dependencies on suggested extension