summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-11-14 16:42:32 +0100
committerRemi Collet <remi@remirepo.net>2019-11-14 16:42:32 +0100
commit0ea6f6520a7ea7fba5dc49869dc7a5dbe121bee6 (patch)
treea6cdf9ebfc5b2dbaf4a66111ca41e09db0aff773
parent7e20bd945b6424969aa13f10c7782af7734840d4 (diff)
v1.0.9.1, synced from FedoraHEADmaster
-rw-r--r--.gitignore8
-rw-r--r--composer.json25
-rw-r--r--php-geshi.spec71
3 files changed, 87 insertions, 17 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..fc9aa8c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+clog
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..1dd3f7e
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,25 @@
+{
+ "name": "geshi/geshi",
+ "description": "Generic Syntax Highlighter",
+ "license": "GPL-2.0+",
+ "homepage": "http://qbnz.com/highlighter/",
+ "authors": [
+ {
+ "name": "Benny Baumann",
+ "email": "BenBE@geshi.org",
+ "homepage": "http://blog.benny-baumann.de/",
+ "role": "Developer"
+ }
+ ],
+ "support": {
+ "forum": "https://lists.sourceforge.net/lists/listinfo/geshi-users",
+ "irc": "irc://irc.freenode.org/geshi",
+ "issues": "https://sourceforge.net/p/geshi/feature-requests/"
+ },
+ "autoload": {
+ "classmap": ["src/geshi/", "src/geshi.php"]
+ },
+ "require-dev": {
+ "phpunit/phpunit": "^5.7 || ^6.5 || ^7.5 || ^8.2"
+ }
+}
diff --git a/php-geshi.spec b/php-geshi.spec
index 7153a21..501de3f 100644
--- a/php-geshi.spec
+++ b/php-geshi.spec
@@ -1,30 +1,49 @@
+# remirepo spec file for php-geshi, from:
+#
+# Fedora spec file for php-geshi
+#
+# License: MIT
+# http://opensource.org/licenses/MIT
+#
+
Name: php-geshi
-Version: 1.0.8.11
-Release: 1%{?dist}
+Version: 1.0.9.1
+Release: 2%{?dist}
Summary: Generic syntax highlighter
-Group: Development/Libraries
License: GPLv2+
-URL: http://qbnz.com/highlighter/
-Source0: http://downloads.sourceforge.net/geshi/GeSHi-%{version}.tar.bz2
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+URL: https://github.com/GeSHi/geshi-1.0
+Source0: %{url}/archive/v%{version}/GeSHi-%{version}.tar.gz
+
BuildArch: noarch
+# from composer.json "require-dev": {
+# "phpunit/phpunit": "^5.7 || ^6.5 || ^7.5 || ^8.2"
+%if 0%{?rhel} == 7
+%global phpunit %{_bindir}/phpunit
+BuildRequires: %{phpunit}
+%endif
+%if 0%{?fedora} >= 29 || 0%{?rhel} >= 8
+%global phpunit %{_bindir}/phpunit8
+BuildRequires: %{phpunit}
+%endif
+
Requires: php-mbstring
-Requires: php-date
Requires: php-pcre
+Provides: php-composer(geshi/geshi) = %{version}
%description
-GeSHi aims to be a simple but powerful highlighting class, with the following
-goals:
+GeSHi aims to be a simple but powerful highlighting class,
+with the following goals:
* Support for a wide range of popular languages
* Easy to add a new language for highlighting
* Highly customisable output formats
%prep
-%setup -q -n geshi
+%setup -q -n geshi-1.0-%{version}
+
find docs -type f -exec chmod a-x {} ';'
find . -type f -name "*.php" -exec chmod a-x {} ';'
@@ -34,24 +53,42 @@ find . -type f -name "*.php" -exec chmod a-x {} ';'
%install
-rm -rf $RPM_BUILD_ROOT
+mkdir -p %{buildroot}%{_datadir}/php/
+cd src
+cp -a geshi geshi.php %{buildroot}%{_datadir}/php/
-mkdir -p $RPM_BUILD_ROOT%{_datadir}/php/
-cp -a geshi geshi.php $RPM_BUILD_ROOT%{_datadir}/php/
-
-%clean
-rm -rf $RPM_BUILD_ROOT
+%if 0%{?phpunit:1}
+%check
+%{phpunit} --verbose
+%endif
%files
-%defattr(-,root,root,-)
+%{!?_licensedir:%global license %%doc}
+%license LICENSE
+%doc BUGS CHANGELOG README.md THANKS
%doc docs/* contrib/
+%doc composer.json
%{_datadir}/php/geshi.php
%{_datadir}/php/geshi
%changelog
+* Thu Nov 14 2019 Remi Collet <remi@remirepo.net> - 1.0.9.1-2
+- provides php-composer(geshi/geshi)
+- run upstream test suite
+
+* Mon Oct 21 2019 Artur Iwicki <fedora@svgames.pl> - 1.0.9.1-1
+- Update to version 1.0.9.1
+- Drop PHP 7.2 deprecation warning patch (merged upstream)
+
+* Fri Oct 04 2019 Xavier Bachelot <xavier@bachelot.org> - 1.0.9.0-1
+- Update to 1.0.9.0.
+- Clean up specfile.
+- Add upstream patch to fix a php 7.2 deprecation warning.
+ (Thanks Artur Iwicki)
+
* Wed Aug 22 2012 Remi Collet <RPMS@FamilleCollet.com> - 1.0.8.11-1
- Update to 1.0.8.11, CVE-2012-3521