summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2017-01-24 10:04:26 +0100
committerRemi Collet <fedora@famillecollet.com>2017-01-24 10:04:26 +0100
commit2435882714bfcb03958e2a601cae4b7267a936cd (patch)
treebbb4fb25d50050aaf0e938b067d1ca766e55dfbf
php-evenement: import from Fedora
-rw-r--r--0000-Fix-a-test-to-catch-TypeError-instead-of-Exception.patch29
-rw-r--r--php-evenement.spec84
2 files changed, 113 insertions, 0 deletions
diff --git a/0000-Fix-a-test-to-catch-TypeError-instead-of-Exception.patch b/0000-Fix-a-test-to-catch-TypeError-instead-of-Exception.patch
new file mode 100644
index 0000000..9c06cfa
--- /dev/null
+++ b/0000-Fix-a-test-to-catch-TypeError-instead-of-Exception.patch
@@ -0,0 +1,29 @@
+From ca430b3bff35f5fd7878a421b761fb6a7e408d75 Mon Sep 17 00:00:00 2001
+From: Randy Barlow <randy@electronsweatshop.com>
+Date: Sat, 14 Jan 2017 23:55:50 -0500
+Subject: [PATCH] Fix a test to catch TypeError instead of Exception.
+
+In PHP 7, TypeError is no longer an Exception but is an Error
+instead. This commit adjusts a test case to catch TypeError instead
+of Exception.
+
+Signed-off-by: Randy Barlow <randy@electronsweatshop.com>
+---
+ tests/Evenement/Tests/EventEmitterTest.php | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/tests/Evenement/Tests/EventEmitterTest.php b/tests/Evenement/Tests/EventEmitterTest.php
+index 7eeaa3d..64c5ffc 100644
+--- a/tests/Evenement/Tests/EventEmitterTest.php
++++ b/tests/Evenement/Tests/EventEmitterTest.php
+@@ -44,6 +44,7 @@ class EventEmitterTest extends \PHPUnit_Framework_TestCase
+ $this->emitter->on('foo', 'not a callable');
+ $this->fail();
+ } catch (\Exception $e) {
++ } catch (\TypeError $e) {
+ }
+ }
+
+--
+2.11.0
+
diff --git a/php-evenement.spec b/php-evenement.spec
new file mode 100644
index 0000000..9b686eb
--- /dev/null
+++ b/php-evenement.spec
@@ -0,0 +1,84 @@
+Name: php-evenement
+Version: 2.0.0
+Release: 3%{?dist}
+BuildArch: noarch
+
+License: MIT
+Summary: Événement is a very simple event dispatching library for PHP
+URL: https://github.com/igorw/evenement
+Source0: %{url}/archive/v%{version}.tar.gz
+# https://github.com/igorw/evenement/pull/33
+Patch0: 0000-Fix-a-test-to-catch-TypeError-instead-of-Exception.patch
+
+BuildRequires: phpunit
+BuildRequires: php-composer(fedora/autoloader)
+
+Requires: php(language) >= 5.4.0
+# This is for the autoloader
+Requires: php-composer(fedora/autoloader)
+
+Provides: php-composer(evenement/evenement) = %{version}
+
+
+%description
+Événement is a very simple event dispatching library for PHP.
+
+It has the same design goals as Silex and Pimple, to empower the user
+while staying concise and simple.
+
+It is very strongly inspired by the EventEmitter API found in node.js.
+
+Autoloader: %{_datadir}/php/Evenement/autoload.php
+
+
+%prep
+%setup -q -n evenement-%{version}
+
+%patch0 -p1
+
+: Create autoloader
+cat <<'AUTOLOAD' | tee src/Evenement/autoload.php
+<?php
+/**
+ * Autoloader for %{name} and its' dependencies
+ * (created by %{name}-%{version}-%{release}).
+ */
+require_once '%{_datadir}/php/Fedora/Autoloader/autoload.php';
+
+\Fedora\Autoloader\Autoload::addPsr4('Evenement\\', __DIR__);
+AUTOLOAD
+
+
+%install
+install -d -p -m 0755 %{buildroot}/%{_datadir}/php
+
+cp -a -r src/Evenement %{buildroot}/%{_datadir}/php/
+
+
+%check
+: Create tests autoloader
+cat <<'AUTOLOAD' | tee autoload.php
+<?php
+require_once '%{buildroot}%{_datadir}/php/Evenement/autoload.php';
+\Fedora\Autoloader\Autoload::addPsr4('Evenement\\Tests\\', __DIR__.'/tests/Evenement/Tests');
+AUTOLOAD
+
+phpunit --bootstrap autoload.php
+
+
+%files
+%license LICENSE
+%doc CHANGELOG.md composer.json README.md
+%{_datadir}/php/Evenement
+
+
+%changelog
+* Tue Jan 24 2017 Randy Barlow <bowlofeggs@fedoraproject.org> - 2.0.0-3
+- Update the patch to work for PHP 5 and PHP 7.
+
+* Tue Jan 17 2017 Shawn Iwinski <shawn@iwin.ski> - 2.0.0-2
+- Use php-composer(fedora/autoloader) instead of php-composer(symfony/class-loader)
+- Install to %%{_datadir}/php/Evenement instead of %%{_datadir}/php/Evenement/Evenement
+
+* Sat Jan 14 2017 Randy Barlow <bowlofeggs@fedoraproject.org> - 2.0.0-1
+- Initial release.