summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-03-24 07:54:12 +0100
committerRemi Collet <remi@remirepo.net>2021-03-24 07:54:12 +0100
commit6fb4def19db69af4e8fded3cafdf297b8e7ce89a (patch)
tree1232e1e253499dfd45fdc4fe519f8906bea3e676
parentd012d4e1d0d9644762991ec1fa3d0034c5ead82a (diff)
switch to phpunit9HEADmaster
-rw-r--r--Makefile2
-rw-r--r--php-evenement.spec18
2 files changed, 15 insertions, 5 deletions
diff --git a/Makefile b/Makefile
index 91b0fd5..13af741 100644
--- a/Makefile
+++ b/Makefile
@@ -1,4 +1,4 @@
SRCDIR := $(shell pwd)
NAME := $(shell basename $(SRCDIR))
-include ../../common/Makefile
+include ../../../common/Makefile
diff --git a/php-evenement.spec b/php-evenement.spec
index dc72f27..59a6455 100644
--- a/php-evenement.spec
+++ b/php-evenement.spec
@@ -26,7 +26,7 @@
Name: php-%{composer_project}
Epoch: 1
Version: %{github_version}
-Release: 1%{?github_release}%{?dist}
+Release: 5%{?github_release}%{?dist}
License: MIT
Summary: Événement is a very simple event dispatching library for PHP
@@ -38,7 +38,7 @@ BuildArch: noarch
%if %{with_tests}
## composer.json
BuildRequires: php(language) >= %{php_min_ver}
-BuildRequires: phpunit6
+BuildRequires: phpunit9
## phpcompatinfo (computed from version 3.0.1)
## <none>
## Autoloader
@@ -106,10 +106,17 @@ require_once '%{buildroot}%{_datadir}/php/Evenement/autoload.php';
]);
BOOTSTRAP
+: for phpunit8/9
+find tests -name \*.php \
+ -exec sed \
+ -e 's/function setUp()/function setUp():void/' \
+ -e 's/function tearDown()/function tearDown():void/' \
+ -i {} \;
+
: Upstream tests
RETURN_CODE=0
-PHPUNIT=$(which phpunit6)
-for PHP_EXEC in "" php71 php72 php73 php74; do
+PHPUNIT=$(which phpunit9)
+for PHP_EXEC in "" php73 php74 php80; do
if [ -z "$PHP_EXEC" ] || which $PHP_EXEC; then
$PHP_EXEC $PHPUNIT --verbose --bootstrap bootstrap.php \
|| RETURN_CODE=1
@@ -131,6 +138,9 @@ exit $RETURN_CODE
%changelog
+* Wed Mar 24 2021 Remi Collet <remi@remirepo.net> - 1:3.0.1-5
+- switch to phpunit9
+
* Sat Dec 14 2019 Shawn Iwinski <shawn@iwin.ski> - 1:3.0.1-1
- Update to 3.0.1 (RHBZ #1480022)
- Use PHPUnit 6