summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2012-06-10 07:18:41 +0200
committerRemi Collet <fedora@famillecollet.com>2012-06-10 07:18:41 +0200
commitb8ea798fe2524504529f24727b38b085b5cb406d (patch)
tree00c44899b14e548ecd5bf2bfa3dae813c1760f93
repo reorgHEADmaster
-rw-r--r--Makefile4
-rw-r--r--php-digitalsandwich-Phake.spec85
2 files changed, 89 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..1e65467
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../common/Makefile
+
diff --git a/php-digitalsandwich-Phake.spec b/php-digitalsandwich-Phake.spec
new file mode 100644
index 0000000..91cd0a2
--- /dev/null
+++ b/php-digitalsandwich-Phake.spec
@@ -0,0 +1,85 @@
+%{!?__pear: %{expand: %%global __pear %{_bindir}/pear}}
+%global pear_name Phake
+%global channel pear.digitalsandwich.com
+
+Name: php-digitalsandwich-Phake
+Version: 1.0.2
+Release: 1%{?dist}
+Summary: Phake is a PHP mocking framework that is based on Mockito
+
+Group: Development/Libraries
+License: BSD
+URL: http://digitalsandwich.com/
+Source0: http://pear.digitalsandwich.com/get/%{pear_name}-%{version}.tgz
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+
+BuildArch: noarch
+BuildRequires: php-pear >= 1:1.4.0
+BuildRequires: php-channel(%{channel})
+Requires: php-channel(%{channel})
+Requires: php-common >= 5.2.3
+Requires(post): %{__pear}
+Requires(postun): %{__pear}
+
+Provides: php-pear(%{channel}/%{pear_name}) = %{version}
+
+
+%description
+Phake is a framework for PHP that aims to provide mock objects, test doubles
+and method stubs.
+
+Phake was inspired by a lack of flexibility and ease of use in the current
+mocking frameworks combined with a recent experience with Mockito for Java.
+
+%prep
+%setup -q -c
+[ -f package2.xml ] || mv package.xml package2.xml
+%{__mv} package2.xml %{pear_name}-%{version}/%{name}.xml
+cd %{pear_name}-%{version}
+
+%build
+cd %{pear_name}-%{version}
+# Empty build section, most likely nothing required.
+
+%install
+cd %{pear_name}-%{version}
+%{__pear} install --nodeps --packagingroot $RPM_BUILD_ROOT %{name}.xml
+
+# Clean up unnecessary files
+%{__rm} -rf $RPM_BUILD_ROOT%{pear_phpdir}/.??*
+
+# Install XML package description
+%{__mkdir} -p $RPM_BUILD_ROOT%{pear_xmldir}
+%{__install} -pm 644 %{name}.xml $RPM_BUILD_ROOT%{pear_xmldir}
+
+
+%clean
+%{__rm} -rf $RPM_BUILD_ROOT
+
+
+%post
+%{__pear} install --nodeps --soft --force --register-only \
+ %{pear_xmldir}/%{name}.xml >/dev/null || :
+
+
+%postun
+if [ $1 -eq 0 ] ; then
+ %{__pear} uninstall --nodeps --ignore-errors --register-only \
+ %{channel}/%{pear_name} >/dev/null || :
+fi
+
+
+%files
+%defattr(-,root,root,-)
+%{pear_xmldir}/%{name}.xml
+%{pear_phpdir}/Phake
+%{pear_phpdir}/Phake.php
+
+%changelog
+* Sun May 27 2012 Remi Collet <RPMS@FamilleCollet.com> 1.0.2-1
+- rebuild for remi repository
+
+* Wed May 2 2012 Christof Damian <christof@damian.net> - 1.0.2-1
+- initial release (1.0.2)
+
+