summaryrefslogtreecommitdiffstats
path: root/php-deepend-Mockery.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-deepend-Mockery.spec')
-rw-r--r--php-deepend-Mockery.spec35
1 files changed, 25 insertions, 10 deletions
diff --git a/php-deepend-Mockery.spec b/php-deepend-Mockery.spec
index 818a9bd..f036c69 100644
--- a/php-deepend-Mockery.spec
+++ b/php-deepend-Mockery.spec
@@ -7,15 +7,15 @@
#
# Please preserve changelog entries
#
-%global gh_commit 6fdb61243844dc924071d3404bb23994ea0b6856
+%global gh_commit 4876fc0c7d9e5da49712554a35c94d84ed1e9ee5
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner padraic
%global gh_project mockery
%global with_tests 0%{!?_without_tests:1}
Name: php-deepend-Mockery
-Version: 0.9.9
-Release: 4%{?dist}
+Version: 0.9.10
+Release: 1%{?dist}
Summary: Mockery is a simple but flexible PHP mock object framework
Group: Development/Libraries
@@ -28,9 +28,6 @@ Source1: %{gh_project}-autoload.php
# Use our autoloader
Patch0: %{gh_project}-tests.patch
-# Upstream patch for 7.2
-Patch1: https://github.com/mockery/mockery/commit/b2f20b33942c2c84bc3b3b169098b448b3e66737.patch
-Patch2: https://patch-diff.githubusercontent.com/raw/mockery/mockery/pull/798.patch
BuildArch: noarch
%if %{with_tests}
@@ -38,7 +35,12 @@ BuildArch: noarch
# "phpunit/phpunit": "~4.0"
BuildRequires: php-composer(phpunit/phpunit) >= 4.0
BuildRequires: php(language) >= 5.3.2
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+BuildRequires: (php-composer(hamcrest/hamcrest-php) >= 1.1 with php-composer(hamcrest/hamcrest-php) < 2)
+%else
+BuildRequires: php-composer(hamcrest/hamcrest-php) < 2
BuildRequires: php-composer(hamcrest/hamcrest-php) >= 1.1
+%endif
# Autoloader
BuildRequires: php-composer(fedora/autoloader)
%endif
@@ -48,8 +50,12 @@ BuildRequires: php-composer(fedora/autoloader)
# "lib-pcre": ">=7.0",
# "hamcrest/hamcrest-php": "~1.1"
Requires: php(language) >= 5.3.2
-Requires: php-composer(hamcrest/hamcrest-php) >= 1.1
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+Requires: (php-composer(hamcrest/hamcrest-php) >= 1.1 with php-composer(hamcrest/hamcrest-php) < 2)
+%else
Requires: php-composer(hamcrest/hamcrest-php) < 2
+Requires: php-composer(hamcrest/hamcrest-php) >= 1.1
+%endif
# From phpcompatinfo report for version 0.9.7
Requires: php-pcre
Requires: php-spl
@@ -75,9 +81,11 @@ To use this library, you just have to add, in your project:
%setup -q -n %{gh_project}-%{gh_commit}
cp %{SOURCE1} library/Mockery/autoload.php
+
+mv library/helpers.php library/Mockery/
+sed -e 's:helpers.php:Mockery/helpers.php:' -i library/Mockery.php
+
%patch0 -p0 -b .rpm
-%patch1 -p1
-%patch2 -p1
%build
@@ -96,7 +104,7 @@ sed -e 's:@BUILD@:%{buildroot}/%{_datadir}/php:' -i tests/Bootstrap.php
: Run upstream test suite
ret=0
-for cmd in php php56 php70 php71 php72; do
+for cmd in php php70 php71 php72 php73; do
if which $cmd; then
$cmd %{_bindir}/phpunit --verbose || ret=1
fi
@@ -122,6 +130,13 @@ fi
%changelog
+* Wed Nov 21 2018 Remi Collet <remi@remirepo.net> - 0.9.10-1
+- update to 0.9.10
+
+* Mon Sep 10 2018 Remi Collet <remi@remirepo.net> - 0.9.9-7
+- use range dependencies
+- ensure hamcrest v1 is used, fix FTBFS
+
* Fri Oct 6 2017 Remi Collet <remi@remirepo.net> - 0.9.9-4
- add patches for PHP 7.2