summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-06-14 13:56:54 +0200
committerRemi Collet <fedora@famillecollet.com>2016-06-14 13:56:54 +0200
commit6c6fe8e5129613686cdf992b291ba44fa6826d61 (patch)
tree5de042a82d0166323dc51a453f25f952d8bfdedd
parentb522f93f6cfd1b0c655032dedfff557da90b7e89 (diff)
php-deepend-Mockery: 0.9.5
-rw-r--r--composer.json35
-rw-r--r--php-deepend-Mockery.spec7
2 files changed, 40 insertions, 2 deletions
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..d538f0d
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,35 @@
+{
+ "name": "mockery/mockery",
+ "description": "Mockery is a simple yet flexible PHP mock object framework for use in unit testing with PHPUnit, PHPSpec or any other testing framework. Its core goal is to offer a test double framework with a succinct API capable of clearly defining all possible object operations and interactions using a human readable Domain Specific Language (DSL). Designed as a drop in alternative to PHPUnit's phpunit-mock-objects library, Mockery is easy to integrate with PHPUnit and can operate alongside phpunit-mock-objects without the World ending.",
+ "keywords": ["library", "testing", "test", "stub", "mock", "mockery", "test double", "tdd", "bdd", "mock objects"],
+ "homepage": "http://github.com/padraic/mockery",
+ "license": "BSD-3-Clause",
+ "authors": [
+ {
+ "name": "Pádraic Brady",
+ "email": "padraic.brady@gmail.com",
+ "homepage": "http://blog.astrumfutura.com"
+ },
+ {
+ "name": "Dave Marshall",
+ "email": "dave.marshall@atstsolutions.co.uk",
+ "homepage": "http://davedevelopment.co.uk"
+ }
+ ],
+ "require": {
+ "php": ">=5.3.2",
+ "lib-pcre": ">=7.0",
+ "hamcrest/hamcrest-php": "~1.1"
+ },
+ "require-dev": {
+ "phpunit/phpunit": "~4.0"
+ },
+ "autoload": {
+ "psr-0": { "Mockery": "library/" }
+ },
+ "extra": {
+ "branch-alias": {
+ "dev-master": "0.9.x-dev"
+ }
+ }
+}
diff --git a/php-deepend-Mockery.spec b/php-deepend-Mockery.spec
index fc3e73d..dbcf3ef 100644
--- a/php-deepend-Mockery.spec
+++ b/php-deepend-Mockery.spec
@@ -7,14 +7,14 @@
#
# Please preserve changelog entries
#
-%global gh_commit 686f85fa5b3b079cc0157d7cd3e9adb97f0b41e1
+%global gh_commit 4db079511a283e5aba1b3c2fb19037c645e70fc2
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner padraic
%global gh_project mockery
%global with_tests 0%{!?_without_tests:1}
Name: php-deepend-Mockery
-Version: 0.9.3
+Version: 0.9.5
Release: 1%{?dist}
Summary: Mockery is a simple but flexible PHP mock object framework
@@ -120,6 +120,9 @@ fi
%changelog
+* Tue Jun 14 2016 Remi Collet <remi@fedoraproject.org> - 0.9.5-1
+- Update to 0.9.5
+
* Fri Oct 16 2015 Remi Collet <remi@fedoraproject.org> - 0.9.3-1
- downgrade to 0.9.3